Ankündigung

Einklappen

INFORMATION

Dieser Bereich ist für fertige Lösungen gedacht. Nutze bitte für Diskussionen die anderen Bereiche.
Mehr anzeigen
Weniger anzeigen

Funk Raum u. Heizkörperthermostate

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • #31
    ich bin unterwegs, kann auf die schnelle keinen Fehler finden, aber du kannst den Befehl den du versuchst über den MS zu senden auch mal einfach in den Browser tippen und schauen was passiert.

    also oben wo die adresse rein kommt in den browser

    http://ip-hm:port/config/xmlapi/stat...x&new_value=28

    z.b. 28 grad senden,---

    auf dem web interface von HM den Thermostat auf "manuell" gestellt ????

    Kommentar


    • wege91
      wege91 kommentierte
      Kommentar bearbeiten
      Hallo,
      also habe jetzt wieder Zeit gefunden weiter zu probieren...

      Wenn ich meinen eingetragenen Befehl:
      http://ip-hmort/config/xmlapi/statechange.cgi?ise_id=1760&new_value=<v.2>

      eingebe kommt eine Fehermeldung:
      <?xml version="1.0" encoding="ISO-8859-1" ?><result><changed id="1760" new_value="<v.2>" /></result>
      ---------------------------------------------------------------------------------------------------------------------------------^

      gebe ich den Befehl mit einem Wert ein:
      http://ip-hm:port/config/xmlapi/stat...0&new_value=23

      so wird der Wert an die CCU weitergegeben und wie gewünscht geändert...

      Mein Fehler wird also denke ich an den Befehl nach "new_value= XXXXX" liegen.

      Ich habe bereits probiert
      <v>
      <v..2>

      jeweils keine Änderung....
      Wie könnte ich den Befehl noch abändern?

      mfg!

  • #32
    Ich....noch mal!

    Habe es nun zum laufen bekommen.

    Auch wenn ich gefühlt nichts mehr geändert habe...

    Eingetragener Befehl lautet nun:

    /config/xmlapi/statechange.cgi?ise_id=1706&new_value=<v>

    Vielen Dank für die Hilfe!!

    Kommentar


    • #33
      Hallo liebe Smarthome Kollegen,

      ich stehe gerade am Anfang der Anbindung von Homematic (RT & HT) <=> Loxberry <=> Loxone.

      Könnte mir hier jemand Hilfestellung geben?

      Aktuell habe ich versucht über das Loxmatic Plugin meine Anforderungen zu erfüllen, leider geht noch nicht so viel.

      Bisher kann ich nur die Istwerte einlesen, vom RT (temp & feuchte) und vom HT (temp).

      Falls jemand Zeit und Lust hat mir hierbei zu helfen würde ich mich sehr freuen.

      Am besten per PN an mich (Skype/Teamview oder Telefon für rückfragen etc.).

      Als Benefit würde ich dann eine Anleitung von Grund auf zur Verfügung stellen mit den oben genannten Anbindungen.

      (BTW: ich bin selbst Softwareentwickler und bringe gewisses Knowhow mit )

      Gruß

      David

      Kommentar


      • #34
        [gelöscht, weil nicht mehr benötigt.]

        Kommentar


        • #35
          Hallo in die Runde,
          die Verwendung von Homematic Thermostaten klappt ja soweit, und wird mit Hilfe von Raspberrymatic/nodered immer einfacher und unkomplizierter.

          Verwendet ihr denn auch den Klima-Kontroller?
          wir haben hier eine alte Ölheizung..die Steuerung ist insoweit smart, das ich auf Tag/Nacht Temperatur über Loxone umstellen kann.

          Ich überlege meine Config nochmal zu ändern ... eventuell die Nachtemperatur (Kesseltemp) soweit runter drehen, dass der Brenner garnicht mehr anspringt. Das wäre dann quasi keine Anforderung des Klimakontrollers...

          Was haltet ihr davon?


          Kommentar


          • #36
            Hallo zusammen,

            ich lese mich hier auch gerade in das Thema Loxone und Homematic Heizkörperthermostate ein. Bin noch Neuling auf dem Gebiet des Rasperry. Habe mir ein RPi3 mit Funkplatine zugelegt und bin aktuell am testen. Anfangs habe ich es mit Loxberry versucht, dort kam ich soweit das ich die Temperaturen vom ersten Test Thermostat in Loxone angezeigt bekommen habe. Bin dann allerdings bei der Übertragung von Loxone zum Thermostat gescheitert (nach 3 Abenden).
            Jetzt habe ich mal Raspberrymatic installiert und mit Nodered herum experimentiert. Gibt es hierzu denn einfache Anleitungen die mir weiterhelfen könnten ? Irgendwie komme ich da auch nicht so recht weiter...

            Kann mir einer von euch Profis vielleicht eine kleine Hilfestellung geben ?

            Für die Tipps wäre ich sehr dankbar !

            Viele Grüße
            Flo

            Update: Habe gestern einen normalen Schalter konfiguriert der bidirektional auf Anhieb funktioniert hat...
            Aber wie verhält sich das mit den Statuswerten der Temperaturen?
            Zuletzt geändert von CTROlum; In den letzten 4 Wochen.

            Kommentar


            • #37
              Ich habs jetzt nicht ausprobiert weil meine Raumthermostate alle über die Zentrale direkt eingebunden sind, wie in der Beschreibung ganz vorne, aber wie schon erwähnt wird die Homematic Einbindung durch Red-Node sehr einfach, es gibt nur einen kleinen Nachteil.

              In red-Node kannst du nur Datenpunkte vom Miniserver auswählen die dort "visualisiert" sind,- d.h du musst Deine VI am IRR Baustein "visualisieren" damit du sie später in Red-node anwählen kannst.

              du brauchst in dem Fall je einen VI für Isttemperatur und einen für Solltemperatur, sowie einen VO für Solltemperatur,- anstelle der Abfragen von der ise_id wie ganz vorne beschrieben, wählst du die Punkte im Node an

              Ich nehme für alle diese Datenpunkte die natürlich nicht in der Visu brauche einen eigenen ungenutzen Raum/Kategorie und lege die dort ab,--

              also z.b Serverraum in dem Fall, dann klickst du Dir diese Punkte so zusammen:

              Klicke auf die Grafik für eine vergrößerte Ansicht  Name: Hm-rednode.JPG Ansichten: 0 Größe: 37,2 KB ID: 272362
              Zuletzt geändert von Lenardo; In den letzten 4 Wochen.

              Kommentar


              • CTROlum
                CTROlum kommentierte
                Kommentar bearbeiten
                Hi,

                danke für die schnelle Rückmeldung und für die Tipps ! Ich werde mein Glück versuchen und melde mich dann wieder...

            • #38
              Servus,

              also für mich war das einfachste eine raspimatic aufzusetzen und dort das Redmatic Plugin, darüber ist die Anbindung dann mega gut.

              Ich habe aktuell noch das Problem die Aktoren HT und WT sinnvoll mit dem Intelligenten Raumregler zu verbinden.

              also Sollwert von HM —> Raumregler—> HM war mein Plan damit ich quasi am Aktor einen Sollwert einstellen zu können oder über loxone das Automatik Programm. Leider schaukelt Sicht das dann alles hoch oder runter von dem Sollwert, das der Ausgang von dem Loxone Baustein eine Hysterese von 0,5 als min hat.

              Das Problem konnte ich bisher nicht lösen.

              Kommentar


              • #39
                du musst mit den HT und dem WT eine Gruppe bilden, das die wissen sie gehören zusammen

                Kommentar


                • #40
                  Zitat von ing-schick Beitrag anzeigen
                  Servus,

                  also für mich war das einfachste eine raspimatic aufzusetzen und dort das Redmatic Plugin, darüber ist die Anbindung dann mega gut.

                  Ich habe aktuell noch das Problem die Aktoren HT und WT sinnvoll mit dem Intelligenten Raumregler zu verbinden.

                  also Sollwert von HM —> Raumregler—> HM war mein Plan damit ich quasi am Aktor einen Sollwert einstellen zu können oder über loxone das Automatik Programm. Leider schaukelt Sicht das dann alles hoch oder runter von dem Sollwert, das der Ausgang von dem Loxone Baustein eine Hysterese von 0,5 als min hat.

                  Das Problem konnte ich bisher nicht lösen.
                  Hallo zusammen, dazu habe ich in Beitrag 19 mal meine Lösung gezeigt. Sollwerte können am Thermostat, am Wandthermostat und über Loxone geändert werden.
                  Wenn am Thermostat oder Wandthermostat gedreht wird, geht der Raumregler für die eingestellt Zeit in den manuellen Heizmodus.
                  Ansonsten läuft der Regler auf "automatisch Heizen" und gibt die Sollwerte eben an HM weiter..

                  https://www.loxforum.com/forum/faqs-tutorials-howto-s/6578-funk-raum-u-heizkörperthermostate?p=182350#post182350

                  Kommentar


                  • #41
                    Hallo,

                    ich kann nun die Soll- und die Ist-Temperaturen in meiner Loxone App live sehen, auch wenn ich am Thermostat die Temperatur ändere. Nur lässt sich die Solltemperatur von Loxone aus nicht verstellen. Wenn ich die IRR verwende, springt die Temperatur immer wieder zurück auf die von "HM" vorgegebene. Der Thermostat steht aber auf manuell. Wenn ich die IRR Gen1 verwende ändert sich auch nichts. Ich habe in Nodered die IRR ausgewählt und Set_Temerature genommen. Das sollte doch passen. Benötige ich noch zusätzlich einen VO an dem IRR-Baustein ? Wenn ja, was muß da als Adresse angegeben werden ?Klicke auf die Grafik für eine vergrößerte Ansicht

Name: 2020-11-01 12_12_45-Window.png
Ansichten: 104
Größe: 508,3 KB
ID: 272886

                    Kommentar


                    • Lenardo
                      Lenardo kommentierte
                      Kommentar bearbeiten
                      wie ich dir schon per PM geschrieben habe brauchst du einen VQ am Ausgang AQt der IRR (ohne eine Adresse einzutragen !), diesen musst du natürlich auch visualisieren damit du diesen im red-node auch auswählen kannst.
                      den wählst du dann im red-node als Loxone In Node aus und schickst in dann auf den HM node des RT mit dem datenpunkt set_temperatur, so wie oben abgebildet

                    • CTROlum
                      CTROlum kommentierte
                      Kommentar bearbeiten
                      Alles klar, danke für die Info !

                  • #42
                    Habe es jetzt nochmals getestet, beim VO am Ausgang AQt muß ich einen Befehl erstellen den ich dann mit dem Ausgang verbinde. Wenn ich diesen aber auswähle ändert sich trotzdem nichts bei der Soll-Temp. Sorry für die warscheinlich dämlichen Fragen eines Newbies
                    Angehängte Dateien

                    Kommentar


                    • #43
                      es gibt keine dämmlichen Fragen, das Board ist dafür da das jemanden geholfen wird.

                      Ich habs grad gestestet, hab persönlich noch die alte Lösung weils läuft, neu würd ichs aber auch mit red-node machen.

                      du musst den "Verknüpfungspartner Heizungsthermostat" 2 auswählen, nur der hat eigentlich die set_temp knoten, bei mir läufts, dann wie gedacht, egal ob ich in Loxone die soll temp änder oder am Wandthermostat es wird überall aktualisiert und ist überall gleich

                      Klicke auf die Grafik für eine vergrößerte Ansicht

Name: hm2.JPG
Ansichten: 83
Größe: 53,3 KB
ID: 272948

                      Kommentar


                      • #44
                        soweit ich das sehe das du ehe alles richtig gemacht, du verwendest aber den HK Thermostat mit Datenpunkt 4, das sollte aber auch gehen, kannst du mal den VQ eindeutiger bezeichnen den hast du vielleicht irgendwo doppelt zur Auswahl?

                        Kommentar


                        • CTROlum
                          CTROlum kommentierte
                          Kommentar bearbeiten
                          Na dann weiß ich auch nicht mehr weiter 😂🙈

                          Komischer Weise springt die Temperatur bei der IRR Gen1 immer wieder auf die von HM ausgegebene Temp zurück. Gibt’s da von HM Seite aus noch irgendetwas zu deaktivieren ? Habe nur über raspberrymatic den HK Thermostat angelernt und den Rest dann über Node-RED...
                          Zuletzt geändert von CTROlum; In den letzten 4 Wochen.

                        • Lenardo
                          Lenardo kommentierte
                          Kommentar bearbeiten
                          hast du sicher beim HT den Manu Modus und nicht den Auto Modus ?

                        • CTROlum
                          CTROlum kommentierte
                          Kommentar bearbeiten
                          Mahlzeit zusammen ! Vielen Dank nochmal für eure Hilfe. Ich habs hinbekommen. Im Prinzip war alles richtig... Habe meinen HK-Thermostat nochmals auf Werkseinstellung zurück gesetzt und neu verbunden und siehe da, es geht alles wie gewünscht ! Irgendwo gab es dort zwischen Raspi und dem Funkthermostat ein Problem
                      Lädt...
                      X