Ankündigung

Einklappen
Keine Ankündigung bisher.

Anbindung von Lüftungsanlage Enervent Pingvin

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Strauchi78
    kommentierte 's Antwort
    hab ich auch mit 2 Modbus Extension gelöst da bei mir (wie bei dir) die Einstellungen der Energiezähler nicht mit der Lüftung kompatibel sind

  • m.haunschmid
    kommentierte 's Antwort
    Bei mir ist 8n1 eingestellt, also 8 Datenbits, keine Parität und 1 Stopbit. Aber eine 2te Extension wäre fast ein wenig übertrieben. Wäre ein Loxberry mit dem Modbus RTU zu Tcp Plugin nichts für dich?

  • maxw
    antwortet
    So, das Problem ist gefunden und leider ziemlich doof...

    In der Enervent Doku steht zu Modbbus

    Specification of Modbus:
    • Modbus address 1 (default)
    • Communication standard RS485
    • Modbus traffic via Modbus connector X26 of controller card
    • Speed 9600, 19200 or 115200 bps
    • 8 bit
    • No parity or parity.
    Problem ist, das mit No parity or parity funktioniert zumindest bei mir nicht.

    Es geht leider nur no parity mit einem Stop Bit - was aber wieder die Loxone Modbus Energiezähler (habe 2 davon, einen für Gesamtverbrauch und einen für die Wärmepumpe extra damit ich mir die AZ (habe auch Wärmemengenzähler) errechnen kann) nicht können, die können Even/Odd Parity und 1 Stop Bit oder ohne Parity und 2 Stop Bits.

    Das wird wohl auf eine 2. Modbus Extensioin hinauslaufen, blöd aber auch.

    m.haunschmid was hast denn du bei der Parity eingestellt?


    Liebe Grüße, Max

    PS: Die AZ der WP (mit 2 x 120m Bohrung) ist die letzten 3 Monate immer ganz knapp über 5

    Einen Kommentar schreiben:


  • maxw
    kommentierte 's Antwort
    Danke, werde nochmals alles prüfen und gegen deine Umsetzung querchecken.
    Ich habe zwar eine andere Platine, aber prinzipiell den selben Anschluss mit Masse A B und 14V (bei dir steht da 12V)
    Wesentliche Informationen für mich, du speist da KEINE 12V ein, so wie ich keine 14V einspeise.
    Zuletzt geändert von maxw; 14.Mr.2019, 09:00.

  • m.haunschmid
    antwortet
    So entschuldige für die lange Wartezeit.
    Ich habe bei mir nur A+ und B- aufgelegt.
    Im Anhang habe ich ein paar Bilder, wie das Ganze bei mir aussieht. Vielleicht hilfts ja, dem Fehler auf die Schliche zu kommen.
    Was sicher auch empfehlenswerte wäre, ist die Verbindung selbst mal mit einem Programm wie "qModMaster" (kostenlos. "https://sourceforge.net/projects/qmodmaster/") zu testen.
    Angehängte Dateien

    Einen Kommentar schreiben:


  • maxw
    antwortet
    m.haunschmid bei dir geht ja alles anscheinend, hast du 14V eingespeist oder nicht?

    Einen Kommentar schreiben:


  • maxw
    antwortet
    So, leider bekomme ich über den Modbus von der Enervent keinerlei Daten. Von 2 anderen Geräten aber schon.

    Ich habe alles probiert und überprüft, Mobbus Adresse stimmt (10 habe ich eingestellt, 1 und 2 sind schon verwendet) Baudrate stimmt (19200) ich habe es mit und ohne Terminierung versucht, mit und ohne GND.

    Das einzige was ich noch nicht probiert habe, ist da ein 14V Versorgung anzulegen, weil weiter oben gesagt wurde, das soll/darf man nicht!?

    Muss das Ding jetzt versorgt werden oder nicht? Kann da jemand von euch mal bitte nachsehen?

    DANKE!

    Liebe Grüße, Max

    Einen Kommentar schreiben:


  • maxw
    kommentierte 's Antwort
    Ich meinte ob die Enervent schon Terminiert oder nicht, aber wahrscheinlich nicht.

  • Strauchi78
    kommentierte 's Antwort
    naja schon:
    https://www.loxone.com/dede/wp-conte...-Extension.pdf

  • maxw
    antwortet
    Und noch eine Frage zum Anschluss. Muss man da was terminieren? Abschlusswiderstand? In der Doku finde ich nix.

    Einen Kommentar schreiben:


  • m.haunschmid
    kommentierte 's Antwort
    Hallo Strauchi, hab mittlerweile alles über das Loxberry Modbus Plugin und einem USB Modbus Adapter am Loxberry realisiert.

  • maxw
    kommentierte 's Antwort
    Danke, dachte ich mir doch...

  • Strauchi78
    kommentierte 's Antwort
    Anzuschließen sind: A, B und GND
    Bloß keine Fremdspannung an die Enervent-Platine, die ist ja schon versorgt.

  • maxw
    antwortet
    Eine Frage noch zum Anschluss der Modbus Extension an den Enervent Modbus.
    Habt ihr nur die beiden Modbus Leitungen A und B angeschlossen an der Enervent? Oder versorgt ihr auch die 14 V auf der Enervent Platine? Mein Installteur meinte das muss man tun, ich glaube ihm aber nicht so recht, kommt mir komisch vor.

    Einen Kommentar schreiben:


  • Strauchi78
    antwortet
    m.haunschmid, maxw:
    sorry dass ich erst heute antworte. Ich habe erst jetzt gesehen dass ihr mir geantwortet habt.
    Also ich verwende die Modbus Extension und das klappt sehr gut, nach wie vor.
    Einen rasp setze ich wirklich nur ein wenn kein konventioneller Weg möglich ist per Loxone. Ist ja wieder ein zusätzliches Gerät was 24/7 Strom braucht und kaputt gehen kann.
    Anleitung, hmm.. Ist dein Thema noch aktuell m.haunschmid?

    Einen Kommentar schreiben:

Lädt...
X