Ankündigung

Einklappen
Keine Ankündigung bisher.

Integration of Shelly1 & Garador

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Integration of Shelly1 & Garador

    Good morning.
    I've connected a Shelly1 to my Garador (same as a Promatic) control head as per the attached diagram. The Shelly is set up as a momentary switch, Power on, Auto Off set to 1s. The Shelly connects to my LAN and I can access its API.
    I've created a Virtual Input, push button, connected to a Virtual Output to control the door. Virtual Output Command with the Shelly IP details (admin/password etc).
    Initially the door can be operated from Loxone but then fails and it loses connection to the LAN.
    I suspect the text in the Output Command is incorrect (/relay/0?turn=on and /relay/0?turn=off) is causing the problem,. Quite why it causes the Shelly to disconnect from the LAN I don't know.
    I think I might need to use one of the commands at this link?
    https://www.loxwiki.eu/display/LOX/Shelly+per+HTTP

    Grateful for any help,. thank you.






  • #2
    Virtual output:
    http://user: passwort@192.168.xxx.xxx

    virtual output command:
    /relay/0?turn=on
    /relay/0?turn=off

    should work.

    If the commands were incorrect, why should this affect the WiFi connection?
    Are you sure, the WiFi is stable?
    Did you manage to give always the same fixed IP address to you shelly device?

    Can you still access the Webversion of your shelly or does it really disconnect from you network? Please ensure using 2,4GHz WiFi as shelly does not support 5GHz
    Haus: Bj 1959, gekauft 2011, totale Entkernung, Dachausbau, Erweiterung & Vergrößerung: Start: 2014, Ende: 2050
    Loxone: 1x MS, 5 x Ext., 3 x Relay Ext., 1 x Dimmer Ext., 2 x 1-wire Ext., 1 x DMX Ext. 1 x TREE Ext. mehr kommt noch
    Licht: DMX LED Beleuchtung (24V), MW HLG Serie und eldoled Dimmer
    Heizung: Brötje WBS 22F, OG Heizkörper und FuBoHeizung über RTL, EG FuBoHeizung

    Kommentar


    • #3
      For Shelly you need only the on command and use the Shelly automatet off function e.g. after 2 seconds...like a impulse

      Kommentar


      • #4
        if checked, then uncheck the settings "Enable AP Roaming" under Internet & Security settings.

        That setting changes between Access Points with best available signal strengths, if you are using several ones. I tried that feature but had a lot of conectivity issues.
        Haus: Bj 1959, gekauft 2011, totale Entkernung, Dachausbau, Erweiterung & Vergrößerung: Start: 2014, Ende: 2050
        Loxone: 1x MS, 5 x Ext., 3 x Relay Ext., 1 x Dimmer Ext., 2 x 1-wire Ext., 1 x DMX Ext. 1 x TREE Ext. mehr kommt noch
        Licht: DMX LED Beleuchtung (24V), MW HLG Serie und eldoled Dimmer
        Heizung: Brötje WBS 22F, OG Heizkörper und FuBoHeizung über RTL, EG FuBoHeizung

        Kommentar


        • #5
          Zitat von PeterH Beitrag anzeigen
          The Shelly is set up as a momentary switch, Power on, Auto Off set to 1s. The Shelly connects to my LAN and I can access its API.
          Why did you set up as momentary switch?
          In your own attachment is written (in German) to use "detached" switch.

          Are you also using a physical switch with you shelly device to control your garage or is it "only" via Loxone?

          Haus: Bj 1959, gekauft 2011, totale Entkernung, Dachausbau, Erweiterung & Vergrößerung: Start: 2014, Ende: 2050
          Loxone: 1x MS, 5 x Ext., 3 x Relay Ext., 1 x Dimmer Ext., 2 x 1-wire Ext., 1 x DMX Ext. 1 x TREE Ext. mehr kommt noch
          Licht: DMX LED Beleuchtung (24V), MW HLG Serie und eldoled Dimmer
          Heizung: Brötje WBS 22F, OG Heizkörper und FuBoHeizung über RTL, EG FuBoHeizung

          Kommentar


          • #6
            Wow, lots of questions - thank you for the replies.
            @Simon
            Outputs commands and connection to the Shelly works initially, I can move the door. Then fails.
            Why it affects the Wifi connection I have no idea. Actually I think it's affecting the power supply and perhaps cycling the relay. It disconnects from the network and cannot be accessed via the API. When I remove the wiring loom from the control head and reconnect, the Shelly relay can be heard clicking continuously.
            Wifi is stable, I have other Shellys controlling lights (in the garage) and they work ok.
            I can only then access the Shelly by wiring to a 240V supply which then seems to 'reset'
            Videos on the subject recommend setting up as a momentary switch to mimic the remote control which is just a push button,
            There is no physical switch just the remote and Loxone,

            @eisenKarl
            I'll remove the off command in Loxone

            @Simon
            The Shelly is no more than 3m from a Wifi AP and have unchecked allow roaming.

            Kommentar


            • #7
              Quick Update: I've connected the Shelly to a 240v supply and I can access its API again. Reconnected to the control head, removed the 'relay turn off' command from Loxone and its working again. Will see if it continues to work.

              Update: Failed again after a successful open and close. Can hear the relay continuously clicking.

              Update: Have changed the Shelly to a 'detached switch' and Power on Default mode to 'switch' Now seems to be more stable. Simon, good spot regarding the "In your own attachment is written (in German) to use "detached" switch.

              Thank you for the help, it's appreciated
              Zuletzt geändert von PeterH; In den letzten 4 Wochen.

              Kommentar


              • #8
                Good morning, I'm sorry to say the Garador/Shelly/Loxone integration has failed again. This is common to two doors and two Shellys.
                Initially, the Shelly / Loxone integration works and the Shelly API is addressable via its API. However, if using the remote to open or close the door and then via Loxone, the problems start. The Shelly becomes unresponsive and unable to access via its IP. Whilst I thought previously it was losing its internet connectivity it (they) are losing power despite the Control head still supplying the 12-24v.
                It seems this is something to do with the Shelly / Loxone interface, with Loxone causing the Shelly to stop working?
                Maybe a 'toggle' command in the Loxone Virtual Output may help?
                In any event, I'll give it a go.

                Kommentar


                • #9
                  A http command usually doesn’t take a Shelly offline.
                  I don’t know what the usage is, but possibly you have an electrical wiring mismatch somewhere.

                  LoxBerry/Plugin Support: Wenn du einen Begriff in meiner Antwort nicht auf Anhieb verstehst, bitte nicht gleich rückfragen, sondern erst die Suche im LoxWiki und bei Google bemühen.
                  PN/PM: Ich bevorzuge die Beantwortung von Fragen in öffentlichen Threads, wo andere mithelfen und mitprofitieren können. Herzlichen Dank!

                  Kommentar


                  • #10
                    The way I had set this up in Loxone was to create a Virtual Input set up as a radio button directly linked to the virtual output. initially all worked but after a few successful runs I could hear the relay constantly clicking / engaging with the device offline and unable to access its API, via its IP address.

                    I have now removed the VI and inserted a push button with a 1 sec duration (although I suspect the duration is probably not that important). This seems to work (for now).

                    The problem is for sure the Loxone / Shelly relationship, but I don't know enough about Shellies to understand why the VI set up has created this problem.

                    Kommentar


                    • #11
                      This is getting really frustrating!
                      As posted earlier today, door operated via Loxone, up, down, no issues. Left it alone for a few hours, checked its API via my PC, all ok. Tried to open via Loxone, nothing and unable to access via its IP. Think I'm running out of options?

                      Kommentar

                      Lädt...
                      X