Ankündigung

Einklappen

PLUGINS

Bitte im Titel immer zuerst den Namen des Plugin hinschreiben
Mehr anzeigen
Weniger anzeigen

Plugin: CamStream4Lox - (fast) JEDE Kamera in den Türsteuerungsbaustein

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Plugin: CamStream4Lox - (fast) JEDE Kamera in den Türsteuerungsbaustein

    Hallo zusammen,

    es gibt ein neues Plugin "CamStream4Lox" als BETA, welches beliebige Streams von Kameras in MJPEG-Streams für den Türsteuerungsbaustein umwandelt. Dazu wird ffmpeg / ffserver verwendet. Das Plugin kann aktuell 10 Kameras verwalten, wobei begrenzend die Hardware des RaspBerry ist!

    Ich habe auf einem Raspi2 testweise ein MJPEG-Stream einer HikVision-Kamera (lässt nur einen Benutzer zur Zeit zu) mit dem Plugin re-streamt, sodass mehrere Clients auf den Stream zugreifen können. CPU-Last war ca. 15%.

    Ein H.264 Stream ebenfalls einer Hikvision-Kamera (640x480, 10 Frames, 2048 Bit Varianble) verursacht hingegen bereits 25% CPU-Last.

    Generell muss der Stream der Kamera möglichst identisch zu den Optionen im Plugin eingestellt werden (gleiche Framerate, gleiche Größe, gleiche Bitrate), damit die Konvertierung möglichst wenig zu tun hat! Zudem die Bildqualität in der Kamera so klein wie möglich einstellen (was gerade noch akzeptabel ist), damit ebenfalls die Last reduziert wird. Beobachtet die CPU-Last nach Aktivieren des Plugins im "MyLoxBerry"-Widget!

    Da bei mir des öfteren mal die Streams von den Cams abbrechen (insbesondere die Kamera, die per WLAN eingebunden ist), bietet das Plugin ein Watchdog, was die Streams bzw. FFServer neu startet, falls ein Stream nicht mehr erreichbar ist.

    Zudem wird auch gleich ein Picture für die Klingel aus dem Stream extrahiert. So kann man auch hier eine kleinere Auflösung verwenden, um das Nachladen der Bilder im Türsteuerungsbaustein zu beschleunigen.

    Das Plugin speichert den Stream permanent in einer temporären Datei - also unbedingt einen USB-Datenträger zum Speichern der temporären Dateien verwenden! Ansonsten schrottet ihr Euch eure SD-Karte!

    Doku gibt es noch nicht, aber das meiste dürfte selbsterklärend sein. Wer mag kann schon einmal testen (BETA!). Download unter:

    https://github.com/mschlenstedt/LoxB...ive/master.zip
    Zuletzt geändert von Prof.Mobilux; 09.Aug.2018, 06:00.
    Spenden für LoxBerry Test-Equipment? http://www.paypal.me/loxberry

    LoxBerry: https://www.loxwiki.eu/display/LOXBERRY/LoxBerry

    LoxBerry Youtube Tutorials:
    https://www.youtube.com/c/LoxBerryTutorials

  • #2
    Hi und gleich vorweg: vielen Dank für die Arbeit, die du dir machst.
    Ist eines, bzw. eigentlich mein einziges Wunschplugin in der Liste.
    Im Wiki hab ich eine Anleitung hierfür hinterlassen wie mans auf der Console zum Laufen bringt. Das funkt auf meinem VM Loxberry wunderbar.
    Leider fehlen mir die Skills für die Plugin Erstellung, deshalb jedenfalls vielen Dank!

    Ich teste es gerade auf meinem VM Loxberry, aktuelle Version und stelle folgendes Verhalten fest:
    - ich wähle Start FFserver für den Autostart
    - HTTP Port 8888 (da läuft/lief meine cmdline installation auch)
    - Temp.Path hab ich so belassen wie voreingestellt
    - 1. Streaming Cam
    -- Active Cam Stream On
    -- Cam Stream URL rtsp://xx.xx.xx.xx:7447/5axxxxxxxxxxxde2_2 -> ist der 640x360 RTSP Stream meiner Ubiquiti G3 Cam, den ich auch in der cmdline Variante verwende

    Rest unverändert. Wenn ich Save klicke schreibt er mir am oberen Bildschirmrand folgende Meldung: (ohne, dass ich deute könnte wohin die Meldung gehört)
    "Bitte wählen Sie einen gültigen Wert. Die zwei nähesten gültigen Werte sind 3072 und 4096."

    Sobald ich dann ganz oben auf "Start" klicke, macht die Seite einen Reset und alles ist wieder weg.
    Port hab ich schon auf 8090 belassen - keine Auswirkung

    Any Idea?

    LG

    edit: im Log ist nichts auffälliges zu finden jedoch, wenn ich mir die ffserver.conf ansehe ist die leer. Kanns sein, dass es da an Schreibrechten scheitert?
    edit 2: dürfte sowas in der art sein. ich habe den inhalt meiner funktionieren ffserver.conf in die o.a. ffserver.conf kopiert und siehe da: das plugin lässt sich starten.
    der Fehler kommt übrigens sobald man irgendeine Änderung vornimmt und speichert. also auch, wenn ich nur wähle "Start FFserver".
    Die Kommandos start/stop/restart etc. funktionieren.
    edit 3: die Meldung bezieht sich scheinbar auf die Bit Rate. die ist voreinstellt auf 404 (vermutlich ein Darstellungsthema). Wenn ich den Schieber ganz nach rechts schiebe kommt keine Meldung mehr. Config schreibt er aber trotzdem nicht beim Speichern. Und sobald ich den Server starten will gibts wieder den Page-reset.
    Zuletzt geändert von hstohl; 10.Aug.2018, 14:51.

    Kommentar


    • #3
      Ja, ich weiß woran es liegt :-) Moment...
      Spenden für LoxBerry Test-Equipment? http://www.paypal.me/loxberry

      LoxBerry: https://www.loxwiki.eu/display/LOXBERRY/LoxBerry

      LoxBerry Youtube Tutorials:
      https://www.youtube.com/c/LoxBerryTutorials

      Kommentar


      • #4
        So, bitte Plugin noch einmal komplett deinstallieren und dann nochmal neu downloaden und installieren (kein upgrade durchführen!). Dann sollte es gehen.

        Deine Anleitung im Wiki war übrigens Basis für das Plugin :-)
        Spenden für LoxBerry Test-Equipment? http://www.paypal.me/loxberry

        LoxBerry: https://www.loxwiki.eu/display/LOXBERRY/LoxBerry

        LoxBerry Youtube Tutorials:
        https://www.youtube.com/c/LoxBerryTutorials

        Kommentar


        • hstohl
          hstohl kommentierte
          Kommentar bearbeiten
          Vom Feinsten! Funktioniert wunderbar und ich freu mich, dass eine meiner Anleitungen mal gebraucht werden konnte :-)
          Irgendwann werde ich hoffentlich die Zeit finden mich mit der Erstellung von Plugins zu beschäftigen. Ist halt komplettes Neuland für mich.
          Einbindung der Homebridge wäre nämlich auch interessant.

          Verbesserungsvorschläge zum Plugin meinerseits:
          Irgendwo vermerken, wie der Stream heißt, den man in der Loxone Config eintragen muss. Sollte zwar jeder relativ schnell von alleine draufkommen, wenn man sich aber noch nie mit der Thematik beschäftigt hat, wirfts ev. Fragen auf.
          Weiters würd ich statt (oder ev. zusätzlich) der Kameraparametrierung 3 vordefinierte Cam-Settings vorschlagen. Minimum-Balanced-Optimum oder sowas in der Art.
          Die Parametrierung ist nämlich... naja auch nicht unbedingt easycheasy.

      • #5
        hstohl Danke für das Feedback. Die Stream-Adressen füge ich noch ein. Die Default-.Settings werde ich im Wiki beschreiben. "Einfach" ist ffserver/ffmpeg tatsächlich nicht zu konfigurieren ;-)
        Spenden für LoxBerry Test-Equipment? http://www.paypal.me/loxberry

        LoxBerry: https://www.loxwiki.eu/display/LOXBERRY/LoxBerry

        LoxBerry Youtube Tutorials:
        https://www.youtube.com/c/LoxBerryTutorials

        Kommentar


        • #6
          Nichts zu danken. Ist das mindeste :-)
          Ja das mit der richtigen Config hat mich auch schon viel Zeit gekostet. Deshalb wär eben mein Vorschlag nach pre-defined Settings.

          Ich denke ich hab dich beim schamlosen kopieren/modifizieren eines eigenen Plugins erwischt :-p
          Hast du zufällig das Weather 4 Loxone Plugin als Basis genommen? ;-)
          Ich bekomme nämlich in der Plugin Verwaltung beim CamStream4Lox den Hinweis, dass die Version 4.3.2. zum Update bereit steht. Updaten (dachte es handelt sich vielleicht nur um einen Darstellungsfehler) bringt natürlich nichts und der Hinweis bleibt bestehen.

          Kommentar


          • #7
            Zitat von hstohl Beitrag anzeigen
            Nichts zu danken. Ist das mindeste :-)
            Ich denke ich hab dich beim schamlosen kopieren/modifizieren eines eigenen Plugins erwischt :-p
            Genau :-) Mache ich (und auch die anderen Entwickler) immer so. Ich schnappe mir ein Plugin, was vom Aufbau so ähnlich ist und nehem das als Basis. Den Bug mit dem falschen Update behebe ich gleich.
            Spenden für LoxBerry Test-Equipment? http://www.paypal.me/loxberry

            LoxBerry: https://www.loxwiki.eu/display/LOXBERRY/LoxBerry

            LoxBerry Youtube Tutorials:
            https://www.youtube.com/c/LoxBerryTutorials

            Kommentar


            • #8
              Kurzes Update/Feedback meinerseits: wie auch schon bei meiner zuvor händischen installierten Methode läuft auch das Plugin stabil, ohne jeglichen Ausfall oder dergleichen.
              Super Sache! Jetzt kann jeder, der sich nicht über die Konsole traut und einen Loxberry laufen hat dem künstlich generierten Zwang zu einem alten Codec entfliehen

              Kommentar


              • #9
                Danke für das Feedback! Ich habe jetzt das erste Release (Version 0.1.0) freigegeben. Im Wiki findet ihr wie üblich eine genaue Beschreibung des Plugins und auch die Download-Links.

                https://www.loxwiki.eu/x/mQE_Ag

                Viel Spaß!

                PS: Wer die Alpha-Version installiert hatte (war wohl nur hstohl ​​​​​​​) muss bitte erst eine komplette Deinstallation durchführen und dann die neue Version wieder installieren. Ein Upgrade funktioniert nicht.
                Spenden für LoxBerry Test-Equipment? http://www.paypal.me/loxberry

                LoxBerry: https://www.loxwiki.eu/display/LOXBERRY/LoxBerry

                LoxBerry Youtube Tutorials:
                https://www.youtube.com/c/LoxBerryTutorials

                Kommentar


                • #10
                  Super Sache!
                  Danke Mobilux für das Plugin und hstohl für die Arbeit mit ffserver!
                  Mein Haus ist fast fertig und bei mir kommen auch die Ubiquiti G3 zum Einsatz. Da hatte ich mir schon die Anleitung von hstohl angesehen.... aber wenns nun so einfach geht mit dem Loxberry Plugin... :-) Wirklich Top! Freu mich schon aufs installieren. Ab Mitte Oktober wenn ich in meinem Smart Home bin gebe ich auch fleißig bei euch mit Feedback und versuch mich an eigenen Dingen um auch was produktiv hier mit beizutragen.
                  Haut rein!

                  Kommentar


                  • #11
                    Hallo zusammen, habe das Plugin versucht, muss aber eine Frage dazu loswerden. Habe eine Kamera Full HD versucht und musste feststellen, das es Verzögerungen zwischen den Stream gibt. Habt ihr dazu eine Idee. Würde gerne verschiedene Kamera einbinden. Das ist der Loxberry etwas zu schwach dafür wahrscheinlich!

                    Kommentar


                  • #12
                    Kurzer Zwischenbericht Auslastung - RPI:
                    Installierte Plugins:
                    *Weather 4 Loxone

                    *CamSteam4Lox -> Aktuell 3 x Hikvision DS2CD2142 und 45

                    *WIFI Scanner mit abfrage 1min....

                    Klicke auf die Grafik für eine vergrößerte Ansicht  Name: Ohne Titel.jpeg Ansichten: 1 Größe: 106,6 KB ID: 165516

                    das find ich jetzut aber nicht so tragisch! CamStream4Lox wurde läuft mit den Originalen Einstellungen!

                    LG Michi
                    LG MRM

                    Kommentar


                    • #13
                      Michael Rene Maurer Sehr cool! Streamst Du den MJPEG Stream der Hikvision weiter oder den H.264 Stream? Du kannst es noch ein wenig optimieren, indem Du Framerate, Bitrate und Bildgröße im Plugin identisch zu den Einstellungen in der Kamera einstellst.
                      Spenden für LoxBerry Test-Equipment? http://www.paypal.me/loxberry

                      LoxBerry: https://www.loxwiki.eu/display/LOXBERRY/LoxBerry

                      LoxBerry Youtube Tutorials:
                      https://www.youtube.com/c/LoxBerryTutorials

                      Kommentar


                      • Michael Rene Maurer
                        Michael Rene Maurer kommentierte
                        Kommentar bearbeiten
                        @#Prof.Mobilux, ja ich streame MJPG... hab bei meinen Cam`s aber 20 FPS drin, und bei Bitrate hab ich glauch 8192 drin, da geht die Last am RPI schon hoch oder?
                        Was mir aufgefallen ist, ich wollte die Puffergröße auf 500MB stellen, spring trotz speichern immer auf 200MB zurück, und ich habe natürlich einen USB Stick am Loxberry...

                    • #14
                      Ok. Ich nutze 4096 in der Cam und am Pi. Das ist noch ok von der Qualität.

                      Die Puffergröße ist ein Bug. Nehme ich mit auf.
                      Spenden für LoxBerry Test-Equipment? http://www.paypal.me/loxberry

                      LoxBerry: https://www.loxwiki.eu/display/LOXBERRY/LoxBerry

                      LoxBerry Youtube Tutorials:
                      https://www.youtube.com/c/LoxBerryTutorials

                      Kommentar


                      • #15
                        Halli Hallo,...
                        Hab ein kleines Problemchen, und zwar startet der Loxberry zwischendurch neu, der FFServer startet nicht mehr. Bekomme dann keine Verbindung mehr über den Port 8090 zu den Kameras... Start und Stopp sowie Neustart des Plugins schafft keine Abhilfe, ich musste dasPlugin NEU installieren.

                        Ich habe ja auch noch den WIFI Scanner installiert, seit dem ich das Plugin CamStream installiert habe, bekomme ich zwischendurch die Meldung das unsere Handys nicht mehr zu Hause sind, eine Minute später sind wir wieder da, Camstream deinstalliert, keine Abmeldeungen mehr!?!

                        Aktuell musste ich das Plugin deinstallieren, leider...

                        LG Michi
                        LG MRM

                        Kommentar

                        Lädt...
                        X