Ankündigung

Einklappen
Keine Ankündigung bisher.

Modbus Soil humidity and temperature sensor from DELTAOHM

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Modbus Soil humidity and temperature sensor from DELTAOHM

    Dears,

    I'm trying to integrate the Deltaohm HD3910 sensor, which I bought with Modbus communication. Here attached u can see some screenshots of Loxone Config setup and the DataSheet of the HD3910.

    I'm not able to get the values out of it... I always see 0 from all 3 registers available.

    - I've left the sensor attached to the Loxone 24Vdc and connected the Modbus wires to a usb-Modbus converter, using ModbusDoctorV2 application on the PC: from here everything works just fine, same speed and parameters (Address 05H, 9600, 8-n-1) I've used with Loxone Modbus extension.

    - Since I also have other 2 devices connected to the Modbus extension, and they're working fine. I've double checked the Address and they're 1, 2, 5.

    - I've terminated the last device with a 120R.

    I really don't know what else I can do here... on Config there's no helpful monitor, and I don't want to go ahead using a Modbus protocol analyzer...

    Thanks!
    Angehängte Dateien

  • #2
    Please check the Sensor manual, on page 4. At the top (1.) you can read:

    By default, the parameters are:
    19200, 8, E, 1

    Your Modbus Extension setting is different !!! ( 9600 )

    For a first test i would change the Extension settings to 19200 to see if this helf in receiving data, if so, then i would reconfigure the sensor itself to work with 9600, 8, n, 1.
    For this you would need a RS485 interface for your PC or at least a RS232 Interface (e.g. USB/RS232) and a RS232/RS485 converter.
    For configuring the sensor i would then use a small windows program called HTerm ( http://www.der-hammer.info/terminal/hterm.zip )
    Check instrutions on page 4 of the manual
    Zuletzt geändert von Labmaster; vor 4 Tagen.

    Kommentar


    • #3
      Yep, you can order this HD3910 with the desired parameters, which is what I did.

      Infact it works just fine with USB-485 and ModbusDoctorV2 on my laptop, 9600-n-8-1, Address 5H. But when I connect it to the Modbus network below Loxone Modbus extension it does not work at all, while all other devices are working fine.

      Kommentar


      • #4
        So you ordered the Sensor with the Modbus Address set to 5 (instead of 1 as default) ?

        Hmm, the last thing i could think of, is the CMWn setting. Maybe it is set to '0' and the loxone Modbus extention can not cope with this, though the default of the sensor would be '1'.
        But who knows ?
        Zuletzt geändert von Labmaster; vor 4 Tagen.

        Kommentar


        • #5
          yes, I ordered it 9600-n-8-1, Address 5. And it's perfectly working with ModbusDoctorV2.

          I'm not an expert about Modbus communication, but yes, this CMWn maybe a problem !:
          1) I will immediately talk to DeltaOhm guys to ask details about CMWn
          2) I should find a way to possibly read this parameter and if necessary change it too. (maybe using RMW command...)

          I'll let you know asap, thanks!

          Kommentar


          • #6
            If you already have a RS485 Interface for you PC, then it should be easy to read and change settings using a simple terminal Program like hTerm (see post #2)

            Kommentar


            • #7
              Finished all my tests right now.

              First of all I counter-checked and tried to re-program some parameters in Serial Line mode, as per the HD3910 datasheet, using TeraTerm serial monitor.

              Then I re-tried to read some Input registers in Modbus Mode (04h), here you can see I can read the temperature which is now 25°C.

              Everything seems OK for my perspective... what do you believe ?



              Kommentar


              • #8
                Hi,

                Did you try to enable the settings for the register order or the byte order, to see something is wrong there?

                In addition, I would try different wait and timeout settings to give the sensor more time.

                Dominik


                Gesendet von iPhone mit Tapatalk

                Kommentar


                • #9
                  Also are you sure the address is correct in your last screenshot is address 5, but in loxone you are using Adress 1?


                  Gesendet von iPhone mit Tapatalk

                  Kommentar


                  • Pippo74
                    Pippo74 kommentierte
                    Kommentar bearbeiten
                    Sure :-( ! I've just included the configuration screenshot since I forgot in when I raised the Question at the beginning.

                • #10
                  Sorry, but for me all seems to be ok then.

                  Now, you could use your RS485 interface to get debug data directly from the bus.
                  Hook up both, the Lox Modbus Extension AND your PC interface to the bus and use a terminal program that offers hex value of all data. (eg. hTerm)
                  Get a modbus spec and verify byte by byte to see whats different compared to other sensor data on the bus.

                  Kommentar


                  • #11
                    eh eh, things are becoming quite complicated here... I've tried to play with diffent polling time and delay on both Modbus extension and device, without any result...

                    On the other hands, I'm also evaluating other Modbus process sensors, like the instruments from S+S Regeltechnik from Nurnberg. Do you know if are they 100% compatible with Loxone Modbus?

                    Kommentar


                    • #12
                      ^Modbus" should be "Modbus", so you are asking the wrong question
                      The question should be, who may violate the specification, is it "Deltaohm" or is it "Loxone".
                      Beside this question i would open a support case at both of them.

                      Kommentar


                      • #13
                        Well,

                        you're 100% right. And by the way it's really difficult opening a ticket if I see from ModbusDoctor2 Deltaohm sensor is delivering the correct values when I request a certain data... So it can either be Loxone.

                        Kommentar

                        Lädt...
                        X