Ankündigung

Einklappen
Keine Ankündigung bisher.

LoxBerry v2.0.1 Problem beim Updaten von Plugins (neues tmp)

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • LoxBerry v2.0.1 Problem beim Updaten von Plugins (neues tmp)

    Hi!

    Das temp. Verzeichnis wurde ja offenbar mit v2.0.1 verlegt.
    Leider fehlt jetzt dort aber das uploads-Directory.
    Daher werden bei eine Plugin-Update die Log-Files wie auch die aktuelle Konfiguration (...?) nicht uebernommen.
    Ist das so beabsichtigt?
    Dann muessten alle Plugin-Autoren im preupgrade.sh statt eines mkdir eben ein mkdir -p eintragen.
    Ich trage das jetzt erstmal bei meine Plugins so ein ...

    Nachtrag:
    Ein einmaliges sudo -u loxberry mkdir -p /tmp/uploads/ von der Konsole aus behebt das Problem.
    Wichtig: das Verzeichnis muss als Benutzer loxberry erzeugt werden!

    Gruss, Oliver
    Zuletzt geändert von olicat; 06.Jan.2020, 13:22.

  • #2
    Prof.Mobilux Bug 🙁

    Danke fürs Melden!
    LoxBerry/Plugin Support: Wenn du einen Begriff in meiner Antwort nicht auf Anhieb verstehst, bitte nicht gleich rückfragen, sondern erst die Suche im LoxWiki und bei Google bemühen.
    PN/PM: Ich bevorzuge die Beantwortung von Fragen in öffentlichen Threads, wo andere mithelfen und mitprofitieren können. Herzlichen Dank!

    Kommentar


    • #3
      Gerne doch!
      Das muss tatsaechlich gefixed werden, denn das upload-Verzeichnis wird nicht nur im preupgrade.sh-Script sondern auch an anderen - vom Plugin-Autor nicht beeinflussbaren Stellen - vorausgesetzt. Mein Schnellschuss mit mkdir -p hilft jedenfalls nicht.
      :-(

      Nachtrag:
      Ein einmaliges sudo -u loxberry mkdir -p /tmp/uploads/ von der Konsole aus behebt das Problem.
      Wichtig: das Verzeichnis muss als Benutzer loxberry erzeugt werden!

      Oliver
      Zuletzt geändert von olicat; 06.Jan.2020, 13:18. Grund: Workaround

      Kommentar


      • #4
        Fixe ich. Bitte ändere nichts an Deinen Plugins! Das muss so funktionieren.
        Spenden für LoxBerry Test-Equipment? http://www.paypal.me/loxberry

        LoxBerry: https://www.loxwiki.eu/display/LOXBERRY/LoxBerry

        LoxBerry Youtube Tutorials:
        https://www.youtube.com/c/LoxBerryTutorials

        Kommentar


        • #5
          Hallo Michael,

          danke fuer die Info. Ich halte die Fuesse still.

          Gab es beim v2.01-Update auch Aenderungen bzgl. Netzwerk (MAC-Adresse? DHCP-Client?) oder ist es ein Zufall, dass mein LoxBerry nach dem erforderlichen Reboot eine neue IP-Adresse vom DHCP-Server (hier FritzBox) erhalten hat? Natuerlich ist der Router so konfiguriert, dass sich bekannte Geraete immer die gleiche IP-Adresse holen. Die Adresse war auch weiterhin fuer ein Geraet reserviert. Aber nach dem Reboot hatte das Geraet eben eine andere.
          Ich war etwas im Stress (hielt das /tmp/uploads-Problem fuer hausgemacht) und habe das auf die Schnelle - ohne weitere Analyse - behoben:

          Abhilfe bringt, in den Einstellungen der FritzBox (wenn diese der DHCP-Server ist) unter Heimnetz/Netzwerk die bisherige IP-Adresse zu suchen (sollte unter dem LoxBerry-Namen in den "Ungenutzte Verbindungen" zu finden sein) und mit dem Button mit dem roten Kreuz zu loeschen.
          Anschliessend das Geraet mit der neuen IP-Adresse bei den "Aktive Verbindungen" suchen und per Stift-Symbol bearbeiten.
          Dort unter "IP-Adresse" die bisherige IP-Adresse eingeben, Haekchen bei "Diesem Netzwerkgerät immer die gleiche IPv4-Adresse zuweisen." setzen und mit OK die Fritzbox-Konfiguration abspeichern

          Anschliessend den LoxBerry neustarten.
          Dann sollte der LoxBerry wieder unter der gewohnten IP-Adresse erscheinen.

          Oliver

          Kommentar


          • #6
            DHCP und MAC werden vom Betriebssystem bzw. Von der Hardware verwaltet, da hat der Loxberry überhaupt keine Finger im Spiel. Der Client holt sich auch keine Adresse, es wird ihm eine zugewiesen. Wenn Du im DHCP Server nicht hinterlegt hast, dass der entsprechende Client immer die selbe IP bekommen soll, dann bekommt er von Zeit zu Zeit auch mal eine andere.
            Miniserver; KNX; Vitogate; EnOcean (EnOceanPi); Loxone Air; Caldav-Kalenderanbindung; RaspberryPi und für keine Frickellösung zu schade :-)

            Kommentar


            • #7
              Ja svethi ,

              Wenn Du im DHCP Server nicht hinterlegt hast, dass der entsprechende Client immer die selbe IP bekommen soll, dann bekommt er von Zeit zu Zeit auch mal eine andere.
              daher schrieb ich ja auch explizit, dass ich das so konfiguriert hatte.
              Und da bei diesem Update erstmals auch ein Neustart des LoxBerry erforderlich war, liegt nahe, dass es da Aenderungen am Betriebssystem gegeben haben koennte.
              Daher meine Nachfrage.

              Oliver

              Kommentar


              • #8
                Dann hatte ich das falsch verstanden, da Du ja im Anschluss detailliert erklärt hast, dass man es so konfigurieren soll, dass die IP immer gleich bleiben soll.
                ich habe derartige Berichte noch nicht gelesen. Eigentlich ist die MAC ja an die Hardware gekoppelt. Wir machen daran gar nichts. Sollte sich die Adresse wirklich geändert haben, tippe ich auf das Firmwareupdate. Obwohl ich der Meinung bin, dass das auch nicht passieren dürfte.
                Miniserver; KNX; Vitogate; EnOcean (EnOceanPi); Loxone Air; Caldav-Kalenderanbindung; RaspberryPi und für keine Frickellösung zu schade :-)

                Kommentar

                Lädt...
                X