Ankündigung

Einklappen
Keine Ankündigung bisher.

Homebridge per Dock im Loxberry

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Homebridge per Dock im Loxberry

    Hi,

    ich beschäftige mich schon recht lange mit Linux, Loxone, und Loxberry, habe schon zig Erweiterungen eingebunden (Modbus, 433mHz, Weather Server, Relaiskarten, ...)

    bin also nicht ganz frisch im Thema aber die Homebridge bringt mich an den Rande des Wahnsinns :-)

    ich habe diese in meinem Loxberry 2 per Dock einbinden wollen (onzu/docker) die Homebridge läuft auch und ich kanm per WebUI drauf zugreifen.

    nur das Loxone Plugin scheint irgend ein Problem zu haben.

    vielleicht kennt jemand das Problem und kamm mir helfen.


    hier der log


    Loading 1 platforms...
    [4/28/2020, 4:20:48 PM] [Loxone] Initializing LoxoneWs platform...
    [4/28/2020, 4:20:48 PM] [Loxone] Info: rooms array not configured. Adding every room.
    [4/28/2020, 4:20:48 PM] [Loxone] object
    New WS: 192.168.178.10:80
    [4/28/2020, 4:20:48 PM] [Loxone] Platform - Waiting 8 seconds until initial state is retrieved via WebSocket.
    [4/28/2020, 4:20:48 PM] [Loxone] LOXONE WS: connect
    [4/28/2020, 4:20:56 PM] [Loxone] Platform - Retrieving initial config from http://xxxx@192.168.178.10:80/data/LoxApp3.json
    [4/28/2020, 4:20:56 PM] TypeError: Class constructor PlatformAccessory cannot be invoked without 'new'
    at PushbuttonItem.AbstractItem (/homebridge/node_modules/homebridge-loxone-ws-adv/items/AbstractItem.js:22:25)
    at PushbuttonItem.SwitchItem (/homebridge/node_modules/homebridge-loxone-ws-adv/items/SwitchItem.js:12:23)
    at new PushbuttonItem (/homebridge/node_modules/homebridge-loxone-ws-adv/items/PushbuttonItem.js:6:27)
    at exports.Factory.parseSitemap (/homebridge/node_modules/homebridge-loxone-ws-adv/libs/ItemFactory.js:66:29)
    at Request._callback (/homebridge/node_modules/homebridge-loxone-ws-adv/index.js:88:38)
    at Request.self.callback (/homebridge/node_modules/homebridge-loxone-ws-adv/node_modules/request/request.js:185:22)
    at Request.emit (events.js:310:20)
    at Request.<anonymous> (/homebridge/node_modules/homebridge-loxone-ws-adv/node_modules/request/request.js:1154:10)
    at Request.emit (events.js:310:20)
    at IncomingMessage.<anonymous> (/homebridge/node_modules/homebridge-loxone-ws-adv/node_modules/request/request.js:1076:12)

    [4/28/2020, 4:20:56 PM] Got SIGTERM, shutting down Homebridge...

  • #2
    habe seit neusten auch das Problem, lief eigentlich Monate ohne Probleme im Docker auf einer Synology-Diskstation, dachte, es hängt mit Update auf LoxOS11 zusammen!?

    Kommentar


    • #3
      Kann nicht sein, hatte ich nicht aufgespielt.
      Ich werds morgen mal mit nem „stand-alone“ pi testen um auszuschließen das es an docker liegt...


      Gesendet von iPhone mit Tapatalk

      Kommentar


      • #4
        Das Problem ist wohl das Update auf homebridge 1.0, das Loxone Ws Plugin muss wohl angepasst werden

        Kommentar


        • #5
          Das Plug in läuft aktuell nur mit der Hombridge in einer Version unter 1.0.
          Bei mir mit 0.4.53
          Miniserver; KNX; Loxberry; Homebridge; Nuki; Roborock; Siemens S7/TIA; DoorBird;

          Kommentar


          • #6
            Downgrade übrigens mit
            sudo npm install -g --unsafe-perm homebridge@0.4.53

            Kommentar


            • #7
              Ok cool, danke für den Hinweis, mal sehen wie ich im docker den downgrade hinbekomme oder ob ich ein image finde für docker.


              Gesendet von iPhone mit Tapatalk

              Kommentar


              • #8
                Perfekt, hat funktioniert


                Gesendet von iPhone mit Tapatalk

                Kommentar


                • #9
                  Das Problem besteht mit der aktuellen Version übrigens immer noch.

                  Kommentar


                  • #10
                    Homebridge V1.1.6 und das Loxone Plugin V1.0.18 läuft bei mir soweit ganz gut.
                    Miniserver; KNX; Loxberry; Homebridge; Nuki; Roborock; Siemens S7/TIA; DoorBird;

                    Kommentar


                    • #11
                      Hallo,

                      ich bekomme das ganze leider nicht zum laufen.

                      Homebridge läuft. Aber sobald ich in der json.config den Miniserver hinzufüge bekomme ich Fehlermeldungen und das Loxone Plugin startet nicht mehr.

                      Könnt ihr mir helfen?

                      Bin leider ein Neuling.

                      Kommentar


                      • #12
                        Was für Fehlermeldungen kommen den?
                        Wie sieht deine Config denn aus?
                        Miniserver; KNX; Loxberry; Homebridge; Nuki; Roborock; Siemens S7/TIA; DoorBird;

                        Kommentar


                        • #13
                          Hallo,

                          homebridge konnte sich mit dem Miniserver nicht verbinden. Hatte viele Fehlermeldungen.

                          Jetzt gehts aber. Habe ein downgrade der Homebridge auf Version 1.1.6 gemacht. Und nutze das Loxone Plugin 1.0.18.

                          jetzt läuft alles soweit.

                          Kommentar


                          • #14
                            Hallo zusammen,

                            ich hänge mich hier mal ran....
                            Ich habe gestern abend bei dem Versuch, einen anderen Fehler zu beheben, mir meine Homebridge zerschossen, und ich verzweifle an der Bedienung von Portainer
                            Ich habe zwei Stunden lang versucht ein Image, welches noch vorhanden aber als "unused" gekennzeichnet ist (nämlich meine konfigurierte Homebridge), wieder dazu zu bewegen, unter "Containers" mit aufgenommen zu werden - ich bekomm es ums Verrecken nicht hin!
                            Wie macht man das ???? Ich verzweifel hier noch.....


                            Verzweifelte Grüße,

                            Martin
                            Zuletzt geändert von Clubsport; 03.Nov.2020, 08:19.

                            Kommentar

                            Lädt...
                            X