Ankündigung

Einklappen
Keine Ankündigung bisher.

Suche Alternative zur SMA Steuerung

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • #76
    Hi

    Extra noch mal getestet, sowohl mit ModBus Register 30775 (den ich verwendet hatte) und ModBus Register 30777.
    Beide reagieren erst deutlich später, und zwar nach rund 50 Sekunden.

    Kommentar


    • #77
      Blöde Frage, kann man den Modbus mit zu vielen Abfragen überlasten?

      Denn ich habe viele nicht genutzte Abfragen gelöscht und andere auf einen höheren Abfragezyklus umgestellt.
      Jetzt kommen die Werte öfter.
      Ich bilde jetzt aus ModBus Register 30775 und ModBus Register 30777 einen Mittelwert, da unterschiedlich.
      Angehängte Dateien
      Zuletzt geändert von KaJu74; 17.Jun.2017, 15:56.

      Kommentar


      • #78
        Mir ist es gelungen mit dem Modbus Poll Tool vom PC die Register 40151 (Steuerung über ext Kommunikation) und 40149 (Leistungvorgabe, mit 0 probiert) im SI zu beschreiben.
        Wenn ich also 40149 auf 0 setze kann ich den SI aktiv oder inaktiv schalten (gilt für Laden und Entladen) indem ich Register 40151 auf 802 oder 803 setze. Aus Loxone habe ich es noch nicht geschafft
        MS mit Modbus, 1-wire, Air. Überwacht/steuert: 3xPV mit 16kWp. LiFeYPo4 8 kWh. Aquarea LWWP 5kW Split, ST und Pelletkessel. 2 BEV an Keba P20. Teilweise Beleuchtung über Homematic

        Kommentar


        • #79
          Aus Loxone heraus kann ich nun das Register 40755
          Maximum AC battery charge current
          beschreiben. Der Wert gilt entgegen der Beschreibung auch für das Entladen. Es kann also der maximale AC Strom eingestellt werden. Auch damit kann man die Ladung "abwürgen". Ich fürchte aber daß dieser Wert auf die SD Karte und/oder in den Flashspeicher geschrieben wird und man das nicht dauerhaft tun sollte. Also keinesfalls für Regelzwecke.
          2x am Tag umstellen sollte es aushalten oder was meint ihr?

          Die für Regelung wohl vorgesehenen Register 40151 und 40149 habe ich noch nicht geschafft, aus Loxone zu beschreiben.
          MS mit Modbus, 1-wire, Air. Überwacht/steuert: 3xPV mit 16kWp. LiFeYPo4 8 kWh. Aquarea LWWP 5kW Split, ST und Pelletkessel. 2 BEV an Keba P20. Teilweise Beleuchtung über Homematic

          Kommentar


          • #80
            Wenn ich mit dem Modbus Poll Tool die Register 40149 und 40151 aufrufe, sehen sie wie im Anhang aus.
            War das vor den Änderungen bei dir auch so?

            Fragen zum Bild in #79:
            Du hast manuelle 70A als maximalen Ladestrom vorgegeben (VI) und mit 65536 multipliziert, dann eine Ganzzahl draus gemacht.
            An welchen Ausgang hast du das Ergebnis "geschickt" (AQ max Netzstrom mA)?
            Dann hast du wieder manuell den maximalen Netzstrom in mA (14300mA) vorgegeben und auch mit 65536 multipliziert und auch zur Ganzzahl daraus gemacht. Das Ergebnis schickst du dann an den Register 40755 geschickt.

            Könntest du bei den Werten die Registerzahl mit angeben, würde es leichter machen.

            Denn oben rechts steht ja noch 77A maximaler Batterie Ladestrom.

            Kommentar


            • #81
              Zitat von KaJu74 Beitrag anzeigen
              Wenn ich mit dem Modbus Poll Tool die Register 40149 und 40151 aufrufe, sehen sie wie im Anhang aus.
              War das vor den Änderungen bei dir auch so?
              Ja das sind aber Write Only Register, da kann man nichts sinnvolles auslesen, den eingespeicherten Wert jedenfalls nicht.


              Zitat von KaJu74 Beitrag anzeigen
              Fragen zum Bild in #79:
              Du hast manuelle 70A als maximalen Ladestrom vorgegeben (VI) und mit 65536 multipliziert, dann eine Ganzzahl draus gemacht.
              An welchen Ausgang hast du das Ergebnis "geschickt" (AQ max Netzstrom mA)?
              Dann hast du wieder manuell den maximalen Netzstrom in mA (14300mA) vorgegeben und auch mit 65536 multipliziert und auch zur Ganzzahl daraus gemacht. Das Ergebnis schickst du dann an den Register 40755 geschickt.

              Könntest du bei den Werten die Registerzahl mit angeben, würde es leichter machen.

              Denn oben rechts steht ja noch 77A maximaler Batterie Ladestrom.
              Bitte ignoriere alles außer das gelb Eingekreiste. Der AQ ist ein Modbus Aktor den Du vorher anlegen musst, Register 40755 siehst Du links oben im Bild.

              MS mit Modbus, 1-wire, Air. Überwacht/steuert: 3xPV mit 16kWp. LiFeYPo4 8 kWh. Aquarea LWWP 5kW Split, ST und Pelletkessel. 2 BEV an Keba P20. Teilweise Beleuchtung über Homematic

              Kommentar


              • #82
                Habe ich gemacht, hat geklappt. Cool.

                Woher wußtest du, in welche Zeile (bei dir Zeile 2 im Modbus Poll Tool) du die 802/803 schreiben mußtest?
                Genauso, wo du die 0 für den Register 40149 hinschreiben mußtest (im Beispiel Zeile 0 oder 9)?

                Sorry für die vielen Fragen.

                Kommentar


                • #83
                  Zitat von KaJu74 Beitrag anzeigen
                  Habe ich gemacht, hat geklappt. Cool.

                  Woher wußtest du, in welche Zeile (bei dir Zeile 2 im Modbus Poll Tool) du die 802/803 schreiben mußtest?
                  Genauso, wo du die 0 für den Register 40149 hinschreiben mußtest (im Beispiel Zeile 0 oder 9)?

                  Sorry für die vielen Fragen.
                  Dass Poll Tool zeigt 10 Register an. Wenn oben 40140 steht dann ist die Zeile 9 das Register 40149 Da wohl in einem Register nur 16 bit gespeichert werden können, werden immer 2 Register verwendet um ein 32 bit Wort zu speichern. Deswegen gibts in der SMA Anleitung auch nur ungeradzahlige Nummern. Im Register 40150 steht also die andere Hälfte von 40149. Zur vollständigen Verwirrung steht im 2. Register wohl der eigentliche Wert. Ich kann es nicht genau erklären, schau doch mal in den Thread wo das mit der Multiplikation mit 65536 erklärt ist.
                  Du musst deswegen auch immer 2 Register gleichzeitig schreiben (16 write multiple registers) damit der Wert vollständig übernommen wird.
                  MS mit Modbus, 1-wire, Air. Überwacht/steuert: 3xPV mit 16kWp. LiFeYPo4 8 kWh. Aquarea LWWP 5kW Split, ST und Pelletkessel. 2 BEV an Keba P20. Teilweise Beleuchtung über Homematic

                  Kommentar


                  • #84
                    Danke für die Erklärung!

                    Du hast übrigens Recht, die Einstellung bei 40755 beeinflußt Laden und auch entladen, leider.

                    Besser wäre da Register 40236:
                    Betriebsart des Batterie-Management-Systems:
                    303 = Aus
                    308 = Ein
                    2289 = Batterie laden
                    2290 = Batterie entladen
                    2424 = Voreinstellung
                    Da könnte man den Ladestrom gleich lassen und "nur" auf 2290 umstellen und schon entlädt sich der Akku, wird aber nicht mehr geladen.

                    Im Anhang übrigens (vermutlich) Register 40236 im Parameter des SI.
                    Denn er war ja mal auf "Steuerung über Kommunikation"!
                    Angehängte Dateien
                    Zuletzt geändert von KaJu74; 17.Jun.2017, 18:34.

                    Kommentar


                    • #85
                      Zitat von tubist88 Beitrag anzeigen
                      Du musst deswegen auch immer 2 Register gleichzeitig schreiben (16 write multiple registers) damit der Wert vollständig übernommen wird.
                      Irgend etwas mache ich falsch.

                      Wenn es die Betriebsarteinstellung ist, kann es vielleicht ein Problem geben, siehe zweites Bild.

                      PS: Versucht nicht, mehr als die 20A bei der maximalen Ladeleistung einzugeben, geht nicht wegen der Schieflast (20A*230V=4.6kW), wollte wissen ob ein 6.0 vielleicht doch mit 6.0 laden kann.
                      Zuletzt geändert von KaJu74; 17.Jun.2017, 19:42.

                      Kommentar


                      • #86
                        Hi

                        Ich würde mir gerne eine Bilanz, wie vom HomeManager zusammen "basteln".
                        Bekannt:
                        30579 = Netzeinspeisung
                        30577 = Netzbezug
                        Tagesertrag = Leistung der PV+BHKW (in meinem Fall)

                        Unbekannt:
                        Batterieladung = 30595 liefert vermutlich die absoluten Zahlen
                        Batterieentladung = 30597 liefert vermutlich die absoluten Zahlen
                        Direktverbrauch = Eigenversorgung - Batterieladung
                        Eigenversorgung = Direktverbrauch + Batterieentladung
                        Tagesverbrauch = Netzbezug + Eigenversorgung

                        Eigenverbrauch = Direktverbrauch + Batterieladung

                        Die anderen 3 Werte sind nur Berechnungen.
                        Zuletzt geändert von KaJu74; 18.Jun.2017, 22:00.

                        Kommentar


                        • #87
                          Da musst Du nichts basteln. Schau Dir mal den Baustein "Energiemonitor" an.

                          Gesendet von meinem SM-G955F mit Tapatalk

                          MS mit Modbus, 1-wire, Air. Überwacht/steuert: 3xPV mit 16kWp. LiFeYPo4 8 kWh. Aquarea LWWP 5kW Split, ST und Pelletkessel. 2 BEV an Keba P20. Teilweise Beleuchtung über Homematic

                          Kommentar


                          • #88
                            Hi

                            Der läuft ja schon bei mir.
                            Aber kann man da auch eine monatliche Übersicht bekommen?

                            Kommentar


                            • #89
                              Hi

                              Wenn ich von der Arbeit auf den Loxone zugreifen will, kann ich mich einloggen und er lädt die 11 Skripte, geht dann aber in einen Wartemodus und nichts passiert mehr.
                              Mit der App geht es aber problemlos.

                              Liegt das am Firmennetzwerk?

                              Kommentar


                              • svethi
                                svethi kommentierte
                                Kommentar bearbeiten
                                Dann sind in dem verwendeten Netzwerk Websocket Verbindungen nicht möglich -> Admin fragen

                            • #90
                              Hi

                              Findet jemand einen/den Fehler?

                              Denn in der App sind bei
                              - Zähler Produktion
                              - Zähler Verbrauch
                              keine Werte.

                              Hingegen sagt der Zähler Lieferung, dass ich 1,5MWh geliefert habe. (In Wirklichkeit etwas über 77kWh)

                              usw...

                              Den Ertrag berechne ich derzeit etwas kompliziert, da noch ein Modbus Adapter fehlt und das BHKW Konstant 1,5kW liefert.
                              Eigentlich misst ein zweiter Energiemeter diese gesamte Produktion.

                              Muss Eingang A "Ein" oder "Aus" sein?
                              Zuletzt geändert von KaJu74; 19.Jun.2017, 16:30.

                              Kommentar

                              Lädt...
                              X