Ankündigung

Einklappen

PLUGINS

Bitte im Titel immer zuerst den Namen des Plugin hinschreiben
Mehr anzeigen
Weniger anzeigen

Plugin: UnifiController

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Plugin: UnifiController

    Hallo,

    da ich gerade nun mein Heimnetzwerk mit Unifi Accesspoints installiert habe, habe ich auch ein Plugin für den Loxberry programmiert.
    Dieses Plugin installiert den Unifi Controller auf dem Loxberry

    Das Plugin verwendet das Loxberry Docker Plugin um den Unifi Controller bereitzustellen.

    Die Installation dauert leider etwas länger. Also bitte etwas Geduld.
    Die Installation braucht beim Schritt Update service config einige Zeit, da hier der container heruntergeladen wird.
    WICHTIG:
    Ihr müsst den Hostnamen im Unifi-Controller auf die IP oder den DNS Namen vom Loxberry setzten und den Hacken bei Override Inform URL setzen damit die Geräte erfolgreich hinzugefügt werden können
    Klicke auf die Grafik für eine vergrößerte Ansicht

Name: config_howto.png?raw=true.png
Ansichten: 2314
Größe: 21,9 KB
ID: 287751

    Würde mich freuen, wenn sich einige Tester finden würden, damit ich das Plugin schnellstmöglich auf Release bringen kann

    Hier der Loxwiki Link: https://www.loxwiki.eu/x/DYAjBQ

  • #2
    Hallo,
    da ich auf meine UAP AC Pro keinen Zugriff mehr habe, wollte ich das eh Mal wieder neu aufsetzen.
    Ich werde daher das Plugin die Tage gern Mal probieren.
    Gruß

    Kommentar


    • #3
      Hallo, ich habe den UniFi Controller (Version 5.6.42) parallel selbst auf meinem Loxberry installiert. Gibt es die Möglichkeit mit diesem Plugin auf die neueste Version 6 zu wechseln?

      Kommentar


      • #4
        Hallo,

        Du müsstest die Daten sichern, die alte Version deaktivieren und dann kannst du das Plugin installieren und die Daten einspielen.
        Wie hast du denn die Version 5.6.42 installiert?

        Kommentar


        • neu.bau
          neu.bau kommentierte
          Kommentar bearbeiten
          Welche Controller Version wird denn bei deinem Plugin installiert?

        • romanlum
          romanlum kommentierte
          Kommentar bearbeiten
          standardmäßig 6.0.43

        • neu.bau
          neu.bau kommentierte
          Kommentar bearbeiten
          Okay, könntest du mir denn etwas behilflich sein? Kann ich die gesicherten Daten von einer alten Controller Version in die neue einspielen? Wie kann ich den Controller deinstallieren?

      • #5
        Mal kurz und knapp: Es funktioniert einfach.

        Vielen Dank für die Arbeit.

        Kommentar


        • #6
          Ich habs es installert und bin auf die Anmeldeseite (port 8443) gekommen wo ich ein backup eingegeben habe (was ich bei einer anderen Installation auch schon erfolgreich verwendet habe) danach ging nichts mehr weiter und nach einem Neustart war dann sowieso kein Zugriff mehr.

          Loxberry neu aufgesetzt, Docker neu aufgesetzt, Unifi Controller neu installiert --- kein Zugriff auf die Seite und im Plugin steht praktisch unendlich "starting"

          jemand eine Idee?

          Klicke auf die Grafik für eine vergrößerte Ansicht

Name: unifi2.JPG
Ansichten: 382
Größe: 36,5 KB
ID: 289359

          Kommentar


          • #7
            Leonard Lassen
            Bitte schau mal unter logs nach ob es eine logdatei gibt

            Kommentar


            • Lenardo
              Lenardo kommentierte
              Kommentar bearbeiten
              Ich hab auch schon docker auf neuesten Stand gebracht und Unifi auf 6.0.45 gebracht macht keinen Unterschied

            • romanlum
              romanlum kommentierte
              Kommentar bearbeiten
              hmm wenn du Zugriff per ssh hast kannst du folgendes versuchen:
              1) die gewünschte Version in der GUI einstellen
              2) per ssh einloggen
              3) sudo systemctl stop unifi eingeben
              4) rm /opt/loxberry/data/plugins/unifi/data/* -r (löscht die Daten des Unifi Controllers)
              5) sudo systemctl start unifi eingeben

            • Lenardo
              Lenardo kommentierte
              Kommentar bearbeiten
              der Ordner opt/loxberry/data/plugins/unifi/data/ ist da, aber es sind zu keinem Zeitpunkt Dateien drinnen und die Rückmeldung ist: rm: cannot remove '/opt/loxberry/data/plugins/unifi/data/*': No such file or directory

          • #8
            Also ich hatte das gleiche Problem bei einem Backup der Version 5.6.
            Mit einer Neuinstallation des Plugins und dann einem sofortigen Downgrade auf die LTS vor dem Backup einspielen hat dann zum Erfolg geführt.
            Allerdings kann ich nicht adoptieren. Welche Adresse muss ich für die Antwort eingeben?

            Kommentar


            • romanlum
              romanlum kommentierte
              Kommentar bearbeiten
              Du musst wie im Plugin beschrieben die IP oder den Domainnamen (falls vorhanden) des Loxberry eingeben

            • Iluminatus23
              Iluminatus23 kommentierte
              Kommentar bearbeiten
              Vielen Dank! Allerdings kommt immer noch folgender Fehler "Beim Einbinden von OG ist ein Fehler aufgetreten. API_ERROR_CANNOT_ADOPT".

          • #9
            Auch von meiner Seite her nochmals vielen Dank für die App. Ich habe Loxberry V2.2.0.4 mit der Unifi Cotroller App Version 0.2.0 am laufen.
            Seit der Installation erhalte ich im Minuten Takt eine Email mit dem folgenden Inhalt:
            Subject: Cron <loxberry@loxberry> /opt/loxberry/bin/plugins/unifi/cron_runner
            Body: PHP Notice: Undefined index: epoch_firstinstalled in /opt/loxberry/data/plugins/unifi/vendor/moay/loxberry-core/src/System/Plugin/PluginDatabase.php on line 157
            Notice: Undefined index: epoch_firstinstalled in /opt/loxberry/data/plugins/unifi/vendor/moay/loxberry-core/src/System/Plugin/PluginDatabase.php on line 157
            (Dies wird dann x mal wiederholt im Email)

            Hat jemand eine Ahnung, was das Problem sein könnte.
            Ich habe die App schon deinstalliert und wieder installiert, und habe das gleiche Problem erhalten. Die Installation lief ohne Errors ab.
            Danke im Voraus für die Hilfe.

            Kommentar


            • #10
              Hallo,

              Ich schau mir das mal an.

              Kommentar


              • #11
                Es schaut so aus als ob in der Plugindatenbank ein ein Eintrag ohne "epoch_firstinstalled" Feld steht
                Werde schauen, dass in der nächsten Version keine Warnung mehr kommt, falls das Feld fehlt.

                Kommentar


                • #12
                  Plugindatenbank - Ist das was von uns? 😃 Müssen wir was fixen?
                  LoxBerry/Plugin Support: Wenn du einen Begriff in meiner Antwort nicht auf Anhieb verstehst, bitte nicht gleich rückfragen, sondern erst die Suche im LoxWiki und bei Google bemühen.
                  PN/PM: Ich bevorzuge die Beantwortung von Fragen in öffentlichen Threads, wo andere mithelfen und mitprofitieren können. Herzlichen Dank!

                  Kommentar


                  • #13
                    Hey,

                    danke für das Plugin Die Mail wie LeeTschi bekomme ich auch. Werde jetzt mal alles testen

                    LG,
                    Andi

                    --------------
                    Loxone: 1x Miniserver, 5x Extension, 1x IR, 1x DMX, 1x 1Wire, 1x Air Base, 1x MultiExtension Air, 3x Smart Socket Air, 1x Remote Air
                    Extern: Sprachausgabe über Raspi, Mobotix T25, Sonos Play 5, Sonos Play 3, APC Back UPS Pro USV 900 VA, Synology DS215j

                    Kommentar


                    • #14
                      Hallo, ich bräuchte bitte Eure Hilfe: Hab seit gestern 2 Unifi AP , die einfach mal im Unifi Controller (Windows) online gebracht wurden. (Das schaffte ich als Neuling) ;-)
                      Nun habe ich mir aufn loxberry die Docker und Unifi-Controller Plugins aufgespielt.
                      Jetzt die Frage!? Wie öffne ich denn Controller? Klicke ich auf das Plugin Unifi Controller kommt: Diese Seite funktioniert nicht.

                      Herzlichen Danke lg Alex

                      Angehängte Dateien

                      Kommentar


                      • #15
                        Schau doch mal, ob es im docker einen unifi Container gibt und ob dieser läuft
                        Miniserver; KNX; Vitogate; EnOcean (EnOceanPi); Loxone Air; Caldav-Kalenderanbindung; RaspberryPi und für keine Frickellösung zu schade :-)

                        Kommentar


                        • loadhelmchen
                          loadhelmchen kommentierte
                          Kommentar bearbeiten
                          Danke. Ja gibt es und er läuft. Habs mal neu gestartet, leider ohne Erfolg.
                      Lädt...
                      X