Ankündigung

Einklappen

PLUGINS

Bitte im Titel immer zuerst den Namen des Plugin hinschreiben
Mehr anzeigen
Weniger anzeigen

LoxBerry: Fhem Plugin verfügbar

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • LoxBerry: Fhem Plugin verfügbar

    Moin zusammen,

    für den LoxBerry ist jetzt ein Fhem-Plugin verfügbar:Das Fhem Plugin stellt auf dem LoxBerry eine Fhem-Installation zur Verfügung. Es bindet die original Fhem-Sourcen in die Verzeichnisstruktur des LoxBerry ein, verändert oder erweitert aber ansonsten keinerlei Funktionen von Fhem.

    Viel Spaß beim Testen!
    Bitte stellt Eure Anfragen nicht per PN, ich bevorzuge das Fragen/Antworten im Forum, damit alle etwas davon haben. Vorher lesen: https://www.loxforum.com/forum/proje...en-bitte-lesen

    LoxBerry: https://www.loxwiki.eu/display/LOXBERRY/LoxBerry

  • #2
    Hallo,

    vielen Dank für die schnelle Umsetzung - endlich beide Server auf einem vereint. Werde dann heute mal das Razberry Modul für ZWAVE installieren.




    Loxone Miniserver / 1-Wire Extension / Air Base Extension, Tree Extension / Dimmer Extension / Debian Server, Raspberry

    Kommentar


    • #3
      Danke.

      Ich habe nun alles auf einen PI3 am laufen.
      Nur ein Problem habe ich auf einmal.

      Die Datei "myUtilsTemplate.pm" ist nach einem "update all" und einem "Shutdown" leer.
      Egal was ich mache die Datei ist danach immer wieder leer.

      Wenn ich "myUtilsTemplate.pm" speichere kommt die Meldung ERROR:

      Undefined subroutine &main::myUtilsTemplate_Initialize called at fhem.pl line 2315


      Kommentar


      • #4
        Das scheint ein Problem von FHEM zu sein: habe die Version auf dem Loxberry und eine weitere Installation ohne Loxberry laufen. Beide produzieren ebenfalls diesen Fehler.

        Kommentar


        • #5
          Kannst du mal den gesamten Inhalt Posten? Da ist wohl ein Fehler drinnen.

          Kommentar


          • #6
            Hallo,

            habe das Plugin gestern installiert. Leider erreiche ich die Webseite nicht. Egal, welchen Link ich anklicke. Die Seite lädt, aber nichts passiert. Egal wie lange ich warte. Hab es auf dem PC mit Chrome und Edge probiert und am Smartphone mit Chrome.

            Woran kann das liegen?

            Danke vorab und beste Grüße

            Horst

            Kommentar


            • #7
              Habe leider das selbe Problem wie Horst01...... Kann anklicken was ich will, ob Desktop oder Smartphone etc.... nix funktioniert. Habe ich vielleicht bei der Plugin installation was verkehrt gemacht oder braucht der Loxberry einen Restart nach der Installation?
              Anbei der Logfile
              Angehängte Dateien

              Kommentar


              • AlexAn
                AlexAn kommentierte
                Kommentar bearbeiten
                Kannst von dem ausgehen das bei jeder Plugin Installation ein Reboot fällig ist.
                Steht in der Regel auch im Update Prozess unten dabei.
                Läuft bei mit auf PI3 und PI2 einwandfrei.

              • dizzy85
                dizzy85 kommentierte
                Kommentar bearbeiten
                Hat sich erledigt.... Funktioniert jetzt auch bei mir.
                Da ich meinen Loxberry nach "außen" offen habe und ich das Plugin von außen installiert habe und ich dann auch von außen auf Fhem zugreifen wollte...Ging das natürlich nicht, da der Fhem -"Server" einen Port hat den ich nicht Freigegeben habe und so nur "zuhause" darauf zugreifen kann.
                Sind halt manchmal die einfachen Dinge die das Leben schwer machen. :-)
                Trotzdem Danke.....
                Zuletzt geändert von dizzy85; 20.Apr.2017, 13:30.

            • #8
              Guten Morgen,
              ich habe FHEM bis jetzt noch auf einer eigenen Maschine installiert und möchte das gerne mit auf den Loxberry umziehen.
              Installation und Einrichtung ist auch kein Problem soweit.

              Wenn ich aber über http einen Befehl auf der FHEM-Instanz des Loxberry ausführen möchte geht das nicht.
              Auf der FHEM-Maschine - in komplett gleicher Konfiguration - wird der Befehl akzeptiert.

              Kann das jemand bestätigen oder nachstellen?

              Gruß
              Jörg

              Kommentar


              • #9
                Welcher Fehler kommt denn?
                PN/PM: Ich bevorzuge die Beantwortung von Fragen in öffentlichen Threads, wo andere mithelfen und mitprofitieren können. Herzlichen Dank!

                Kommentar


                • #10
                  Liegt es vielleicht an den Änderungen in Version 5.8: "csrfToken: dieses FHEMWEB Attribut verhindert CSRF Angriffe, indem alle FHEMWEB-Aufrufe, die einen FHEM Befehl ausfuehren, das Token spezifizieren muessen"

                  Siehe auch https://forum.fhem.de/index.php?topic=67625.0

                  Gruss

                  roadrunnner

                  Kommentar


                  • #11
                    Am csrfToken könnte es wirklich liegen. die erste Instanz von FHEM läuft noch nicht auf 5.8. Werde ich heute Abend mal ausprobieren.
                    Christian Fenzl : es kommt gar kein Fehler. Der Befehl läuft einfach ins Nirvana.

                    Kommentar


                    • #12
                      Hallo!

                      ich habe das neue Image V1.0 installiert wollte darauf das Fhem Plugin installieren dabei habe ich folgende Probleme:
                      1. ich kann Fhem über das Plugin wie im Bild Anhang nicht starten wenn ich Fhem im Browser starte funktioniert Fhem.
                      2. Wenn ich den Fhem Service stoppe und wieder starte stürzt alles ab und dich muss den Raspberry 3 neu starten.
                      3. Wenn ich Loxberry update auf Version:1.0.3.2 besteht das selbe Problem.

                      LG
                      Bobo log datei install fhem.txt

                      Kommentar


                      • #13
                        Mhhh, Problem hatte ich hier nicht. Ich teste aich nochmal. Bitte mach mal folgendes:

                        - Image 1.0 installieren
                        - Upgrade auf 1.0.3.2 (Release) durchführen
                        - Erst dann: FHEM-Plugin installieren
                        Bitte stellt Eure Anfragen nicht per PN, ich bevorzuge das Fragen/Antworten im Forum, damit alle etwas davon haben. Vorher lesen: https://www.loxforum.com/forum/proje...en-bitte-lesen

                        LoxBerry: https://www.loxwiki.eu/display/LOXBERRY/LoxBerry

                        Kommentar


                        • #14
                          Hallo,

                          ich habe versucht
                          - Image 1.0 installiert ohne etwas selber auf dem Raspberry 3 gemacht und dann das Plugin Fhem installiert
                          - Image 1.0 installiert ohne etwas selber auf dem Raspberry 3 gemacht Upgrade auf 1.0.3.2 dann das Plugin Fhem installiert
                          hatte immer die selbe Probleme


                          Kommentar


                          • #15
                            Ok, ich schaue mal.
                            Bitte stellt Eure Anfragen nicht per PN, ich bevorzuge das Fragen/Antworten im Forum, damit alle etwas davon haben. Vorher lesen: https://www.loxforum.com/forum/proje...en-bitte-lesen

                            LoxBerry: https://www.loxwiki.eu/display/LOXBERRY/LoxBerry

                            Kommentar

                            Lädt...
                            X