Ankündigung

Einklappen

PLUGINS

Bitte im Titel immer zuerst den Namen des Plugins hinschreiben
Mehr anzeigen
Weniger anzeigen

LoxBerry: Fhem Plugin verfügbar

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • #31
    http://IP Loxberry:8083 damit du direkt auf FHEM kommst.
    oder
    http://IP Loxberry/admin/plugins/fhem/index.cgi um den Dienst vom Loxberry zu starten, stoppen usw.

    teste mal den virtuellen Ausgangsbefehl vom Miniserver aus:
    Adresse http://User@passwort@IP Loxberry
    Befehl bei ein /admin/plugins/fhem/index.cgi?do=restart
    AlexAn
    Lebende Foren Legende
    Zuletzt geändert von AlexAn; 23.09.2018, 08:02.
    Grüße Alex

    Kommentar


    • #32
      Hi Alex,
      danke für die schnelle Rückmeldung.

      Die Möglichkeit über die Weboberfläche und vom Miniserver aus meinte ich nicht.
      Ich suche den Pfad (vgl. root@loxberry:/etc/init.d/ $), den ich dem Plugin "monit" in der "monitrc" angeben kann, also im loxberry OS via telnet (z.B. putty etc.).
      Der Befehl würde dann Beispielsweise so aussehen "/etc/init.d/fhem stop" und "/etc/init.d/fhem start" - nur halt mir dem passenden Pfad beim loxberry, den ich leider nicht finde.

      Kommentar


      • #33

        https://github.com/mschlenstedt/LoxB.../index.cgi#L85

        Das ist der Command, der im WebIf ausgeführt wird.
        Die Variablen sind /opt/loxberry und fhem.

        lg, Christian
        LoxBerry/Plugin Support: Wenn du einen Begriff in meiner Antwort nicht auf Anhieb verstehst, bitte nicht gleich rückfragen, sondern erst die Suche im LoxWiki und bei Google bemühen.
        PN/PM: Ich bevorzuge die Beantwortung von Fragen in öffentlichen Threads, wo andere mithelfen und mitprofitieren können. Herzlichen Dank!

        Kommentar


        • #34
          Hallo Christian,
          perfekt! Das ist´s, was ich gesucht habe.
          Danke und Gruß Marcus

          Kommentar


          • #35
            erledigt
            Zuletzt geändert von t_heinrich; 09.12.2018, 15:56.

            Kommentar


            • #36
              Ich benutzte FHEM hauptsächlich für meine Max Thermostate, leider verlieren die alle nach dem Neustart des Loxberry viele Einstellungen wie ihr Wochenprofil. Angeblich könnte es an fehlenden Rechten des Benutzers liegen unter dem das FHEM läuft, das kann ja nur der User loxberry sein, weil ich sehe keinen FHEM User im Loxberry oder?

              Kommentar


              • Christian Fenzl
                Christian Fenzl
                Lebende Foren Legende
                Christian Fenzl kommentierte
                Kommentar bearbeiten
                Wo sind diese Sachen denn gespeichert?

              • andylox
                andylox kommentierte
                Kommentar bearbeiten
                Soweit ich das sehen kann in der FHEM.save unter log/plugins/fhem, aber die restlichen Sachen bleiben ja da, also beim Rechte Problem wäre es doch alles da oder nicht da aus meiner Sicht.

              • svethi
                svethi
                Lebende Foren Legende
                svethi kommentierte
                Kommentar bearbeiten
                Was haben Einstellungen im Logverzeichnis zu suchen? Das Logverzeichnis liegt aus Haltbarkeitsgründen der SD Karte nur im RAM und ist tatsächlich alles nach Neustart weg. Das müsste ins config/plugins/fhem

            • #37
              Das ist offenbar in der Standardconfig so drin:
              attr global statefile /opt/loxberry/log/plugins/fhem/fhem.save

              Ich mach bei Michael einen Issue.
              LoxBerry/Plugin Support: Wenn du einen Begriff in meiner Antwort nicht auf Anhieb verstehst, bitte nicht gleich rückfragen, sondern erst die Suche im LoxWiki und bei Google bemühen.
              PN/PM: Ich bevorzuge die Beantwortung von Fragen in öffentlichen Threads, wo andere mithelfen und mitprofitieren können. Herzlichen Dank!

              Kommentar


            • #38
              Also hab das File unter config gelegt mit dem Befehlt:
              attr global statefile /opt/loxberry/config/plugins/fhem/fhem.save

              Loxberry neugestartet und alles ist noch da! Danke für die Hilfe!
              Zuletzt geändert von andylox; 19.12.2018, 14:02. Grund: Falscher Pfad

              Kommentar


            • #39
              Das ist sicherlich meine Schuld. Das Plugin stammt noch aus der 0.2.3er Zeit. Da lag "log" noch nicht in der Ramdisk. Der richtige Ort ist "config" oder "data". Ich passe das an.
              Kein Support via PN - bitte stellt eure Fragen im Forum!

              Kommentar


              • #40
                Version 0.4 des Plugins behebt das Problem: https://github.com/mschlenstedt/LoxB...eleases/latest
                Kein Support via PN - bitte stellt eure Fragen im Forum!

                Kommentar


                • #41
                  Hallo,
                  danke erstmal für das PlugIn. Vorweg, ich bin kompletter Laie auf dem FHEM Gebiet.

                  Leider bekomme ich folgenden Fehlermeldung im Browser wenn ich FHEM im Desktop aufrufen will.
                  Restart bringt nichts und den Port vom Loxberry habe ich auch schon geändert.
                  Forbidden

                  You don't have permission to access /fhem on this server.


                  Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.


                  Apache/2.4.25 (Raspbian) Server at 10.0.0.195 Port 8083


                  Danke für die Hilfe.

                  Kommentar


                  • Prof.Mobilux
                    Prof.Mobilux
                    Supermoderator
                    Prof.Mobilux kommentierte
                    Kommentar bearbeiten
                    Bist Du über den Link auf der Pluginseite gegangen?

                  • ogrimo30
                    ogrimo30
                    Extension Master
                    ogrimo30 kommentierte
                    Kommentar bearbeiten
                    Ja über den Button " Fhem aufrufen (Dektop)".
                    10.0.0.195 ist die IP des Loxberrys mit dem Standard Port 8080

                    Log:
                    2018.12.20 16:37:13 1: Including /opt/loxberry/config/plugins/fhem/fhem.cfg
                    2018.12.20 16:37:13 3: telnetPort: port 7072 opened
                    2018.12.20 16:37:14 1: WEB: Can't open server port at 8083: Address already in use. Exiting.

                    Leider weiß ich nicht wo der Port schon verwendet werden sollte?
                    ogrimo30
                    Extension Master
                    Zuletzt geändert von ogrimo30; 20.12.2018, 16:40.

                • #42
                  8083 „gehört mir“ - da sitz ich glaub ich mit dem Squeezelite Plugin

                  EDIT: Nein, doch nicht, ich bin im 9000er-Bereich unterwegs
                  Christian Fenzl
                  Lebende Foren Legende
                  Zuletzt geändert von Christian Fenzl; 20.12.2018, 18:44.
                  LoxBerry/Plugin Support: Wenn du einen Begriff in meiner Antwort nicht auf Anhieb verstehst, bitte nicht gleich rückfragen, sondern erst die Suche im LoxWiki und bei Google bemühen.
                  PN/PM: Ich bevorzuge die Beantwortung von Fragen in öffentlichen Threads, wo andere mithelfen und mitprofitieren können. Herzlichen Dank!

                  Kommentar


                  • #43
                    Camstream4Lox drauf?
                    Kein Support via PN - bitte stellt eure Fragen im Forum!

                    Kommentar


                    • #44
                      Das waren die Standardports von FHEM, das kann man aber bestimmt umkonfigurieren. Leider kenne ich mich überhaupt nicht mit FHEM aus (habe es nie benutzt). Ich hab damals nur das Plugin zusammengebaut ;-)
                      Kein Support via PN - bitte stellt eure Fragen im Forum!

                      Kommentar


                      • #45
                        Hallo,

                        zur Info >> hab mal die 0.4 Version auf Raspberry 3 mit Loxberry 1.2.5.5 installiert und komme auch nicht aufs Webinterface.

                        Kommentar

                      Lädt...
                      X