Ankündigung

Einklappen

PLUGINS

Bitte im Titel immer zuerst den Namen des Plugins hinschreiben
Mehr anzeigen
Weniger anzeigen

LoxBerry: Fhem Plugin verfügbar

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • #46
    Und? Welche Plugins sind denn noch installiert?
    Kein Support via PN - bitte stellt eure Fragen im Forum!

    Kommentar


    • #47
      Hi
      Prof.Mobilux
      Supermoderator
      Prof.Mobilux

      in meinem Fall diese hier. Eingerahmt mal die PlugIns die ich "wirklich" nutze.

      Kommentar


      • #48
        Nutze folgende Plugins.

        LoxBerry v1.2.5.5.
        Fhem 0.3

        Alle anderen Plugins sollten auch aktuell sein.
        ogrimo30
        Extension Master
        Zuletzt geändert von ogrimo30; 20.12.2018, 21:56.

        Kommentar


        • #49
          Also haben wir folgende Übereinstimmungen:
          • FHEM
          • Weather
          Weather verwendet meines Wissens keinen In-Port, also ist wohl FHEM Schuld ;-)

          Ich hab gerade auf einem frischen LB das FHEM-Plugin installiert, und das funktioniert ganz normal.

          LoxBerry/Plugin Support: Wenn du einen Begriff in meiner Antwort nicht auf Anhieb verstehst, bitte nicht gleich rückfragen, sondern erst die Suche im LoxWiki und bei Google bemühen.
          PN/PM: Ich bevorzuge die Beantwortung von Fragen in öffentlichen Threads, wo andere mithelfen und mitprofitieren können. Herzlichen Dank!

          Kommentar


          • #50
            Mir ist heute noch folgendes aufgefallen:

            Wenn ich Fhem starte und dann zurück zur Plugin-Verwaltung gehe und dann wieder ins Plugin rein, ist Fhem gestoppt.

            Ist das normal?

            Kommentar


            • #51
              Hallo zusammen,

              habe leider auch ein kleines Problem.
              Ich habe heute versucht auf meinem Loxberry 1.2.5.5 das aktuelle FHEM Plugin zu installieren.
              Dies lief auch problemlos durch.
              Keinerlei Fehler und laut Log ist der Webserver auch unter 8083 bis 8085 geöffnet. (HABridge läuft unter 8080, Loxberry unter 80)
              Leider komme ich nicht auf FHEM, weder über die Buttons, noch direkt im Browser.
              Status ist running mit eine PID welche nach einem Neustart wechselt.
              Kann das eventuell am Weather Emulator liegen?
              Jemand eine Idee?

              Grüße und Danke vorab
              Sascha
              Angehängte Dateien

              Kommentar


            • #52
              Kann mir keiner helfen?

              Beste Grüße,
              ogrimo30

              Kommentar


              • #53
                Wie kriege ich die Daten von FHEM auf mein Miniserver? Gibt es hier eine einfache Anleitung? Muss ich alles regelmässig per TCP pollen?

                Kommentar


              • #54
                ogrimo30
                Extension Master
                ogrimo30
                t_heinrich
                Was sagt denn bei euch das Log? Startet FHEM laut Log? Dort stehen auch die Ports drin, die verwendet werden, oder wenn die belegt wären.

                lg, Christian

                PS: Bitte schreibt bei offenen Problemen unten dran im Thread. Kommentare auf Beiträge, die zwei Seiten zuvor waren, sind wie Randnotizen, die nie wieder gefunden werden.
                LoxBerry/Plugin Support: Wenn du einen Begriff in meiner Antwort nicht auf Anhieb verstehst, bitte nicht gleich rückfragen, sondern erst die Suche im LoxWiki und bei Google bemühen.
                PN/PM: Ich bevorzuge die Beantwortung von Fragen in öffentlichen Threads, wo andere mithelfen und mitprofitieren können. Herzlichen Dank!

                Kommentar


                • #55
                  Log:

                  2019.01.02 22:14:22 1: Including /opt/loxberry/config/plugins/fhem/fhem.cfg
                  2019.01.02 22:14:22 3: telnetPort: port 7072 opened
                  2019.01.02 22:14:22 1: WEB: Can't open server port at 8083: Address already in use. Exiting.
                  2019.01.02 22:15:51 1: Including /opt/loxberry/config/plugins/fhem/fhem.cfg
                  2019.01.02 22:15:51 3: telnetPort: port 7072 opened
                  2019.01.02 22:15:51 1: WEB: Can't open server port at 8083: Address already in use. Exiting.
                  ​​​​​​
                  Wenn ich Fhem starte und dann zurück zur Plugin-Verwaltung gehe und dann wieder ins Plugin rein, ist Fhem gestoppt.

                  FHEM sollte ja dauernd laufen oder?

                  Kommentar


                • #56
                  Christian Fenzl
                  Lebende Foren Legende
                  Christian Fenzl

                  Hier mal mein Log, hatte es die letzten Tage nicht weiterverfolgt, da ich mich mit anderen Loxberry Plugins beschäftige.

                  Code:
                  2018.12.30 19:50:04 1: Including /opt/loxberry/config/plugins/fhem/fhem.cfg
                  2018.12.30 19:50:04 3: telnetPort: port 7072 opened
                  2018.12.30 19:50:05 3: WEB: port 8083 opened
                  2018.12.30 19:50:05 3: WEBphone: port 8084 opened
                  2018.12.30 19:50:05 3: WEBtablet: port 8085 opened
                  2018.12.30 19:50:05 2: eventTypes: loaded 0 events from /opt/loxberry/log/plugins/fhem/eventTypes.txt
                  2018.12.30 19:50:05 1: usb create starting
                  2018.12.30 19:50:06 3: Probing CUL device /dev/ttyAMA0
                  2018.12.30 19:50:06 3: Probing TCM_ESP3 device /dev/ttyAMA0
                  2018.12.30 19:50:06 3: Probing FRM device /dev/ttyAMA0
                  2018.12.30 19:50:11 3: Probing TCM_ESP3 device /dev/ttyUSB0
                  2018.12.30 19:50:12 3: Probing TCM_ESP2 device /dev/ttyUSB0
                  2018.12.30 19:50:12 3: Probing FHZ device /dev/ttyUSB0
                  2018.12.30 19:50:12 3: Probing TRX device /dev/ttyUSB0
                  2018.12.30 19:50:13 3: Probing ZWDongle device /dev/ttyUSB0
                  2018.12.30 19:50:14 3: Probing FRM device /dev/ttyUSB0
                  Ich habe Loxberry Version 1.4.0.2 und Plugin Version 0.4
                  Hier noch eine Übersicht meiner Plugins:


                  Kommentar


                • #57
                  Dank Teamviewer und der super Unterstützung von
                  Christian Fenzl
                  Lebende Foren Legende
                  Christian Fenzl konnte das Problem behoben werden, wieso sich das Webinterface von FHEM bei mir nicht öffnete.
                  Schuld war der USB-Lesekopf für den Stromzähler.
                  Aus irgendeinem Grund verschluckt sich FHEM beim Start dabei.
                  Sobald der Lesekopf ausgesteckt war, lies sich FHEM problemlos starten.

                  Um das Problem künftig zu vermeiden, muss innerhalb von FHEM in der fhem.cfg die letzte Zeile auskommentiert werden:

                  Code:
                  # Disable this to avoid looking for new USB devices on startup
                  # define initialUsbCheck notify global:INITIALIZED usb create
                  Danach funktionniert FHEM auch mit angeschlossenem USB-Lesekopf.

                  @christian: das nächste Bier geht definitiv auf mich.

                  Kommentar


                  • Prof.Mobilux
                    Prof.Mobilux
                    Supermoderator
                    Prof.Mobilux kommentierte
                    Kommentar bearbeiten
                    Das könnte ich per Default machen. Ist das sinnvoll?

                  • t_heinrich
                    t_heinrich kommentierte
                    Kommentar bearbeiten
                    Gute Frage. Ich hatte mich (aus technischer Sicht) eher gewundert, wieso FHEM wegen einem USB Gerät nicht korrekt startet - ich hätte erwartet, dass das USB-Device dann einfach ignoriert wird und es dann eine Fehlermeldung gibt.
                    So gesehen ist es evtl. nicht verkehrt es per Default zu deaktivieren, jmd der sich mit FHEM dann beschäftigt muss sowieso die Komfortzone "Loxberry" verlassen und kann es dann ja wieder in der fhem.cfg aktivieren.
                    Just my 2 cents. ;-)

                • #58
                  Es gibt nun Version 0.5.0 des Plugins. Es wurden nur Anpassungen auf Grund des neuen Loxberry 2.0 gemacht. FHEM wird nun nicht mehr unterhalb von /opt/loxberry installiert, sondern im Standardverzeichnis /opt/fhem. Auch die fhem-Konfiguration liegt nun an diesem Standardort.

                  Für bestehende User besteht kein Grund zum Update! die Installationen laufen ohne Probleme weiter. FHEM kümmert sich um seine updates selbst!
                  Kein Support via PN - bitte stellt eure Fragen im Forum!

                  Kommentar


                  • #59
                    Also auch wenn ich auf Loxberry 2.0 Update, kann ich bei Version 0.4.3 bleiben. Oder was passiert wenn ich doch update auf Version 0.5.0?

                    Kommentar


                  • #60
                    Nach Update auf Loxberry 2.0 sind leider alle meine Geräte weg, FHEM ist im "Auslieferungszustand".
                    Ich habe vor Update auf 2.0 ein Backup vom kompletten Loxberry gemacht: Was ist nun der beste Weg um meine Einstellungen und Geräte wiederherzustellen? Backup zurück spielen? Wie nehme ich am besten die Einstellungen rüber zu 2.0?

                    Kommentar

                    Lädt...
                    X