Ankündigung

Einklappen

PLUGINS

Bitte im Titel immer zuerst den Namen des Plugin hinschreiben
Mehr anzeigen
Weniger anzeigen

Alexa<->Lox

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Alexa<->Lox

    Anbei das Plugin für Alexa...

    Beschreibung ist im Plugin rechts oben unter i

    ACHTUNG!!!!!! Plugin funktioniert nur über die DE Anmeldeseite https://alexa.amazon.de Alle Alexas die sich über https://pitangui.amazon.com anmelden bekommen keine Daten retour und es können keine Befehle abgesetzt werden (Captscha Abfrage)

    Important information!!!!! Plugin works only via the DE login page https://alexa.amazon.de All Alexas who log in via https://pitangui.amazon.com get no data back and no commands can be issued (Captcha query)

    Wenn man zu oft auf die Alexaseite zugreift (vor allem beim Einrichten) kann es sein das man von Amazon gesperrt wird, dann bitte am nächsten Tag noch einmal probieren .


    Update 18.06.18

    alexaloxv0.10a.zip als Plugin

    alexa_remote_control.zip oder nur die veränderte Datei, die Datei braucht nur ausgetauscht werden ( /opt/loxberry/webfrontend/cgi/plugins/alex2lox/ ) man muß nicht das ganze Plugin neu installieren

    Bitte testen und Rückmelden, Ich hatte leider wenig Zeit es ausführlich zu testen


    Neuer Befehl /admin/plugins/alex2lox/Alexa.php?daten= -d Esszimmer -e speak:'Guten_Appetit!'


    Infos über Alexa2Lox 2.0 hier http://www.loxwiki.eu/display/LOXBERRY/Alexa2Lox+2.0

    Update 24.06.18
    wie oben nur ohne Ram-Disk

    Update 27.10.18

    alexaloxv0.10b

    Fehlerhaften Chmod Befehl entfernt, brachte neue Loxberry Version zum Absturz


    Update 07.02.19

    alexaloxv3.0.0
    Infos unter https://www.loxwiki.eu/pages/resumed...1-94283af8ff23

    DownloadLink
    http://www.gem-net.at/Loxberry/alexalox3.0.1.zip
    Zuletzt geändert von Peter B; 09.Feb.2019, 11:07.

  • #2
    Top danke werde ich mal testen!

    gruss

    Kommentar


    • #3
      Spitze, Danke! Was jetzt noch top wäre ist eine Sprachausgabe von Texten die man in der LoxConfig konfiguriert. Das wäre dann die ideale Speechout Funktion für Nachrüster :-)

      Kommentar


      • #4
        Hallöchen.... Funktioniert soweit ganz prima.
        Aber wie muss ich die virtuellen Ausgänge am Miniserver anlegen wenn ich dem Loxberry einen bestimmten Track spielen lassen will auf Alexa?

        Habe Quasi bei Amazon kleine MP3´s mit Text to Speech angelegt (z.B. "Fenster geöffnet" oder "Tür geöffnet" etc.) Diese wollte ich nun vom Miniserver über das Alexa-Lox-Plugin auf Alexa laufen lassen.

        Wenn ich die Url (http://loxberry/admin/plugins/alexal...-xx&Volume=100) normal in den Browser hacke funktioniert das auch Prima, nur bekomme ich es nicht hin das ganze per virtuellen Ausgang am Miniserver zum laufen zu bringen.....?!
        Angehängte Dateien

        Kommentar


        • dizzy85
          dizzy85 kommentierte
          Kommentar bearbeiten
          Hat sich erledigt..... Muss der Url in den virtuellen Ausgängen mein benutzername u. passwort mitgeben dann gehts :-)

        • Muto
          Muto kommentierte
          Kommentar bearbeiten
          Benutzername und Passwort für den Loxberry?

        • dizzy85
          dizzy85 kommentierte
          Kommentar bearbeiten
          Jupp....
          quasi so http://benutzername:passwort@loxberr...-xx&Volume=100)
          kann aber daran liegen das ich in den Plugin-Einstellungen meine Miniserver Daten nicht eingegeben habe.... möchte eigentlich Alexa nur "Steuern" und nicht Alexa in Loxone "Visualisieren"

      • #5
        Da das Abspielen/Hochladen von eigenen Track´s (MP3´s) bei Amazon ziemlich bescheiden ist....
        Weil 1.Prime benötigt wird und 2. nur 250 Tracks hochladbar sind bin ich auf der Suche nach einer Möglichkeit, Alexa Tracks´s von meiner NAS spielen zu lassen und das ganze per Loxberry/Miniserver zu steuern.
        Bin aber bei der Suche hier https://www.amzecho.de/viewtopic.php...lit=nas#p16418 zum erliegen gekommen.
        Hat von euch vielleicht noch einer eine Idee wie man Alexa sagen könnte das Sie gesteuert von Loxone, Tracks von einem NAS abspielt.
        Sollte das irgendwie machbar sein hätte man mittels Alexa<-> Loxone eine gute Mutlirom-Lösung für relativ überschaubares Geld und wäre eine Alternative zum Loxone-Musikserver oder MusicServer4Lox.........
        Zuletzt geändert von dizzy85; 30.Mär.2017, 12:31.

        Kommentar


        • Muto
          Muto kommentierte
          Kommentar bearbeiten
          So viel ich weiß kann Alexa nichts von lokalen Quellen spielen

      • #6
        Hi Peter, ich wollte gerade auf die schnelle mal eine zeitgesteuerte Lautstärke-Einstellung meiner Echo/Dots konfigurieren und mich dann im Laufe des Wochenendes mit Text2speech beschäftigen.

        Ich musste zwar einige Passagen der Anleitung mehrfach lesen aber ich denke ich habe letztlich alles korrekt eingestellt.

        Bei dem von dir vorgeschlagenen Testaufruf bekomme ich jetzt folgende Rückmeldung

        Code:
        B&B Technik OG: Alexa <-> Lox
        -------------------------------------------------------------------------------------------------------------------------------------
        
        
        
        Device
        
          Interpret:/opt/loxberry/webfrontend/cgi/plugins/alexalox      
        
        
         Interpret:/opt/loxberry/webfrontend/cgi/plugins/alexalox  
        
        Uebergebene Befehle:  
        
        Sender: s25217
        Volume: 20
        Track: Playlist:
        Befehl:  
        
        Infos aus Datei:  
        
        alexalox    
        
        
         Interpret:/opt/loxberry/webfrontend/cgi/plugins/alexalox  
        
        Status....Done. />
        Leider wird aber weder die Lautstärke auf 20 gestellt, noch das Radio gestartet. Hast du eine Idee woran es liegen könnte?

        Gruß
        Muto

        P.S. Würdest du für das Plugin evtl ein GitHub Projekt einstellen? Würde mich dann gerne etwas am Frontend beteiligen.
        Zuletzt geändert von Muto; 31.Mär.2017, 11:01.

        Kommentar


        • #7
          Funktioniert es einzeln? wie sieht der Befehlsaufruf vom Miniserver aus?

          Kommentar


        • #8
          Starte mal einen Radiosender über die App und schau ob Du im Infofenster xx.xx.xx.xx./admin/plugins/alexalox/index.cgi irgendwelche Rückmeldungen bekommst. geht Irgendein Befehl?

          Kommentar


          • Peter B
            Peter B kommentierte
            Kommentar bearbeiten
            Das kann schon möglich sein, Ich habs grad bei mir gelöscht und neu installiert mit der aktuellen Version, bei mir funktionieren die Befehle

          • Muto
            Muto kommentierte
            Kommentar bearbeiten
            Ok dann belassen wir es mal dabei und ich teste es übers WE auf dem Raspberry

          • Muto
            Muto kommentierte
            Kommentar bearbeiten
            Am Raspberry reagiert er genau gleich. Kommandos werden nicht übertragen, Sender und Titel werden korrekt angezeigt, die Lautstärke aber falsch.

        • #9
          Hast Du das vom Beitrag #8.6 am Raspberry schon versucht?

          Kommentar


          • Muto
            Muto kommentierte
            Kommentar bearbeiten
            Nein, probiere ich heute Abend

        • #10
          Hallo Peter ....
          Gibt es eine Möglichkeit per virtuellen Ausgang am Miniverserver alle vorhandenen "Alexa´s" zusteuern, also Quasi z.B einen Zentralruf (Alarm oder Essen is fertig etc.) zu konfigurieren?
          Im Moment müsste ich ja für jede Alexa einzeln den entsprechenden Befehl konfigurieren.

          Kommentar


          • #11
            Nein, ist nicht vorgesehen.....

            Kommentar


            • #12
              Hallo Peter....
              Habe seid Heute das Problem das egal wieviele oder welche Alexa ich anlegen will im Plugin,dass Plugin immer zu Bezug auf Alexa NR.1 nimmt und alles auch nur auf Alexa Nr.1 abspielt egal welche Alexa ich im Befehl (Zum Aufruf des 2. Echo muss jeweils der Ordner /2 vorgestellt werden / egal ob 2 oder oder 4) steuern will....
              Habe schon versucht die Alexa´s neu zu Installieren im Plugin aber egal was ich eingebe nimmt das Plugin immer zu Bezug auf NR.1. --- devicenamme, devicenummer, etc....
              Habe nichts an den Einstellungen geändert so.....? Hast du vielleicht eine Idee?
              Angehängte Dateien

              Kommentar


              • dizzy85
                dizzy85 kommentierte
                Kommentar bearbeiten
                Lösche ich alle Alexa`s im Plugin und lege nur eine (immer nur 1) an funktioniert jede der Alexas die ich habe... wenn ich Sie nacheinander anlege und wieder lösche...
                Aber sobald 2 bzw 3 gleichzeitig anlege bzw läuft nimmt das Plugin jedesmal die Daten der ersten Alexa.... Irgendwie passt hier was mit der zuordnung im Plugin nicht. Ich kenne mich leider mit Linux nicht aus um tiefgehender zu suchen.
                Die Alexa´s laufen ohne das Plugin ganz normal und spielen über Amazon-Music auch das ab, was sie sollen bzw. passen auch im Browser die Devicenummern etc...
                Hoffe du kannst mir weiter helfen...
                Zuletzt geändert von dizzy85; 23.Apr.2017, 18:53.

            • #13
              Hi
              Habe jetzt auch mal dein Plug-In getestet. Funktioniert Teilweise.
              Abspiele des Gewünschten Senders Funktioniert. Volume ändern geht auch, aber Alexa hört z.B nicht auf den Pause Befehl. Laut Web Rückmeldung Befehl Pause Aktiv.
              Musik lauft weiter und auf der Alexa-Info.php ist auch noch Playing. Gibt's auch einen Stopp Befehl ?

              Bei den Daten die zum Miniserver Übertragen werden ,funktionieren Volume und Status nicht. Bei Status kommt nur eine 1, anstatt Playing

              Nicht getestet Shuffle und Repeat.

              Kommentar


              • #14
                Hallöchen......
                Möchte nochmal kurz ein Feadback zu meinem oben genannten Problem geben...
                Ich habe Loxberry jetzt nochmal komplett Platt gemacht und nochmal neu Aufgesetzt.
                Alexa-Lox neu Installiert und 2 Dot´s eingerichtet. Funktionieren bei "Ersteinrichtung" auch tadellos.
                Lösche ich aber jetzt z.B Dot Nr.2 oder 4 etc. und lege Ihn wieder neu an nimmt das Plugin immer wieder bezug auf Alexa Nr. 1 und übernimmt die Daten von Alexa Nr.1

                Dies habe habe ich mehrmals probiert und in der config.txt -Datei unter webfrontend/cgi/alexalox/ kontrolliert.
                Hier trägt das Plugin tatsächlich die ID-Device-Numer von Alexa Nr. 1 ein und auch das Cookie wird von Nr.1 genommen.

                Trage ich nun manuell per Filezilla die richtigen Daten in die config.txt für die Entsprechende Alexa (Nr.2...4....7) funtioniert die Zuordnung wieder und die "richtige" Alexa spielt das Ab was sie soll bzw. kann gesteuert werden. Zwar wird dann im Plugin (Weboberfläche) statt der richtigen Devicenummer(Amzazon-Nr.) vom Dot nur die entsprechende Nummer (also 2...3...7 etc) angezeigt (siehe Bild oben) aber sie macht erstmal wieder das was sie soll.
                Vielleicht könnte das jemand nachvollziehen oder ausprobieren ob es sich bei euch auch so verhält?!
                Denke das hier ein Bug im Plugin vorliegt der bei zweit oder dritt installation einer Alexa die Zuordnungen der Daten durcheinander bringt oder so etwas.
                Was mir auch aufgefallen ist dass das Plugin nach einer sporadischen Zeit von ca. 1Woche extrem langsam wird und sehr sehr langsam reagiert. (Alle anderen Plugins Laufen sauber und schnell auf meinem Loxberry).... hier hilft nur die Abhilfe.... Alexalox zu löschen und neu aufsetzen und wieder einrichten...
                Bin jetzt Absolut kein Linux-Experte aber vielleicht kann hier Peter B nochmal drüber schauen und hat vielleicht doch noch eine Idee...?
                Zuletzt geändert von dizzy85; 11.Mai.2017, 08:02.

                Kommentar


                • #15
                  Für alle die das AlexLox Plugin für den Loxberry nutzen.
                  Nicht wundern wenn Alexa nach ca. 3- 4 Wochen nicht mehr "spricht".
                  Habe jetzt nach längerm probieren heraus gefunden das das "Anmelde-Cookie" was ihr in der Config im Plugin eingebt (dieser ewig Lange string) nur eine bestimmte Zeit bzw Zyklen gültig ist. Und dann wieder neu ausgelsen und wieder eingegeben werden muss.
                  Hierfür gibt es aber leider noch keine Lösung.
                  Also falls Alexa übers Plugin nicht mehr mit euch reden möchte....Cookie erneuern. Habe mir daran fast einen Wolf gesucht und probiert und probiert

                  Kommentar

                  Lädt...
                  X