Ankündigung

Einklappen
Keine Ankündigung bisher.

Loxone Automatikjalousie und KNX

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • #31
    Ich glaube ich habe nun für mich eine brauchbar Lösung gefunden meine MDT KNX Raff Aktoren mit dem Automatikjalousie Bausstein von Loxone zu verbinden.
    Meine Anforderungen war, die komplette Kontrolle der Loxone Automatikjalousie zu geben, jedoch trotz der KNX Timing Herausforderung die Lamellenstellung passend hin zu bekommen, hierbei sollte jedoch die manuelle Steuerung über die Eingänge Up/Dw am Autojalo Baustein noch grundsätzlich funktionieren, mal von Verzögerungen bei der manuellen Verstellung durch den KNX Bus abgesehen.

    Die für mich nun beste Lösung war, die Positionshöhe und die manuelle Verstellung über Up / Down am Aktor direkt zu machen, wohlweislich, daß durch Bustiming es gegebfalls mal nicht stimmen wird. Bei der Höheeinstellung fällt das nicht wirklich auf, und beim manuelle verstellen der Lamellen (kurzes antickern) sieht man ja sofort ob es passt oder nicht.
    Die Lamellenverstellung im Automatik Betrieb läuft jedoch über die direkte Lamellenpositionsvorgabe von dem Automatikjalousiebaustein an den Aktor somit stimmt diese so gut, wie es der KNX Aktor selbst eben intern kann. (mein MDT Aktor macht das bisher wirklich gut, passene Timing Einstellungen im Aktor vorausgesetzt)

    Wie man in der Konfig sieht, benötigt man auch Infos aus dem Aktor (zumindest bei meinen MDT), in diesen Fall ob die Jalo gerade fährt oder nicht. Abhängig davon wird der Stopp am Aktor entsprechend getriggert oder nicht, da im Stillstand der Stopp Eingang zu einer Kurzfahrt führen würde.

    In der Autojalo Konfig habe ich Tdt, Tot h auf 0 gesetzt und M möglichst kurz da dies eh vom MDT Aktor sichergestellt wird, in der Loxone Logik die Pegel an den Ausgängen "Q-up" und "Q-down" jedoch möglichst schnell wieder resetet werden sollen, damit beim Lamellen verstellen nicht erst über die up/down Befehle und dann anschließend nochmal per Absolut-Lamellen-Positions Vorgabe gefahren wird.

    Alle anderen Angaben sind entsprechend den echten Verhältnissen anzupassen,
    auch im MDT Aktor, hier ist es wirklich wichtig, das die Timings jeweils sehr gut passen.

    Klicke auf die Grafik für eine vergrößerte Ansicht  Name: LoxConfig_KNXJalo_V2.JPG Ansichten: 0 Größe: 61,0 KB ID: 211008

    Klicke auf die Grafik für eine vergrößerte Ansicht  Name: LoxConfig_KNXJalo2.JPG Ansichten: 0 Größe: 76,3 KB ID: 211009

    Grundsätzlich hatte ich nun auch schon wesentlich kompliziertere Logiken erdacht und getestet, nur benötigten die jeweils so viel Platz im MS, daß ich nicht alle 23 Raffstores umsetzen konnte. Ebenso war die Wartung und Fehlersuche ein echtes Abenteuer.

    Achtung !!!
    Ich hab noch vergessen zu erwähnen, daß am Aktor für die GA der Lamellenverstellung in der Loxone Config eine "Korrektur" von 0,0 zu 1,100 eingestellt werden muß, da der Lamellen Ausgang des AutoJalo Bausteins 0 bis 1 liefert, der Aktor jedoch 0 bis 100 möchte.

    Nachtrag: (Danke an TomT für den Hinweis, siehe Kommentare unten)
    -die Monoflop Zeit habe ich auf 0.1s gestellt.
    -Wenn man im MDT Aktor die Einstellung (ETS) so vornimmt, daß das Objekt für den Verfahrstatus als 1 Objekt ausgegeben wird, kann man sich das "UND" ,also die Zusammenführung der zwei Objekte in der Loxone Config sparen.


    Noch ein Wichtiger Hinweis:
    Nach einer Änderung bzw. Neustart des Miniservers während die Jalos nicht ganz offen sind, muß man erst mal alle Jalos manuell ganz nach oben fahren bevor man die Autmatikbeschattung aktiviert oder reaktiviert um die Funktion zu prüfen. Also nicht wunder wenn nach dem Änderungen und Restart erst mal nichts passt/funktioniert. Ansonsten halt auf die nächste Beschattungsperioden Änderung warten (morgend oder Abdends) dann passiert das ja automatisch.
    Beim Testen möchte ich aber üblicherweise nicht solange warten ;-)

    Zuletzt geändert von Labmaster; In den letzten 2 Wochen.

    Kommentar


    • Labmaster
      Labmaster kommentierte
      Kommentar bearbeiten
      @TomT
      1. Ja, sorry, Monoflop hab ich auch auf 0,1 jedoch anscheinenend vergessen oben anzugeben.
      2. das stimmt, Ich hatte schon seit längerem alle KNX Adressen in die ETS Exportiert (mittlerwileüber 1000GA's und es werden zukünftig wohl noch mehr ) und damals beim Export nicht alle KO's des MDT Aktors mit aufgenommen. Daran ,nochmal in der ETS nachzusehen ob es einen kombinierten Status gibt, hab ich gar nicht mehr gedacht,
      Danke dafür.

      AQpp, kannste total vergessen, der liefert m.M nach Müll.
      Ursprüngich wollte ich ja alleine darüber alles machen, aber Loxone hat den anscheinend während laufender Weiterentwicklung kaputt programmiert. Beim manuellen Fahren gibt der als Befehl immer 1 raus, bei der Automatik dann nur noch 3 ohne vorher per 1 oder 2 die Behanghöhe angefahren zu habe. Während der Automatik bleibt der 3er Befehl dann auch noch von der Lamellenposition unnverändert, erst wenn man die Automatik stoppt und wieder aktiviert zieht er die Lamellenposition nach. in manchen anderen Fällen kommt meiner meinung nach nur noch Mist raus.
      Da der AQpp je eigentlich obsolete ist, da es ja denn speziellen "Automatikjalousie Integriert" Bausstein gibt, über welchen Loxone aber die Komunikation mit den Geiger Motoren intern im Hintergrund ablaufen läßt, gehe ich mal davon aus, daß Loxone auch gar keine Interesse daran hat, daß der AQpp überhaupt funktioniert. Würde ja nur Fremdhardware supporten :-(
      Zuletzt geändert von Labmaster; In den letzten 2 Wochen.

    • kitikonti
      kitikonti kommentierte
      Kommentar bearbeiten
      Vielen Dank auch von meiner Seite. Toll das nicht immer alle nur ihre Probleme posten, sondern dann letztendlich auch die funktionierende Lösung. Ganz verstanden habe ich es noch nicht, aber das wird sich vermutlich von selbst klären, wenn ich das nachbaue. Komm vermutlich in den nächsten Tagen/Wochen irgendwann dazu das ich mir das näher ansehe. Aktuell habe ich immer nur bei einem Fenster getestet und dort habe ich die KNX/Loxone Automatikjalousie Loesung von Loxwiki laufen. Witziger weise habe ich auf einmal am naechsten Tag bemerkt das offenbar bei dem Fenster die Automatikfunktion aktiv war da die Raffstore unten war mit waagrechten Lamellen. Die Lamellennachfuehrung hat zufaelliger weise auch funktioniert. Mal sehen was fuer eine Loesung ich dann zum schluss im Einsatz habe.

    • kitikonti
      kitikonti kommentierte
      Kommentar bearbeiten
      Labmaster welche Werte hast du den beim MDT Aktor eingestellt? Und welche Raffstore verwendest du, bzw welchen Motor.

  • #32
    Ich hab da in diesem Zusammenhang mal ne Frage an die Loxone Config Nerds hier ?
    Gib es ne einfach Möglichkeit das Senden eine Wertes auf einen KXN Aktor zu triggern, unabhängig davon ob sich der Wert selbst geändert hat oder nicht.
    Also ich brauche zwei Eingänge die in entsprechende Logik, einmal den zu sendenen Wert und einmal den Trigger zum senden.
    Beim Triggern darf sich aber der zu sendende Wert nicht ändern und es dürfen dabei auch keine doppelten Telegramme auf den KNX Bus gehen.
    Übersehe ich da was ganz einfaches ?

    Ne Idee ???
    Zuletzt geändert von Labmaster; In den letzten 2 Wochen.

    Kommentar


    • Christian Fenzl
      Christian Fenzl kommentierte
      Kommentar bearbeiten
      Mit‘m Analogspeicher.

    • Labmaster
      Labmaster kommentierte
      Kommentar bearbeiten
      Der hat aber wieder das Problem, daß Änderungen des Analogwertes den KXN nicht triggern, was ich leider ebenso auch benötige, bzw. muß ich da den Trigger hierfür dann mit nem Vergleicher und ner Verzögerugn wieder selber bauen.

  • #33
    Labmaster Ich bin mir nicht ganz sicher, ob es das ist, was Du brauchst, aber wir hatten hier schon mal die Umsetzung von KNX mit der Lichtsteuerung (+Zentral) gelöst.

    Das Problem war hier, dass eine Steuerung über den Bus nur den Status ändern, aber nicht zusätzlich ein Telegramm schicken sollte. Anbei die Lösung. Der Langzeitklick ist auf TI: 0,15, T: 0,02 V1-V4: 1.

    So hast Du eine kleine Verzögerung der Statusanzeige, aber trotzdem die Schaltfunktion über die App. Funktioniert bei mir einwandfrei.

    Kommentar

    Lädt...
    X