Ankündigung

Einklappen

INFORMATION

Dieser Bereich ist für fertige Lösungen gedacht. Nutze bitte für Diskussionen die anderen Bereiche.
Mehr anzeigen
Weniger anzeigen

Fronius Symo API Abfrage

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Fronius Symo API Abfrage

    Eventuell hat ja jemand eine Verwendung meiner Vorlage für den Fronius Symo.

    VI_Fronius API Abfrage.txt in XML Endung abändern und in das Vorlagenverzeichnis von der Config legen - neu starten

    Klicke auf die Grafik für eine vergrößerte Ansicht  Name: Fronius API Abfrage II.JPG Ansichten: 1 Größe: 52,3 KB ID: 84760
    Klicke auf die Grafik für eine vergrößerte Ansicht

Name: Fronius API Abfrage III.JPG
Ansichten: 404
Größe: 38,6 KB
ID: 84796

    URL zum Abfragen: http://IP vom WR/solar_api/v1/GetPowerFlowRealtimeData.fcgi


    sollte dann so ausschauen:
    Klicke auf die Grafik für eine vergrößerte Ansicht  Name: Fronius API Abfrage.JPG Ansichten: 1 Größe: 421,2 KB ID: 84761
    Zuletzt geändert von AlexAn; 19.Feb.2017, 13:01.
    Grüße Alex


    MS, MS Go, 5 Smart Socket´s Air, Airbase, Modbusext.,2*Eastron Sdm630 Modbus, Zählerinterface,3 S0 Zähler, Wetterstation Elsner P03 Modbus, Fronius Symo 10 - Überschusslieferung, WP Waterkotte DS5017.3, WW WP M-Tec WPE2000 + WW Speicher Stiebel Eltron 400 + 6kW E-Patrone mit Leistungssteller, DM7020hd, Husqvarna Automower 330x

  • #2
    Hallo Alex,

    super Idee, habe auch alles so gemacht wie Du beschrieben hast. Leider Funktioniert es bei mir nicht.
    Habe die Vermutung das die Kommunikation zwischen Wechselrichter und Loxone nicht Funktioniert, warum auch immer. Ping Baustein sagt Online aber Informationen kann er keine Abrufen.

    Grüße

    Kommentar


    • #3
      Was sagt der Befehl im Firefoxbrowser:
      http://IP vom WR/solar_api/v1/GetPowerFlowRealtimeData.fcgi

      Hat der Symo ein Update gemacht?
      Hat der DHCP Server eventuell eine andere IP vergeben?
      Wie schaut es im Solarweb aus?
      Zuletzt geändert von AlexAn; 19.Feb.2017, 15:44.
      Grüße Alex


      MS, MS Go, 5 Smart Socket´s Air, Airbase, Modbusext.,2*Eastron Sdm630 Modbus, Zählerinterface,3 S0 Zähler, Wetterstation Elsner P03 Modbus, Fronius Symo 10 - Überschusslieferung, WP Waterkotte DS5017.3, WW WP M-Tec WPE2000 + WW Speicher Stiebel Eltron 400 + 6kW E-Patrone mit Leistungssteller, DM7020hd, Husqvarna Automower 330x

      Kommentar


      • #4
        Hallo,

        das zeigt er an wenn ich es bei Firefox eingebe. IP Adresse und zugang zu Solarweb passt.

        Kommentar


        • #5
          Dein S0 Zähler ist nicht da!
          anderer Befehl:
          http://IP vom WR/solar_api/v1/GetMeterRealtimeData.cgi?Scope=Device&DeviceId=0
          DeviceID kann auch 1 sein je nach dem!


          Erscheint der Verbrauch im Solarweb?
          Hybrid??
          Zuletzt geändert von AlexAn; 19.Feb.2017, 16:49.
          Grüße Alex


          MS, MS Go, 5 Smart Socket´s Air, Airbase, Modbusext.,2*Eastron Sdm630 Modbus, Zählerinterface,3 S0 Zähler, Wetterstation Elsner P03 Modbus, Fronius Symo 10 - Überschusslieferung, WP Waterkotte DS5017.3, WW WP M-Tec WPE2000 + WW Speicher Stiebel Eltron 400 + 6kW E-Patrone mit Leistungssteller, DM7020hd, Husqvarna Automower 330x

          Kommentar


          • #6
            Schon den Hinweis über die aktuelle fronius Software gesehen?

            https://www.loxone.com/dede/kb/energie-monitor/
            Beste Grüße
            Amin Cheema
            www.cheemasystems.de / www.smarthome-builder.de

            Kommentar


            • loxonaut
              loxonaut kommentierte
              Kommentar bearbeiten
              Na geil. Genau die Software Version habe ich. Super das das der eigene Support nicht weiß.

          • #7
            Hi,

            Verbrauch zeigt er im Solar Web nicht an. S0 Zähler ist jedoch im Verbrauchszweig angeschlossen und mit 1000 imp. Eingegeben. Drähte sind auch fest.

            Kommentar


            • #8
              Hab auch die 3.7.4-5 drauf und läuft oder hast du schon die 3.7.4-6

              Was sagt der Datenmanager wird dort der Verbrauch angezeigt.
              Wenn er dort auch nicht ist dann liegt es am Zähler selber oder ist er noch nie gegangen?

              Datenmanager/WR eventuell neu starten
              Zähler eventuell stromlos machen SDM630 kann sich schon mal aufhängen
              Schau mal mit einem Fluke ob die Impulse überhaupt zum Symo kommen
              Grüße Alex


              MS, MS Go, 5 Smart Socket´s Air, Airbase, Modbusext.,2*Eastron Sdm630 Modbus, Zählerinterface,3 S0 Zähler, Wetterstation Elsner P03 Modbus, Fronius Symo 10 - Überschusslieferung, WP Waterkotte DS5017.3, WW WP M-Tec WPE2000 + WW Speicher Stiebel Eltron 400 + 6kW E-Patrone mit Leistungssteller, DM7020hd, Husqvarna Automower 330x

              Kommentar


              • #9
                Hi
                habe die 3.7.4-6

                Schau später mal ob Impulse am WR ankommen.

                Kommentar


                • #10
                  Servus,

                  Danke für die API Abfrage!
                  Habs soeben Installiert und funktioniert einwandfrei
                  Habe auch die Fronius Version 3.7.4-6

                  Danke
                  mfg
                  Franz

                  Kommentar


                  • #11
                    Moin,

                    gibt es schon was neues bezüglich der Abfrage zwischen Fronius und Loxone?
                    Habe jetzt die Abfrage des Verbrauchs im Wechselrichter hinbekommen.
                    Leider Funktioniert die API Abfrage von Alex leider noch nicht bei mir.

                    Kommentar


                    • #12
                      Wie lange hast du gewartet? Nach dem einspielen kann es schon etwas dauern bis die Abfrage kommt.
                      Der Webbefehl klappt ja also muss es auch in der Loxone klappen.
                      Sonst mach alles nochmal neu!
                      Grüße Alex


                      MS, MS Go, 5 Smart Socket´s Air, Airbase, Modbusext.,2*Eastron Sdm630 Modbus, Zählerinterface,3 S0 Zähler, Wetterstation Elsner P03 Modbus, Fronius Symo 10 - Überschusslieferung, WP Waterkotte DS5017.3, WW WP M-Tec WPE2000 + WW Speicher Stiebel Eltron 400 + 6kW E-Patrone mit Leistungssteller, DM7020hd, Husqvarna Automower 330x

                      Kommentar


                      • #13
                        Hm hatte alles noch mal gelöscht, gespeichert, neu angelegt und wiedr gespeichert, aber es zeigt alles 0,0
                        Ist bestimmt nur eine kleinigkeit. Aber ich komm nicht drauf. :-(

                        Kommentar


                        • AlexAn
                          AlexAn kommentierte
                          Kommentar bearbeiten
                          Hast was am Router/Modem verändert oder Update gemacht das die Anfragen vom Miniserver geblockt werden.
                          Das würde auch erklären warum der Baustein und die API nicht gehen.

                      • #14
                        Hat schon jemand versucht den Fronius über Modbus auszulesen?

                        Kommentar


                        • #15
                          loxonaut

                          Schau doch mal hier -> https://www.loxforum.com/forum/germa...1666#post61666

                          Güße
                          Robert
                          -----------------------------
                          LOXONE: MiniServer, Air, RGBW Dimmer, SmartSockets, IR Control, Remote, Temperatur- Feuchtefühler, Wassermelder, Türkontakte, Regensensor
                          KNX: ca. 20 Mehrfachtaster, ca. 50 Schaltaktoren, ca. 10 Dimmer, ca. 15 Temperatursensoren, Jalousiesteuerung, Raumtemperaturregelung, Garagentor, Markise
                          SONSTIGES: 5 kWp PV mit Symo-Hybrid und Batteriespeicher, go-e Wallbox, Rauchmelder vernetzt mit Koppelmodul am MS, Globalstrahlungssensor, Stromzähler, Wetterstation (WLAN)

                          Kommentar


                          • loxonaut
                            loxonaut kommentierte
                            Kommentar bearbeiten
                            Danke Robert,

                            Probier ich heute Abend gleich aus. Geht das auch mit dem "Normalen" Fronius Symo?

                          • RobertS
                            RobertS kommentierte
                            Kommentar bearbeiten
                            Die "Standard" Abfragen ja, es gibt aber vmtl. auch spezifische Abfragen für die Solarbattery.
                            Die Temperaturabfragen funktionieren bei mir übrigens leider nicht, gerade diese Info wollte ich aber.

                          • loxonaut
                            loxonaut kommentierte
                            Kommentar bearbeiten
                            Habs noch nicht hinbekommen. Kannst Du mal Posten was Du beim Fronius eingegeben hast?
                        Lädt...
                        X