Ankündigung

Einklappen
Keine Ankündigung bisher.

SolarEdge Wechselrichter einbinden

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • SolarEdge Wechselrichter einbinden

    Hallo zusammen,

    hat jemand von euch schon einen solaredge WR in Loxone eingebunden?.....wenn ja, wie berechnet ihr den skalierfaktor???

    danke schon jetzt für eure hilfe

  • #2
    Hallo,

    dazu benötigst du einen Formelbaustein den du mit dem jeweiligen Wert und Skalierungsfaktor versorgst.

    Soweit ich mich erinnere war das dann folgendermaßen zu berechnen: 'Wert*10^Skalierungsfaktor'

    Also z.B.: Frequenz*10^Frequenz Skalierungsfaktor


    Allerdings habe ich es nicht geschafft Wert und Skalierungsfaktor gleichzeitig über Loxone auszulesen. Somit hast du kurzfristig das Problem, dass der Wert und der Skalierungsfaktor für einen Abfragezyklus evtl. nicht zusammen passen. Ich hatte dann morgens z.B.: kurzfristig Werte von 6kW statt 600W.

    Daher errechnet bei mir ein Raspberry PI die Werte und gibt diese an Loxone weiter.

    Also SolarEdge mit RS485->USB Konverter an PI angeschlossen + Programm das die Werte berechnet und über Modbus TCP für Loxone zur Verfügung stellt.

    Hoffe das hilft dir weiter....

    Kommentar


    • #3
      Ja, ich habe es via Modbus am laufen. Funktioniert einwandfrei.
      Aber wie von raabw erwähnt musst Du den AC Power berechnen (siehe Bild), da es sonst Probleme und Ausreisser gibt, da der AC Power Wert und der Skalierungsfaktor kurz nicht synchron sind. Der SF ändert bei AC Current und AC Voltage nie, darum gibt es hier keine Probleme.

      Formel: I1*10^I2

      AC Energy geht gut direkt, hier ändert sich der Wert auch nicht dauernd.

      Kommentar


      • mbj3000
        mbj3000 kommentierte
        Kommentar bearbeiten
        Ich hab jetzt die Werte in einem Rutsch ausgelesen - als 32-bit signed Integer und dann 2 Register anhaken. (Warum ich das anhaken muss, ist mir unklar, wenn ich eine 32bit-Zahl hole, sind es ja immer 2 Register) und dann mit nur einer Formel umgerechnet.
        Die wird allerdings etwas lang, weil es keine Binär- oder Hex-Rechenoperationen gibt:
        INT(I1/65536)*10^((I1-(INT(I1/32768)*32768))*(1-INT((I1-(INT(I1/65536)*65536))/32768))+(I1-(INT(I1/32768)*32768)-32768)*INT((I1-(INT(I1/65536)*65536))/32768))/1000
        Adresse ist 40083 und dann 32 bit signed integer auslesen. "2 Register für 32 bit" ist angehakt, und "Registerreihenfoge" auch.
        Ich hoffe, ich habe nirgends einen Dreher drin, hab mal ein paar Werte simuliert, die gehen. Und ich komme mit nur einem Baustein aus.

      • the_steckenpferd
        the_steckenpferd kommentierte
        Kommentar bearbeiten
        Hallo, ich bin gerade am verzweifeln.....muss man das Programm so kompliziert gestalten? Gibt es keine Möglichkeit die Werte direkt auszulesen?
        Ich habe einen Solaredge WR inkl Solaredge Modbus 3-Phasenzähler und möchte gerne Erzeugte, Verbrauchte und Eingespeiste oder bezogene Leistung auslesen. Schon mal vielen Dank für eure Hilfe.....

      • Faxe88
        Faxe88 kommentierte
        Kommentar bearbeiten
        Hallo blaess!
        Habe das selbe Programm wie du,jedoch habe ich nach einer Woche laufzeit Error(%Gf) am Energiemonitor bekommen!(Skalierfaktor schätze ich)
        Du auch?

    • #4
      Hallo zusammen

      Ich kämpfe noch damit die aktuelle Leistung richtig berechnet wird. Ich habe von Loxone an der Modbus-Extension 2 Solaredge-WR eingefügt und die Modbusadressen eingestellt.
      Die Einstellungen bei I_AC_Power und I_AC_Power_SF sind wiefolgt: Adresse: 40084, resp. 40085, Befehl: 3, Datentyp: 16bit S INT, kein Flag gesetzt und Abfragezyklus 60.
      Der SF ist um 5000 rum, mal 4998 mal 5003 oder irgendwas dazwischen... mit oben genannter Formel ergibt das keine sinnigen Werte.

      was mache ich falsch? bin dankbar für jeden Hinweis!

      Kommentar


      • #5
        Die Adressen sind falsch. I_AC_Power ist 40083 und I_AC_Power_SF ist 40084. Der Rest stimmt.

        Kommentar


        • #6
          Hallo Bläss

          das wars! vielen Dank!

          Kommentar


          • #7
            Hallo,

            ich möchte gerne meinen Wechselrichter ins Loxone System einbinden. Was genau benötige ich dafür? Wie habt ihr das gemacht?
            Modell: Solar Edge SE5k Wechselrichter

            benötige ich dazu Zusatzplatinen/Adapter von Solaredge? MODBUS?

            vielen Dank für eure Antworten...

            lg markus

            Kommentar


            • #8
              Eigentlich nix.... wenn Du ein Version 3 Communication-Board hast solltest Du Modbus TCP nutzen können. Schau Dir mal die Doku an.
              http://www.solaredge.com/sites/defau...nical-note.pdf

              Loxone stellt eine Modbus-Vorlage für den WR bereit.

              Btw: Leider habe ich Modbus TCP noch nicht zum laufen gebracht. Der Modbus TCP Server meines WR hängt im "Init" Zustand. Case mit SolarEdge R&D ist offen.

              Kommentar


              • #9
                Tatsächlich, bei meinem (installiert im April) gibt's das noch nicht!

                Bin ich blind, oder gibt's auf der SolarEdge Homepage wirklich keine Firmware zum Download?!

                Habe jetzt den Support deswegen angeschrieben...

                Kommentar


                • blaess
                  blaess kommentierte
                  Kommentar bearbeiten
                  Firmware Update wird vom Support ausgelöst. Gibt es nicht zum Download. Einfach Case eröffnen und der WR wird updated.

                  PS: Würde mich interessieren ob Modbus TCP ohne Probleme läuft.

              • #10
                Habe gerade meinen neuen WR per Modbus TCP angeschlossen. Modbus TCP musste im WR noch aktiviert werden. Der Modbus Status im Display bleibt bei mir auch auf INIT hängen, die Kommunikation funktioniert aber. Auf dem Miniserver habe ich die von Loxone bereitgestellte Vorlage verwendet, funktioniert.
                Allerdings kann ich "I_AC_Energy_WH" nicht auswerten, da empfange ich unsinnige Werte. SolarEdge gibt als Datentyp "acc32", sagt mir jetzt nix, kann ich bei Loxone auch nicht auswählen.
                geht das bei Euch?

                Kommentar


                • #11
                  Die neue Firmware ist heute per E-Mail gekommen (CPU: 3.1968).

                  Verbindung mit Modbus TCP läuft damit prinzipiell (Status ist ebenfalls Init).

                  Auf die schnelle probiert habe ich:

                  I_AC_Frequency + I_AC_Frequency_SF -> OK
                  I_AC_Energy_WH + I_AC_Energy_WH_SF -> Werte passen nicht

                  Das von Loxone gelieferte Template ist allerdings zumindest für "I_AC_Energy_WH" falsch! Hier muss noch die Checkbox 'Registerreihenfolge' gewählt werden. Dann passt zumindest dieser Wert, allerdings ist I_AC_Energy_WH_SF bei mir immer 0? Nachdem ich per RS485 hier korrekte Werte bekommen, liegt das aber vermutlich auch am Template....

                  Klicke auf die Grafik für eine vergrößerte Ansicht  Name: I_AC_Energy_WH.jpg Ansichten: 1 Größe: 70,6 KB ID: 70502
                  Zuletzt geändert von raabw; 12.Dez.2016, 22:45.

                  Kommentar


                  • blaess
                    blaess kommentierte
                    Kommentar bearbeiten
                    Du hast recht. Gilt aber NUR für Modbus TCP, bei Modbus RTU braucht es kein Haken bei "Registerreihenfolge", was unlogisch ist. Modbus RTU and Modbus TCP sollten gleich sein. Ein Anpassen der Vorlage macht hier also nur beschränkt Sinn. Werde mal SolarEdge schreiben.

                • #12
                  Jetzt hatte ich schon mit den Datentypen rumgespielt, aber den Haken hatte ich noch nicht probiert. Jetzt gehts. Meine Firmware ist 3.17.xxx.

                  dass beim ...._SF eine Null kommt ist bei mir auch, ist ja richtig, wenn der kWh-Wert noch in die 2 Byte von I_AC_ENERGY reinpasst. Die Formel steht ja ausnahmsweise auch in der Loxone-Online-Doku.
                  Und das Template ist auch nicht nur für SolarEdge, das ist ja sunspec-Standard.

                  Kommentar


                  • #13
                    Interessant. Also bei mir funktioniert die Kommunikation nicht. Er zweigt zwar beim Einfügen eines Wertes den Wert an, der ändert sich aber nicht mehr. Wie wenn 1x Abfragen geht, danach aber nie mehr.
                    Aber auf jeden Fall ist bei SolarEdge auch was nicht gut. Der WR sollte definitiv nicht im "Init" Status bleiben. Nur die ersten 10s. Danach Ready und dann Connected.

                    Kommentar


                    • mbj3000
                      mbj3000 kommentierte
                      Kommentar bearbeiten
                      das "init"-Thema ist bei mir nur kosmetisch. Hast Du denn den Rest richtig, Eintrag bei MiniServerkommunikation usw.?
                      Ich habe auf dem WR die FW 3.1818 und auf dem Miniserver die 8.1.11.11.
                      Zuletzt geändert von mbj3000; 13.Dez.2016, 08:38.

                    • blaess
                      blaess kommentierte
                      Kommentar bearbeiten
                      mbj3000 - denke schon. WR FW 3.1969, Miniserver auch aktuell. IP Adresse stimmt, Modbus ID 1.
                      Viel mehr kann man ja nicht falsch machen.

                    • blaess
                      blaess kommentierte
                      Kommentar bearbeiten
                      So, habe es herausgefunden. Bei Modbus RTU habe ich Modbus ID 3 gewählt. Dieser Wert wird im WR auf für Modbus TCP verwendet.
                      Mein WR ist auch noch im "init", aber ich kann die Werte lesen ;-)

                  • #14
                    Habt Ihr denn auch einen Stromzähler an den Wechselrichter angeschlossen (wegen der dynamischen 70%-Abregelung)? Ich habe mir jetzt den von Saia PCD bestellt, das ist der, den Loxone auch unter eigenem Label verkauft, habe aber den dringenden Verdacht, dass der nicht mit dem WR über Modbus kann.

                    Kommentar


                  • #15
                    Die IO-Adresse von I_AC_VoltageCN ist im Template von Loxone ebenfalls falsch. Hier gehört 40081 und nicht 40082.
                    Zuletzt geändert von raabw; 13.Dez.2016, 11:45.

                    Kommentar


                    • blaess
                      blaess kommentierte
                      Kommentar bearbeiten
                      Stimmt, habe ich auch bemerkt. Werde dies korrigieren lassen, aber er wenn wir wissen wo genau das Problem bei I_AC_Energy_WH.
                      Modbus TCP und Modbus RTU sollten ja eigentlich gleich sein. Bei mir funktioniert I_AC_Energy_WH unter Modbus RTU.

                    • raabw
                      raabw kommentierte
                      Kommentar bearbeiten
                      I_AC_Energy_WH wird korrekt angezeigt wenn 'Registerreihenfolge' gewählt ist. Ich hatte nur übersehen, dass hier Wh und nicht kWh geliefert werden.
                      Bei mir stimmen allerdings die berechneten Werte nicht wirklich überein. WR produzierte z.B.: 80W (Nebel), der berechnete Wert aus den Strömen /Spannungen war allerdings 420W.
                      Zuletzt geändert von raabw; 13.Dez.2016, 11:42.
                  Lädt...
                  X