Ankündigung

Einklappen
Keine Ankündigung bisher.

SolarEdge Wechselrichter einbinden

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • #46
    Danke mbj3000 daran wird es wohl liegen, macht Sinn. Hatte deinen Kommentar 3.2 übersehen, die Formel da ist noch korrekt?
    Nachrüster-EFH: MS, Extension, EnOcean, Awaptec Switches, Loxberry, Zählterinterface Air, 2 Loxone 3 Phasenzähler, Eastron Sdm630 Modbus, Photovoltaik 9.82kWp, Eigenverbrauchsoptimierung mit Loxone

    Projekte: Photovoltaik-Anlage, Keba P30 Wallbox, VW e-Golf Test, myStrom WiFi Switch einbinden

    Kommentar


    • #47
      Formel läuft bei mir. Wuerde ich wieder so machen :-)

      Kommentar


      • #48
        Perfekt, läuft einwandfrei. Habe das Register zusätzlich eingefügt, hast du den Rest gelöscht den du nicht nutzt?
        Nachrüster-EFH: MS, Extension, EnOcean, Awaptec Switches, Loxberry, Zählterinterface Air, 2 Loxone 3 Phasenzähler, Eastron Sdm630 Modbus, Photovoltaik 9.82kWp, Eigenverbrauchsoptimierung mit Loxone

        Projekte: Photovoltaik-Anlage, Keba P30 Wallbox, VW e-Golf Test, myStrom WiFi Switch einbinden

        Kommentar


        • #49
          Ja.

          Kommentar


          • #50
            Hallo

            Seit kurzem hab ich auch einen SolarEdge Wechselrichter in Betrieb.
            Funktioniert soweit auch ganz gut mit der Leistung.
            Das einzige Problem ist die Gesamtproduktion Adresse 40094 I_AC Energy_WH, dieser Wert hat sich zum Beispiel über neujahr geändert und auch 1 Woche später nochmal.
            Gibt es da eine Lösung oder hat jemand das gleiche Problem?
            Hab jetzt ca. 180kWh erzeugt insgesamt und seit heuer ca. 110kWh. Anzeigen tut es mir gerade einmal 47kWh.

            Vielen Dank

            Kommentar


            • blaess
              blaess kommentierte
              Kommentar bearbeiten
              Nimm mal 40093 und lies Post 11. Sollte helfen!

            • KellysChips
              KellysChips kommentierte
              Kommentar bearbeiten
              Hat funktioniert. Vielen Dank

          • #51
            Hallo Habe das Problem das ich keine Verbindung zwischen Loxone Modbus Extension und Solar edge WR zusammenbringe. Kann mir jemand die Parameter und Verkabelungsplan zukmmen lassen
            Herzlichen Dank Johann

            Kommentar


            • #52
              Der WR muss am Netzwerk hängen (Patch Kabel)
              Pass auf wenn du im Gehäuse arbeitest, dass die PV "spannungsfrei" ist (siehe WR Bedieungsanleitung)
              Gib ihm im LAN Menü eine statische IP Adresse. zB 192.168.1.88
              Subnet zB 255.255.255.0
              Gateway zB 192.168.1.1. (=Adresse des Routers)
              DNS 19.2.168.1.1

              Modbus aktivieren beim WR:
              Select Communication --> LAN Config --> Modbus TCP
              Set TCP Port (wie oben der stat. Adresse) zB 192.168.1.88
              Port 502
              Dann steht in der Anleitung (kann man bei solaredge downloaden) dass man 2 Minuten Zeit hat den Client zu verbinden, sonst schaltet er den Modbus ab.

              Also rechtzeitig vorher im Loxone die Schnittstellen eintipseln (siehe Bild), damit es zugreift. (Bei mir gings auf anhieb, mit Glück).
              Im Loxone git es bereits die Sensoren des Wechselrichter schon fertig angelegt unter "Peripherie einfügen".
              Die Sensoren zB AC_Power o.ä. kannst du dann mit den (schon in den vorigen Blogs) beschriebenenen Formeln umrechnen.

              Zum testen müsste dann wieder Strom fließen, sonst zeigt er ja nur 0 Watt an, und das würde er auch ohne Verbindung machen.

              Kommentar


              • #53
                Hallo kannst du mir noch weiter helfen. Gibt's die Möglichkeit über Modebus den einzubinden
                habe da auch schon den Energiezähler eingebunden. ohne Problem wohlgemerkt
                Werde am Samstag Modebus TCP nochmals probieren.
                Es hängen beide Geräte im WLAN Netz (Solaredge über WLAN und Miniserver Go über LAN)
                irgendwo fehlt womöglich ein kleines Häkchen lol.
                Hast du noch screenshoots oder Fotos dazu?
                Danke im Voraus für deine Unterstützung

                Kommentar


                • Passivhaus2017
                  Passivhaus2017 kommentierte
                  Kommentar bearbeiten
                  Kommt drauf an welche screenshots ... der Eine sagt schon ziemlich alles.
                  Der Energiezähler läuft schon im Loxone ? Dann wäre ja die Verbindung erledigt.
                  Dass solaredge eine W-Lan Verbindung macht ist mir neu, hast da einen "Super" Wechselrichter?

              • #54
                Zitat von Passivhaus2017 Beitrag anzeigen
                Modbus aktivieren beim WR:
                Select Communication --> LAN Config --> Modbus TCP
                Set TCP Port (wie oben der stat. Adresse) zB 192.168.1.88
                Port 502
                Dann steht in der Anleitung (kann man bei solaredge downloaden) dass man 2 Minuten Zeit hat den Client zu verbinden, sonst schaltet er den Modbus ab.

                ...

                Zum testen müsste dann wieder Strom fließen, sonst zeigt er ja nur 0 Watt an, und das würde er auch ohne Verbindung machen.
                Ich habe es soweit geschafft, Modbus TCP am Solaredge Wechselrichter zu aktivieren im Menü.
                Jetzt kommt aber bei Status immer nur "Init", er wechselt nicht zu ready oder connected.
                Im Miniserver ist soweit alles vorbereitet, dass der Miniserver als Client zugreifen könnte. "I_AC_Power" und "I_AC_Energy" sind an "Pp" bzw. "Ep" vom Energiezähler angeschlossen (inklusive Formel für Skalierungsfaktor).

                Laut Solaredge Beschreibung heißt Status "Init":
                Init – Initializing server – This state only occurs after the first configuration until it reaches the ready status. This activity lasts about 10 seconds.

                Was fehlt noch?
                Wie kann ich noch testen, ob eine Verbindung zustande gekommen ist?
                Geht das in Loxone über den Diagnoseeingang (Onlinestatus Solaredge)?
                Zuletzt geändert von AndyH; 20.Feb.2018, 09:13.

                Kommentar


                • AndyH
                  AndyH kommentierte
                  Kommentar bearbeiten
                  Habe jetzt Daten vom aktuellen Verbrauch in Loxone angezeigt bekommen.
                  Es kommt also trotzdem was an, auch wenn der Wechselrichter immer den Modbus TCP Status "Init" meldet.

              • #55
                Welche Eingänge vom Energiemonitor habt ihr belegt?
                Ich kenne bisher nur Ep und Pp (aktuelle Gesamtproduktion und Gesamtleistung).

                Können die Eingänge Ev, Pv und Ed (Verbrauch, Leistung und Lieferung) auch über Modbus TCP von Solaredge WR geliefert werden?
                Oder benötige ich dazu einen separaten Stromzähler?

                Kommentar


                • AndyH
                  AndyH kommentierte
                  Kommentar bearbeiten
                  Ok, dann wird es wohl bei Ep und Pp bleiben.
                  So ein Bild mit den Pfeilen in der App wäre halt schön, wenn es mit den Daten vom Fremdbezug und Einspeisung ergänzt werden könnte.
                  Siehe Beispiel hier:
                  https://www.loxforum.com/filedata/fetch?photoid=34792

                  Was ich mich jetzt noch frage:
                  Wie kommen dann die Daten in die Online-Überwachung von Solaredge (monitoring.solaredge.com)?
                  Hier sind bei mir ja schön alle Werte sichtbar, sowohl die Einspeisung als auch der Fremdbezug.
                  Das bedeutet doch, der Wechselrichter hat auch bereits die Info über diese Daten oder bekommt sie von einem Stromzähler (Fabrikat "Finder" bei mir).

                • Passivhaus2017
                  Passivhaus2017 kommentierte
                  Kommentar bearbeiten
                  Hallo Andy,
                  ja echt, beim Monitoring von Solaredge hast den Fremdbezug dabei? Das ist nicht schlecht, wenn du diesen "Finder" Zähler zusätzlich zum Energieversorger Stromzähler hast wird der Daten an den Wechselrichter übertragen und der dann an Solaredge. Somit müsstest du auch direkt Daten von dem Finder einlesen können. Vielleicht gibts wen der das hat bzw. Anleitung....

                • AndyH
                  AndyH kommentierte
                  Kommentar bearbeiten
                  Hallo,

                  ja, ich habe den Finder S0-Zähler 7E.46.8.400.0012.
                  Allerdings sagt mir mein Installateur, dass dieser für die Abrechnung mit dem Netzbetreiber verwendet wird, und nicht ein zweites Mal für die Einbindung in Loxone abgegriffen werden darf.

              • #56
                Guten Abend.

                Seit heute bin Ich Besitzer einer Solaredge Anlage.
                Wie habt ihr den Solaredge Modbus zähler in Loxone eingefügt?
                Bei mir möchte er die Daten nich auslesen.
                Vom WR kann ich die Daten erfassen und auswerten.
                Hoffe das es jemand schon implementiert hat.
                Schönen Abend
                Lg

                Kommentar


                • #57
                  Genau an der Stelle stecke ich auch gerade.
                  Produktion des Wechselrichters (I_AC_Energy_WH und I_AC_Power) habe ich über "Ep" und "Pp" Eingänge in den Loxone Energiemonitor eingebunden.
                  Aber schön wäre noch die Zählerwerte für Einspeisung und Bezug Stromnetz. Hierfür gibt es wohl keine entsprechenden Sensoren in der Modbus Vorlage zum "Solaredge WR".
                  Wechselrichter müsste ja die Werte schon kennen, jedenfalls kann er sie ins Monitoring-Portal importieren:
                  Zuletzt geändert von AndyH; 23.Feb.2018, 13:53.

                  Kommentar


                  • #58
                    Ich bin einen Schritt weiter: Der Energiemonitor zeigt nun den Energiefluß in der Visualisierung an.

                    Einbindung über die Monitoringapi von Solaredge.
                    Die Doku dazu liegt hier: https://www.solaredge.com/sites/defa...toring_api.pdf

                    Der relevante Teil ist die Möglichkeit den aktuellen PowerFlow auszulesen:
                    Site Power Flow
                    Retrieves the current power flow between all elements of the site including PV array, storage (battery), loads (consumption) and grid.
                    Note: Applies when export , import and consumption can be measured.


                    Hierbei lese ich drei Werte alle 10 min. von der API in virtuelle HTTP Eingänge:
                    - GRID (kW)
                    - PV (kW)
                    - LOAD (kW)

                    (Speicher habe ich keinen, wäre aber auch möglich)
                    Screenshots:
                    Klicke auf die Grafik für eine vergrößerte Ansicht  Name: Energiemonitor_Eingänge_Monitoringapi_Solaredge.png Ansichten: 1 Größe: 26,9 KB ID: 147263Klicke auf die Grafik für eine vergrößerte Ansicht  Name: Energiemonitor_Eingänge_Monitoringapi_Solaredge_GRID.png Ansichten: 1 Größe: 19,5 KB ID: 147264
                    Für den "GRID" Wert ist dabei wichtig zu unterscheiden, ob aktuell Import (purchase) oder Export (feed-in) vorliegt.
                    Die drei Größen hängen also direkt zusammen, es gibt folgende Umrechnungsmöglichkeit:
                    GRID = PV - LOAD (bei Bezug < Stromeinspeisung)
                    GRID = LOAD - PV (bei Bezug > Stromeinspeisung)

                    Virtueller HTTP-Eingang PV wird direkt an den Eingang "Pp" vom Energiemonitor angeschlossen.
                    Über einen Formelbaustein wird dann der Leistungseingang "Pv" vom Energiemonitor Baustein berechnet.
                    Dieser kann negativ / positiv sein, je nach Energiebezug/Einspeisung.
                    Dies kann wie oben beschrieben über die Subtraktion von "PV" vom "LOAD" Wert ermittelt werden:

                    Klicke auf die Grafik für eine vergrößerte Ansicht  Name: Energiemonitor_Solaredge.png Ansichten: 1 Größe: 54,5 KB ID: 147262Klicke auf die Grafik für eine vergrößerte Ansicht  Name: Energiemonitor_PowerFlow_Solaredge.png Ansichten: 1 Größe: 12,3 KB ID: 147840


                    Habe die gesammelten Infos inzwischen in einem neuen Eintrag im loxwiki zusammengefasst:
                    http://www.loxwiki.eu/x/24K3AQ

                    Bei Bedarf gerne ergänzen!
                    Zuletzt geändert von AndyH; 12.Mär.2018, 13:06.

                    Kommentar


                    • Passivhaus2017
                      Passivhaus2017 kommentierte
                      Kommentar bearbeiten
                      Genial, das ist richtig smart, danke für die Tipps, wie lang hast du für die Erabreitung gebraucht?

                    • gerd-fn
                      gerd-fn kommentierte
                      Kommentar bearbeiten
                      Für die Energieanzeige ist das Abgreifen der Daten über API alle 10 Minuten einigermaßen ausreichend. Für ein Energiemangement leider nicht. Die Werte können auch direkt mit Modbus TCP/IP aus dem WR über Intranet ausgelesen werden. Auch wenn das Internet aus ist! Mit den nun bekannten Adressen (Siehe Blog #60) geht das auch einfacher. Aber Respekt, hast dich da ja ganz schön reingehängt. Top

                    • AndyH
                      AndyH kommentierte
                      Kommentar bearbeiten
                      Erarbeitung war recht schnell, nachdem ich im Dokument gefunden habe dass die "PowerFlow" Abfrage meine Zwecke recht gut erfüllt (plus zusätzlicher Umrechnung bei Einspeisung/Bezug).

                      Dass die API alle 10 Minuten abfragt genügt mir für die Anzeige in der Visualisierung. Über Modbus TCP bekomme ich ja noch zusätzlich die aktuellen Werte der PV-Produktion, die können häufiger abgefragt werden (z.B. alle 60 Sek.).

                      Was ich aber über Modbus TCP nicht bekomme, ist der Wert für Netto-Einspeiseleistung ins Netz bzw. Bezug aus dem Netz. Im PDF aus Blogbeitrag #60 habe ich dazu jedenfalls nichts gefunden ;-(

                  • #59
                    Hallo Zusammen,

                    zu meinem Beitrag #41 konnte mir wohl keiner helfen.

                    Nun bin ich nach etlichen Versuchen mit den SE-Außendienstmitarbeiter gestern zu einem SE-Vortag in Memmingen gekommen.

                    Problem war:
                    Über Modbus lassen sich in Konstellation mit LG-Akku nicht die Akkuwerte und tatsächliche Produktion bei Akkladung auslesen. Die Doku von SE-Juli 2016 sunspec spricht nur WR+Zählerwerte an, jedoch nicht die Akkuwerte. Hier gibt es auch keine Möglichkeit direkt etwas anzusteuern!

                    Es gibt seit Nov. 2017 eine erweiterte Adressliste, in welcher sich auch alle weiteren Werte über Modbus auslesen, als auch ansteuern lassen. Diese Beginnen mit der Adresse 6...... soweit ich das gesehen habe.

                    Heute habe ich es endlich geschaft über 62853 den Akkustand auszulesen. Dabei entspricht der Wert 16896 = 0% und 17096 = 100%.
                    Für den Status ist wohl Register 62845 zuständig. Beide lassen sich mit 3(read) und uinit16 auslesen.

                    Die nur in englisch vorhandene Liste hat mir der SE-Techniker bei der Schulung gezeigt, also die gibt es! Nur hat er mir diese noch nicht zugesendet. Herunterladen kann man diese leider nicht.
                    Wenn jemand interesse hat bitte melden, dann stelle ich diese nach Erhalt zur Verfügung.

                    Kommentar


                    • #60
                      So, jetzt habe ich Fakten, Dokumente und Antworten zum Auslesen eine Akkus an SE-Wechselrichter inkl. auslesen und ansteuern des Energiemangementes.

                      Die Adressregister in meinem vorherigen Beitrag sind nur bedingt richtig! Bitte die im Dokument (Akku Seite 20) angegebenen Registeradresse Hex umrechnen in Dezi dann passt es. Umrechner gibt es bei wikipedia.

                      Es lassen sich alle Werte des Akkus einwandfrei auslesen und weiter verarbeiten. Somit kann bei Summierung der DC-Eingänge nun die tatsächliche erzeugte Energie während der Akkuladung eingebunden werden.

                      Die Werte müssen mit 3(read Holding Register 4x) und "32-Bit unsigned" + Haken bei "2 Register für 32-Bit" ausgelesen werden. Bei Float32-Werten demensprechend "32-Bit Floating-Point".

                      Hier noch einmal ein Danke für alle die zu diesem Themenbereich auch mir mit vielen Tips weitergeholfen haben.
                      Angehängte Dateien

                      Kommentar


                      • MrMister76
                        MrMister76 kommentierte
                        Kommentar bearbeiten
                        Ich hatte mal ein Excel Sheet zugeschickt bekommen mit den Registern des Akkus. Das Auslesen hat auch über Monate hinweg funktioniert und nun meint der liebe Wechselrichter plötzlich, dass es diese 6x Register nicht gibt.
                        Die Datei in deinem Beitrag ist leider nicht mehr verfügbar, kannst du die nochmal anhängen?

                      • DomDom
                        DomDom kommentierte
                        Kommentar bearbeiten
                        Frage:
                        Wenn ich als am Energiemonitor den Eingang SS beschalten möchte, muss ich:
                        Zwei Analoge Sensoren mit den IO-Adressen 57726 (E17E) und 57728 (E180) für Battery 1 Max Energy und Battery 1 Available Energy anlegen.
                        Das dann mit dem Formelbaustein (I1/I2*100) berechnen.

                        Ist das richtig?

                      • Ralphidelio
                        Ralphidelio kommentierte
                        Kommentar bearbeiten
                        Irgendwie bekomme ich keine Werte über die beiden Adressen "E186 (F586) Battery 1 Status" bzw. "E184 (F584) Battery 1 State of Energy (SOE)" ausgelesen. Bei mir läuft er in einen Timeout im MODBUS TCP (Fehlerstatus des Analogsensors auf 1 nach einige Sekunden). Interessanterweise kann ich alle anderen Werte des Inverters und des Meters lesen. Nur beim Batteriestatus liefert er nichts.
                        Meine Anlage ist erst ein paar Tage alt: SE8K-RWS mit LG RES10 (48V).
                        Call bei SE läuft bereits. Bin mal auf die Antwort gespannt.

                        @Gerd: Hast du die SE mit MODBUS RTU oder TCP angeschlossen?

                        Gruß Ralph
                    Lädt...
                    X