Ankündigung

Einklappen

PLUGINS

Bitte im Titel immer zuerst den Namen des Plugin hinschreiben
Mehr anzeigen
Weniger anzeigen

Plugin: MiRobot2Lox-NG - Xiaomi Vacuum Robots

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Plugin: MiRobot2Lox-NG - Xiaomi Vacuum Robots

    Moin zusammen,

    ich habe ein neues Plugin online gestellt: MiRobot2Lox-NG (https://www.loxwiki.eu/display/LOXBERRY/MiRobot2Lox-NG).

    Leider entwickelt hismastersvoice das Original-Plugin aus diversen Gründen nicht mehr weiter. Sein altes Plugin hat aber mittlerweile diverse Probleme durch den neuen LoxBerry V1.0. Ich habe mich daher entschieden das Plugin von Grund auf neu zu schreiben. Das grundsätzliche Konzept von hismastersvoice habe ich dabei übernommen - vielen Dank an dieser Stelle für die klasse Arbeit!

    Das neue Plugin nutzt eine andere Kommunikationsstruktur mit dem Miniserver: Befehle an den Robot werden per HTTP REST API an das Plugin abgesetzt. Da es eine direkte Schnittstelle zum darunter liegenden Softwarepaket Python-MIIO gibt, können so auch neue oder vom Plugin nicht vorgesehene Befehle selbst integriert werden. Die Daten werden per UDP oder HTTP Eingang an den Miniserver gesendet.

    Als kleines "Schmankerl" können mit dem Plugin auch neue Soundpacks (z. B. Deutsche Sprache) kostenlos auf den Robot installiert werden. Ich habe dazu die Soundpacks per GoogleTTS und AmazonPolly TTS erstellt und als kostenlosen Download bereitgestellt.

    All who are missing their own lagnuage for the Soundpacks: Please translate the Plugin using the LoxBerry Translation Wizard and I will create the Soundpack for your language and integrate it into the plugin.

    Viel Spaß dabei! Bugs bitte hier oder auf GitHub melden.


    LoxBerry Projekt: Wiki: http://www.loxwiki.eu:80/x/o4CO Download: https://download.loxberry.de/ Plugins: http://plugins.loxberry.de/

    Fragen zum LoxBerry: Support-Anfragen werden nicht mehr per PN beantwortet - sorry, das schaffe ich nicht! Bitte fragt im Forum nach - dafür ist es da!

  • #2
    Wo nehmt ihr alle die Zeit her! Vielen Dank für eure Arbeit.

    Kommentar


    • #3
      Eigennutz :-) Das Plugin von hsimastersvoice ging bei mir nicht mehr und meine Frau hat Druck gemacht, dass der Robbi bei Abwesenheit endlich wieder von alleine fahren soll :-)


      LoxBerry Projekt: Wiki: http://www.loxwiki.eu:80/x/o4CO Download: https://download.loxberry.de/ Plugins: http://plugins.loxberry.de/

      Fragen zum LoxBerry: Support-Anfragen werden nicht mehr per PN beantwortet - sorry, das schaffe ich nicht! Bitte fragt im Forum nach - dafür ist es da!

      Kommentar


      • #4
        Wo finde ich das heute plugin?

        Gesendet von meinem SM-G950F mit Tapatalk

        Kommentar


        • Scrati
          Scrati kommentierte
          Kommentar bearbeiten
          Sach mal, da oben ist doch ein Link im ersten Post.

      • #5
        Echt? bei mir läuft das noch immer zuverlässig.

        Ich habe mir dein PlugIn gerade mal installiert und habe mir mal die robotsdata.txt angeschaut. Ich habe in meiner Programmierung eine Abfrage enthalten, ob der Staubsauger in den letzten x Stunden bereits gesaugt hat und wieviel qm er in diesem Durchgang gesaugt hat. Abhängig davon wird er dann bei Abwesenheit gestartet oder eben nicht. Die Daten werden von deinem Plugin noch nicht übertragen, wenn ich das richtig verstanden habe. Könntest du sowas noch einbauen?

        Arbeit zieht Arbeit nach sich :P

        Kommentar


        • #6
          Ja, hat leider 100% Last auf dem Raspi erzeugt und ich habe es nicht beheben können. Leider waren da auch einige Dateien in dem alten Plugin kompiliert und ohne Sourcecode. Als hismastersvoice mir dann den Sourcecode geschickt hatte war es schon zu spät - da hatte ich schon angefangen zu programmieren.

          Zu Deinem anderen problem: Stimmt, habe ich noch nicht drin. Dachte das braucht niemand :-) Ich baue das noch mit ein.


          LoxBerry Projekt: Wiki: http://www.loxwiki.eu:80/x/o4CO Download: https://download.loxberry.de/ Plugins: http://plugins.loxberry.de/

          Fragen zum LoxBerry: Support-Anfragen werden nicht mehr per PN beantwortet - sorry, das schaffe ich nicht! Bitte fragt im Forum nach - dafür ist es da!

          Kommentar


          • #7
            Habe das Plugin gerade installiert. Wie immer tolle Arbeit.

            Mir ist etwas aufgefallen...
            Du hast die Lüfter mit Quiet 25%,Balanced 50%,Turbo 75%,Full 100% angegeben.
            Richtig wäre 38% 60% 77% 90%, ansonsten wird in der Mi-App der die Einstellung falsch bzw. gar nicht angezeigt.
            Deswegen habe ich keine freie Wahl des Fan-Speed zugelassen sondern nur die 4 vorgegeben Werte des Saugers.

            Kommentar


            • Prof.Mobilux
              Prof.Mobilux kommentierte
              Kommentar bearbeiten
              Danke für den Hinweis. Ich nutze die App nicht mehr, daher kriege ich sowas gar nicht mit :-) Das ändere ich ab.

            • hismastersvoice
              hismastersvoice kommentierte
              Kommentar bearbeiten
              Vielleicht nutzt du auch nicht % sondern die Quiet,Ballanced usw. dann stimmt es überein mit dem Rest.

            • Prof.Mobilux
              Prof.Mobilux kommentierte
              Kommentar bearbeiten
              Ja, die Bezeichnungen würde ich übernehmen. Wobei ich gerade die FloleVac App (Android) probiert habe. Die setzt 38%, 60%, 75% und 100% für Geringe Leistung, Mittlere Leistung, Hohe Leistung und Höchste Leistung.

          • #8
            Zitat von Prof.Mobilux Beitrag anzeigen
            Moin zusammen,

            ich habe ein neues Plugin online gestellt: MiRobot2Lox-NG (https://www.loxwiki.eu/display/LOXBERRY/MiRobot2Lox-NG).

            Leider entwickelt hismastersvoice das Original-Plugin aus diversen Gründen nicht mehr weiter. Sein altes Plugin hat aber mittlerweile diverse Probleme durch den neuen LoxBerry V1.0. Ich habe mich daher entschieden das Plugin von Grund auf neu zu schreiben. Das grundsätzliche Konzept von hismastersvoice habe ich dabei übernommen - vielen Dank an dieser Stelle für die klasse Arbeit!

            Das neue Plugin nutzt eine andere Kommunikationsstruktur mit dem Miniserver: Befehle an den Robot werden per HTTP REST API an das Plugin abgesetzt. Da es eine direkte Schnittstelle zum darunter liegenden Softwarepaket Python-MIIO gibt, können so auch neue oder vom Plugin nicht vorgesehene Befehle selbst integriert werden. Die Daten werden per UDP oder HTTP Eingang an den Miniserver gesendet.

            Als kleines "Schmankerl" können mit dem Plugin auch neue Soundpacks (z. B. Deutsche Sprache) kostenlos auf den Robot installiert werden. Ich habe dazu die Soundpacks per GoogleTTS und AmazonPolly TTS erstellt und als kostenlosen Download bereitgestellt.

            All who are missing their own lagnuage for the Soundpacks: Please translate the Plugin using the LoxBerry Translation Wizard and I will create the Soundpack for your language and integrate it into the plugin.

            Viel Spaß dabei! Bugs bitte hier oder auf GitHub melden.
            Wir sind wo kann man das installieren?

            Gesendet von meinem SM-G950F mit Tapatalk

            Kommentar


            • svethi
              svethi kommentierte
              Kommentar bearbeiten
              Was aber auch bekannt ist

            • hismastersvoice
              hismastersvoice kommentierte
              Kommentar bearbeiten
              Prof. glaubt halt immer noch an das gute im Menschen

            • Prof.Mobilux
              Prof.Mobilux kommentierte
              Kommentar bearbeiten
              Bin halt 'n netter ;-) Außerdem gehe ich gleich Wein trinken :-)

          • #9
            Zitat von Schurich83 Beitrag anzeigen
            Wir sind wo kann man das installieren?
            Hier: https://www.loxwiki.eu/display/LOXBERRY/MiRobot2Lox-NG


            LoxBerry Projekt: Wiki: http://www.loxwiki.eu:80/x/o4CO Download: https://download.loxberry.de/ Plugins: http://plugins.loxberry.de/

            Fragen zum LoxBerry: Support-Anfragen werden nicht mehr per PN beantwortet - sorry, das schaffe ich nicht! Bitte fragt im Forum nach - dafür ist es da!

            Kommentar


            • #10
              Ok soweit habe ich's jetzt bin ich an den Punkt angekommen was muss ich da genau machen?

              Gesendet von meinem SM-G950F mit Tapatalk

              Kommentar


              • Scrati
                Scrati kommentierte
                Kommentar bearbeiten
                Ernsthaft jetzt? Das wird installiert wie jedes andere Plugin auch. Da du hier schon länger unterwegs bist, würde ich denken, du hast schonmal die WebOberfläche deines loxberry gefunden. Weil ich aber keine Lust habe dir das alles zu erklären gibt es den Link. Mit meinem Sohn übe ich auch immer Textverständnis: https://www.loxwiki.eu/display/LOXBERRY/Erste+Schritte

                Ich bin gespannt!

                Wenn es dir nicht mehr um die PluginINstallation geht, sondern um die Extraktion des Tokens, solltest du die Frage präziser formulieren. Denn was du tun musst hast du ja bereits geposted.
                Zuletzt geändert von Scrati; 16.Sep.2018, 17:22.

            • #11
              Hallo,
              Leider erscheint bei mir beim Versuch des ersten Starts folgende Fehlermeldung: Software error:

              Undefined subroutine &LoxBerry::Web::mslist_select_html called at /opt/loxberry/webfrontend/htmlauth/plugins/mirobot2lox-ng/index.cgi line 263.
              Depending of what you have done, report this error to the plugin developer or the LoxBerry-Core team.
              Further information you may find in the error logs.

              Kommentar


              • #12
                Und täglich grüßt das Murmeltier.
                Version des LoxBerry??
                Sieht ganz danach aus als ist der LoxBerry zu alt
                Miniserver; KNX; Vitogate; EnOcean (EnOceanPi); Loxone Air; Caldav-Kalenderanbindung; RaspberryPi und für keine Frickellösung zu schade :-)

                Kommentar


                • #13
                  hi bei der instalieren kommt bei mir der fehler raus schon mehrmals versucht Loxberry V1.2.4.5

                  Angehängte Dateien

                  Kommentar


                  • #14
                    Mea culpa: Version 1.2 reichte nicht aus....mit 1.2.4 gehts! Danke

                    Kommentar


                    • svethi
                      svethi kommentierte
                      Kommentar bearbeiten
                      Ja, dumm gelaufen, Du hattest dann wohl grad die Version gehabt, in der der Versionscheck kaputt war. Sonst hättest Du einen Hinweis bekommen.

                  • #15
                    Zitat von Iluminatus23 Beitrag anzeigen
                    Mea culpa: Version 1.2 reichte nicht aus....mit 1.2.4 gehts! Danke
                    Heißt wieder runter gehen?

                    Gesendet von meinem SM-G950F mit Tapatalk

                    Kommentar

                    Lädt...
                    X