Ankündigung

Einklappen

PLUGINS

Bitte im Titel immer zuerst den Namen des Plugin hinschreiben
Mehr anzeigen
Weniger anzeigen

LoxBerry: Fhem Plugin verfügbar

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • #61
    Das ist verwunderlich. Kannst Du herausfinden welche Config-DatEi FHEM jetzt verwendet? Normalerweise war das Plugin so konfiguriert, dass alles im Verzeichnis /opt/loxberry/config/plugins/fhem abgelegt wird. Dieses Verzeichnis wird von Update nicht angefasst.

    Kannst Du mal schauen ob dort noch Dateien liegen? Und welche FHEM zum Start einliest (steht bestimmt irgendwo in den Logs).

    Zur Wiederherstellung, damit bei Dir wieder alles läuft, einfach erst einmal das Backup zurückspielen. Dann läuft der LB wieder auf 1.4.3

    Wenn Du nicht weiterkommst schicke mir bitte mal eine PN, bevor Du das Backup zurückspielst. Ich würde mir das dann per Remote mal anschauen.
    Bitte stellt Eure Anfragen nicht per PN, ich bevorzuge das Fragen/Antworten im Forum, damit alle etwas davon haben. Vorher lesen: https://www.loxforum.com/forum/proje...en-bitte-lesen

    LoxBerry: https://www.loxwiki.eu/display/LOXBERRY/LoxBerry

    Kommentar


    • #62
      2019.11.11 07:16:52 0: Server shutdown
      2019.11.11 07:17:38 1: Including fhem.cfg
      2019.11.11 07:17:39 3: WEB: port 8083 opened
      2019.11.11 07:17:39 2: eventTypes: loaded 0 events from ./log/eventTypes.txt
      2019.11.11 07:17:39 1: Including ./log/fhem.save
      2019.11.11 07:17:39 0: Featurelevel: 5.9
      2019.11.11 07:17:39 0: Server started with 5 defined entities (fhem.pl:20460/2019-11-05 perl:5.028001 os:linux user:fhem pid:822)

      -> geht nicht draus vor, oder?

      Ich habe mal im Backup-Image nachgeschaut: Dort ist \opt\loxberry\config\plugins\fhem leer, also vermutlich hat der vorhin schon "falsch" abgespeichert. Wo könnte die cfg im Backup denn noch liegen?

      Kommentar


      • #63
        Das Original FHEM speichert nach /opt/fhem glaube ich. Eventuell hast Du da mal das Paket oder so aktualisiert?
        Bitte stellt Eure Anfragen nicht per PN, ich bevorzuge das Fragen/Antworten im Forum, damit alle etwas davon haben. Vorher lesen: https://www.loxforum.com/forum/proje...en-bitte-lesen

        LoxBerry: https://www.loxwiki.eu/display/LOXBERRY/LoxBerry

        Kommentar


        • #64
          Ja in /opt/fhem liegen Dateien. Welche davon muss ich denn rüberkopieren, wo sind die Einstellungen gespeichert? Die fhem.cfg ist sehr überschaubar, da sind die Geräte nicht hinterlegt...
          Kann durchaus sein, dass ich mal den update Befehl ausgeführt habe...

          Kommentar


          • #65
            Mmmhh, keine Ahnung, ich nutze FHEM selbst nicht. Normalerweise müsste alles in der fhem.cfg stehen, soweit ich das verstehe.
            Bitte stellt Eure Anfragen nicht per PN, ich bevorzuge das Fragen/Antworten im Forum, damit alle etwas davon haben. Vorher lesen: https://www.loxforum.com/forum/proje...en-bitte-lesen

            LoxBerry: https://www.loxwiki.eu/display/LOXBERRY/LoxBerry

            Kommentar


            • #66
              Christian Fenzl weisst du da mehr?
              Bitte stellt Eure Anfragen nicht per PN, ich bevorzuge das Fragen/Antworten im Forum, damit alle etwas davon haben. Vorher lesen: https://www.loxforum.com/forum/proje...en-bitte-lesen

              LoxBerry: https://www.loxwiki.eu/display/LOXBERRY/LoxBerry

              Kommentar


              • #67
                DaOptika

                Also in der 0.3er Version des FHEM-Plugins (was Neueres hab ich nicht installiert )
                Bei mir steht alles in /opt/loxberry/config/plugins/fhem/fhem.cfg


                Zum Verständis:
                Du hast auf LB2.0 aktualisiert, und das Plugin selbst nicht? Oder hast du das Plugin auch auf 0.5 upgedated?
                PN/PM: Ich bevorzuge die Beantwortung von Fragen in öffentlichen Threads, wo andere mithelfen und mitprofitieren können. Herzlichen Dank!

                Kommentar


                • #68
                  Plugin auf 0.5, Backup, LB2.0
                  dann hat er mir die config wohl schon bei dem 0.5 update update zerschossen...
                  Mist!

                  Kommentar


                  • #69
                    Hallo zusammen!

                    Bei mir hat auch das Update auf 0.5 die Konfiguration zerschossen, wegen Backup aber nicht so schlimm!


                    Neue Frage: Ich möchte "tradfri-fhem" nutzen, habe das nach den gängigen Anleitungen installiert und bekomme es einfach nicht zu laufen. Gibt es Besonderes zu beachten wenn man einen Loxberry nutzt?


                    Vielen Dank!
                    Gruß Markus

                    KNX, Miniserver (10.2.3.26), 1x Extension, 1x Air Base Extension, 1x Multi Extension Air, 6x Temp. & Hum. Air, 4x Raumklima Sensor Air, 4x Smart Socket Air, 2x Nano IO Air, 1x Remote Air, 1x Contact Air, LoxBerry (Weather 4 Loxone, FHEM, MQTT Gateway), WP Waterkotte DS5017.3, Landroid L WG798E

                    Kommentar


                    • #70
                      Ich hab zwar keine Tradfri, aber nach https://wiki.fhem.de/wiki/TR%C3%85DFRI -> "neu: tradfri-fhem Modul" hat zumindest das Modul bei mir gleich funktioniert.
                      Node.js brauchst du auf LoxBerry 2.0 nicht installieren (ist schon drauf).
                      In FHEM präventiv mal 'update' ausgeführt.
                      Und dann als root npm install -g tradfri-fhem
                      und schlussendlich die Config in der fhem.cfg, wie's im Wiki-Artikel steht.
                      PN/PM: Ich bevorzuge die Beantwortung von Fragen in öffentlichen Threads, wo andere mithelfen und mitprofitieren können. Herzlichen Dank!

                      Kommentar


                      • MikulaM
                        MikulaM kommentierte
                        Kommentar bearbeiten
                        Vielen Dank!

                        Ich hab zwar absolut keine Ahnung was ich vorher falsch gemacht habe, jetzt klappt's auf jeden Fall!
                        Zuletzt geändert von MikulaM; In den letzten 3 Wochen.

                    • #71
                      Hallo zusammen,

                      leider löscht das Update auf die 0.5.0 Eure gesamte Config Mit dem LB2.0 hat das nichts zu tun, sondern mit dem Pluginupdate. Ich habe daher die 0.5.0 erst einmal zurückgezogen und werde das fixen.

                      Wenn ihr noch ein Backup vor dem Pluginupdate habt, spielt das bitte zurück.
                      Zuletzt geändert von Prof.Mobilux; In den letzten 3 Wochen.
                      Bitte stellt Eure Anfragen nicht per PN, ich bevorzuge das Fragen/Antworten im Forum, damit alle etwas davon haben. Vorher lesen: https://www.loxforum.com/forum/proje...en-bitte-lesen

                      LoxBerry: https://www.loxwiki.eu/display/LOXBERRY/LoxBerry

                      Kommentar


                      • #72
                        Leider kein Backup vor dem 0.5.0 Update... Bin ich aber selbst Schuld, war immer zu faul mal eins zu machen.
                        Jetzt darf ich 40 Hue-Geräte neu einlernen

                        Kannst mir vielleicht per PM nochmal die 0.5.0 schicken? Wenn ich jetzt sowieso wieder von Null starte, dann wenigstens mit der aktuellen Version (habe es natürlich für einen frischen Start deinstalliert bevor ich das hier gelesen habe...)

                        Kommentar


                      • #73
                        Hallo zusammen,

                        es gibt nun Version 0.6.0 als PRE-RELEASE. Hierbei wird eine bestehende FHEM-Installation in die neue Installation migriert. Christian Fenzl hat es auf seiner Installation getestet und es scheint so zu funktionieren. Bitte mal versuchen das Update so durchzuführen.

                        Vorher mit LoxBerry Backup ein backup eurer SD-Karte anfertigen, damit ihr zur Not wieder zurückkommt. Wenn das so bei einigen funktioniert, mache ich die Version zum Release.

                        Download: https://github.com/mschlenstedt/LoxB...HEM-V0.6.0.zip
                        Bitte stellt Eure Anfragen nicht per PN, ich bevorzuge das Fragen/Antworten im Forum, damit alle etwas davon haben. Vorher lesen: https://www.loxforum.com/forum/proje...en-bitte-lesen

                        LoxBerry: https://www.loxwiki.eu/display/LOXBERRY/LoxBerry

                        Kommentar


                        • MikulaM
                          MikulaM kommentierte
                          Kommentar bearbeiten
                          Hallo,

                          bei mir ist nach einem Update von 0.4.2 auf 0.6.0 ebenfalls die Config weg. Mein System LB 2.0.0.3 virtualisiert auf einer Syno.
                          Ich kann gerne testen wenn es was neues gibt, ein Snapshot ist ja schnell zurück gespielt. ;-)


                          Gruß,
                          Markus

                        • Prof.Mobilux
                          Prof.Mobilux kommentierte
                          Kommentar bearbeiten
                          MikulaM Ich würd emich gerne mal Remote bei Dir einwählen, damit ich mir das anschauen kann. Geht per Remote Widget - Du musst dazu nicht "anwesend" sein. Schreib mit bitte mal eine PN.

                      • #74
                        Schlechte Nachrichten: Nach Neustart des Raspberrys ist mit 0.6.0 bei mir wieder alles weg...

                        Kommentar


                        • DaOptika
                          DaOptika kommentierte
                          Kommentar bearbeiten
                          Bin jetzt wieder zurück beim alten LB und FHEM 0.4.2... Never change und so...

                        • Prof.Mobilux
                          Prof.Mobilux kommentierte
                          Kommentar bearbeiten
                          Mmhh, Schade. Das hätte ich mir gerne mal Remote angeschaut. Hat hier eigentlich funktioniert.

                      • #75
                        MikulaM hat mir freundlicherweise einen Test-LoxBerry zur Verfügung gestellt. Da müssen jetzt aber die FHEM-Experten ran :-)

                        Nach dem Upgrade liegt FHEM standardmäßig unter /opt/fhem. Die alte Konfiguration wird auch nach /opt/fhem/fhem.cfg mit übertragen. Aber geladen wird sie nicht! FHEM läd irgendeine Default. Obwohl der Aufruf im Service.file zu stimmen scheint:

                        Code:
                        ExecStart=/usr/bin/perl fhem.pl fhem.cfg
                        Kann ich irgendwie den vollen Pfad der fhem.cfg herausfinden, die FHEM da läd?
                        Bitte stellt Eure Anfragen nicht per PN, ich bevorzuge das Fragen/Antworten im Forum, damit alle etwas davon haben. Vorher lesen: https://www.loxforum.com/forum/proje...en-bitte-lesen

                        LoxBerry: https://www.loxwiki.eu/display/LOXBERRY/LoxBerry

                        Kommentar

                        Lädt...
                        X