Ankündigung

Einklappen

PLUGINS

Bitte im Titel immer zuerst den Namen des Plugin hinschreiben
Mehr anzeigen
Weniger anzeigen

NUKI Smartlock Plugin

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • #46
    maestro1 Bitte um Screenshot, ich weiß nicht, was du meinst.
    PN/PM: Ich bevorzuge die Beantwortung von Fragen in öffentlichen Threads, wo andere mithelfen und mitprofitieren können. Herzlichen Dank!

    Kommentar


    • #47
      Klicke auf die Grafik für eine vergrößerte Ansicht

Name: Screenshot_20191111-094707.jpg
Ansichten: 140
Größe: 173,1 KB
ID: 219731

      Kommentar


      • #48
        Schaut richtig aus.
        Wenn du die Callback-Url aus dem Plugin in deinem Webbrowser aufrufst, kommt dann sowas raus?

        Klicke auf die Grafik für eine vergrößerte Ansicht  Name: callback.JPG Ansichten: 0 Größe: 24,6 KB ID: 219742

        Der Fehler in der Meldung ist ok (wir haben mit dem Browseraufruf ja keine Daten mitgeschickt). Beim Aufruf darf keine Passwortabfrage kommen.

        Sonst mal die Bridge abstecken und wieder anstecken, vielleicht spinnt sie einfach.
        PN/PM: Ich bevorzuge die Beantwortung von Fragen in öffentlichen Threads, wo andere mithelfen und mitprofitieren können. Herzlichen Dank!

        Kommentar


        • #49
          So siehts korrekt aus. Haus wurde um 7:40 verlassen um 9:30 wars noch immer nicht so sehen, leider habe ich jetzt keinen Screen wenns nichts anzeigt, aber es sieht halt so aus anstatt dem schild ist ein "i" symbol und darunter steht noch Kominierter Status, das wars, rest ist leer.
          Was ich mir eben noch eingerichtet habe ist das ich nicht nur den Kombi habe sondern einzeln Batterie und Schließzustand.
          Batterie zeigt mir immer etwas an, nur eben der Kombi und Schließ diese 2 zeigen mir oft nichts an.

          Kommentar


          • #50
            maestro1

            Wenn das Verhalten wieder auftritt, mach bitte einen Screenshot aus der LiveView mit den Eingangswerten, und aus der "Incoming Overview" vom MQTT Gateway.

            lg, Christian
            PN/PM: Ich bevorzuge die Beantwortung von Fragen in öffentlichen Threads, wo andere mithelfen und mitprofitieren können. Herzlichen Dank!

            Kommentar


            • #51
              Bei Aufruf des Callbacks:
              Using broker settings from MQTT Gateway plugin: Topic: nuki/ Host : localhost Port : 1883 User : loxberry Pass : 5*************** Type : callback (1) DATA : ERROR: No valid json data

              -> Sollte also passen. Habe alles was beteiligt ist schon mehrfach neu gestartet

              Kommentar


              • #52
                Dann kann ich leider nicht mehr weiterhelfen.
                Der Callback wird von der Bridge ausgeführt, und diese ruft die genannte Callback-URL auf (oder sollte das tun).
                Da du den Cron-Eintrag bekommst, funktioniert die Verbindung LoxBerry->Bridge und Nuki-Plugin->MQTT-Broker.

                Ob die Verbindung Bridge->LoxBerry in deinem Netzwerk funktioniert, bzw. was die Bridge mit dem Callback macht, kann ich leider nicht prüfen.

                lg, Christian
                PN/PM: Ich bevorzuge die Beantwortung von Fragen in öffentlichen Threads, wo andere mithelfen und mitprofitieren können. Herzlichen Dank!

                Kommentar


                • #53
                  Mache ich vielleicht einen Fehler beim Senden der Befehle und deswegen wird dann kein Callback ausgelöst? Bei mir funktionieren leider die Links auf die Templates nicht...

                  Ich habe einen virtuellen Ausgang, als Adresse http://192.168.178.69:8080, Haken bei "Verbindung nach Senden schließen".
                  Lock-Befehl ist dann zum Beispiel: /lockAction?nukiID=xxxx&deviceType=0&action=2&nowai t=1&token=xxxx

                  Kommentar


                  • #54
                    Warum funktioniert das Template nicht? Was ist im Template anders als bei deinem Aufruf?

                    EDIT: Ach, du kannst das Template garnicht erst runterladen? Das liegt an einem grottigen Browser Wenn der Sperrbefehl vom Schloss richtig ausgelöst wird, dann passt dein Befehlt jedenfalls. Dem Callback ist es egal, ob du per Bridge API, per Nuki App oder mit der Hand am Schloss drehst.
                    Aber wie gesagt, der Callback ist keine Funktion von uns, das Plugin ist nur der Empfänger.
                    Zuletzt geändert von Christian Fenzl; In den letzten 3 Wochen.
                    PN/PM: Ich bevorzuge die Beantwortung von Fragen in öffentlichen Threads, wo andere mithelfen und mitprofitieren können. Herzlichen Dank!

                    Kommentar


                    • DaOptika
                      DaOptika kommentierte
                      Kommentar bearbeiten
                      Der Link auf die Templates funktioniert nicht: wenn ich im Plugin bei "Geräte" auf die Ein-und Ausgänge gehe, sind da zwei Download-Links, die bei mir beide nicht funktionieren ("VO_NUKI_Haustür.xml konnte nicht heruntergeladen werden"), liegt scheinbar daran dass ich den Namen vom Nuki auf "Haustür" geändert habe?

                    • Christian Fenzl
                      Christian Fenzl kommentierte
                      Kommentar bearbeiten
                      OK, verstehe. Siehe EDIT oben. Das mit dem Download muss ich mir ansehen, wahrscheinlich muss der Dateiname im Link irgendwie encoded sein.

                  • #55
                    Hallo zusammen,

                    klappt das eigentlich auch mit der Softwarebridge ? Oder muss zwingend die originale Bridge herbei ?
                    (Sorry falls ich das irgendwo überlesen habe)

                    Reiner

                    Kommentar


                    • #56
                      rvbruch
                      Grundsätzlich SOLLTE es funktionieren (die API ist identisch), aber wir haben es selbst nicht getestet und bisher kein spezifisches Feedback zur Software-Bridge erhalten.

                      @ALL
                      Ist hier jemand, der das Plugin mit der Software-Bridge einsetzt?

                      lg, Christian
                      PN/PM: Ich bevorzuge die Beantwortung von Fragen in öffentlichen Threads, wo andere mithelfen und mitprofitieren können. Herzlichen Dank!

                      Kommentar


                      • #57
                        Hallo,

                        super Plugin! Bin gerade erst darauf gestoßen nachdem ich bis jetzt die manuelle "Eigenbau"-Variante für Callbacks verwendet habe. Danke!

                        Nur eine Frage. Mir kommt vor, dass ich nur dann ein Callback bekomme wenn ich das Nuki über die Nuki-App schließe oder öffne. Das funktioniert perfekt. Callback innerhalb von etwa 4 Sekunden würd ich sagen.

                        Wenn ich aber über den digitalen Ausgang schließe oder öffne dann bekomme ich kein Callback.

                        Sollte das nicht in allen Fällen funktionieren? Kennt jemand dieses Verhalten?

                        LG
                        Markus

                        Kommentar


                        • Prof.Mobilux
                          Prof.Mobilux kommentierte
                          Kommentar bearbeiten
                          Die Bridge ist leider schrott (Softwareseitig). Du darfst sie nicht überfordern (also zu oft/schnell hintereinander probieren). Nuki arbeitet bereits an einem Update. Einfach mal ein wenig warten und nix machen, dann über den Dig. Ausgang schalten. Dann sollte auch ein CallBack kommen.

                      • #58
                        Moin !

                        habe mich inzwischen auch für die Bridge entschieden. Mir fällt auf, dass sich das Teil regelmäßig aus dem Wlan verabschiedet. Ganz speziell, wenn ich aus der Loxone heraus zB einen Schließbefehl abschicke. Danach ist erstmal Feierabend. Kommt aber irgendwann wieder.
                        Aber auch so kann ich ab und zu nicht über die Bridge zugreifen.

                        Was sagen die Erfahrenen? Normal oder ein Fall für Reklamation?
                        Ich habe die Fritzbox eigentlich in der Nähe, habe aber noch zusätzlich einen Repeater gesetzt. Ändert auch nix.

                        Reiner

                        Kommentar


                        • #59
                          Auf jeden Fall prüfen, dass du die aktuellste Firmware hast (im Wiki sind Links, was grad aktuell ist).

                          Was wir wissen (was Prof.Mobilux oben schon geschrieben hat):
                          Kommen viele Befehle auf einmal, ist die Bridge mehr oder weniger tot. Irgendwann geht es wieder. Es gab im DEV-Forum von Nuki auch Meldungen von Crashes.

                          Nuki arbeitet daran, gibt schon Fortschritte.

                          Ob das bei dir jetzt die schlechte Bridge-Firmware, oder tatsächlich ein WLAN-Issue ist, kann man schwer sagen.
                          Wenn du die Bridge definitiv nicht überforderst, dann evt. mal den Support kontaktieren, am besten mit der Bridge Hardware-ID.
                          PN/PM: Ich bevorzuge die Beantwortung von Fragen in öffentlichen Threads, wo andere mithelfen und mitprofitieren können. Herzlichen Dank!

                          Kommentar


                          • #60
                            Ich hab das heute nochmal ausprobiert. Wenn ich direkt über den Button am Smartlock oder über die Nuki App öffne oder schließe dann bekomm ich praktisch sofort den Callback. Über den Digitalausgang in Loxone bekomme ich keinen Callback. Es kann auch nicht an einer Überlastung der Bridge liegen. Heute Morgen hab ich zum ersten Mal nach etwa 12 Stunden über Loxone aufgesperrt und es kam wieder kein Callback.

                            Kennt das jemand oder habt ihr eine Idee was das Problem sein kann?

                            Kommentar

                            Lädt...
                            X