Ankündigung

Einklappen

INFORMATION

Dieser Bereich ist für fertige Lösungen gedacht. Nutze bitte für Diskussionen die anderen Bereiche.
Mehr anzeigen
Weniger anzeigen

Phillips HUE mit Loxone verwenden

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • fhainz da fällt mir grad ein, dass wir einfacher testen könnten ob da bei den Befehlen durch das Script ein Fehler zurückgeschickt wird. Du könntest die Befehle direkt an der Bridge ausprobieren. Da gibts den Debugkonsole. Sieh Dir mal https://developers.meethue.com/develop/get-started-2/ an da ist erklärt. Wie es geht. Eine UserID brauchst Du ja nicht erstellen. Du kannst ja die nehmen, die Du im Script benutzt.
    Ich stelle Dir mal Daten zusammen, auf die ich gern die Reaktion der Bridge hätte.
    Miniserver; KNX; Vitogate; EnOcean (EnOceanPi); Loxone Air; Caldav-Kalenderanbindung; RaspberryPi und für keine Frickellösung zu schade :-)

    Kommentar


    • svethi
      svethi kommentierte
      Kommentar bearbeiten
      Nee, keine Ahnung

    • svethi
      svethi kommentierte
      Kommentar bearbeiten
      Hi fhainz,
      Du hast ein Update für die Bridge bekommen und da haben die die debug/clip.html kaputt gespielt
      Hab gerade meine Bridge getauscht, die vorhandenen User wurden leider nicht übernommen und nun wollte ich "mal eben" einen neuen User generieren ... geht nicht so.
      Hast Du etwas Ahnung? Ich könnte Dir einen gepatchte clip.html geben, die Du Dir auf irgendeinen webserver (z.B. Loxberry) packen kannst um wieder ranzukommen?.

    • fhainz
      fhainz kommentierte
      Kommentar bearbeiten
      Danke für den Hinweis mit der clip.html. Auf das wäre ich nie gekommen.

      Du kannst mal noch einen Farbbefehl versuchen, doch ich vermute mal, dass da auch kein Fehler kommt.
      {"xy": [0.3171,0.3366],"bri": 250,"on":true, "transitiontime": 10}
      Wie du vermutet hast, bekomme keinen Fehler zurück.

      Code:
      [
      	{
      		"success": {
      			"/lights/14/state/transitiontime": 10
      		}
      	},
      	{
      		"success": {
      			"/lights/14/state/on": true
      		}
      	},
      	{
      		"success": {
      			"/lights/14/state/xy": [
      				0.3171,
      				0.3366
      			]
      		}
      	},
      	{
      		"success": {
      			"/lights/14/state/bri": 250
      		}
      	}
      ]

  • ist es möglich, ein 'Philips Hue Filament' mit dem Pico-Skript zu dimmen? Wenn ja, wie kann ich das machen?

    Kommentar


    • 24cx
      24cx kommentierte
      Kommentar bearbeiten
      svethi
      Irgendetwas irgendwie eingeben mache ich normalerweise auch nicht, aber nachdem alles richtig war blieb mir nichts mehr übrig. Ich habe immer alles auf den Miniserver gespielt und habe auch das Array zwischenzeitig angepasst - es handelt sich um ein zweites Script, welches im Wertebereich ID 12-23 (mit Lücken dazwischen) steht. Schließlich kommt man irgendwann auf mehr als 10 Lampen / Schalter und will diese auch steuern. Lücken entstehen ja leider beim Löschen und neu hinzufügen.

      Ich habe die API Calls leider nicht überprüfen können, weil die CLIP.html nicht mehr funktioniert (nach Update) und weil das Script die API Calls ja erstmal nicht ausgibt. Aber interessanterweise funktionieren sowohl die innr Steckdosen, als auch das Filament wenn man sie über einen virtuellen Befehl in Loxone anlegt. Dann klappt es auch mit dem Dimmen im Bereich 1-254 super. Irgendwo hat sich also mein zweites HUE Script aufgehängt bzw. kommt nicht mit den Lücken oder IDs de rLampen zurecht.

    • svethi
      svethi kommentierte
      Kommentar bearbeiten
      Wenn Du hier mal etwas gelesen hättest, hättest Du auch gesehen, dass ich die clip.html korrigiert zur Verfügung gestellt habe.
      Welche Version des Scriptes hast Du denn?

    • 24cx
      24cx kommentierte
      Kommentar bearbeiten
      Ich habe hier alles gelesen. Auch dass du die CLIP zur Verfügung gestellt hast. Sogar mehrfach alles gelesen und auch wegen des Kommentars #453 z.B. überhaupt erst angefangen die 7 als Gruppe einzustellen... Ich habe nur erklären wollen woran es gescheitert ist schlussendlich.... zumindest nicht mehr ging mit den normalen Hausmitteln - ich habe die Version die auf Bridge V2 aktualisiert war.


  • Vielen Dank für die Antworten. Die 'Philips Hue Filament'-Lampen können in der Tat als dimmbare Lampe verwendet werden (heller oder weicher und ein / aus). Folgendes wird im Skript eingestellt: 7 = Dimmer-Eingang, wer 1, aber für Gruppe.
    Zuletzt geändert von grotius; 16.Nov.2019, 18:13.

    Kommentar


    • Ich habe das Problem, dass ich von dem CLIP API Debugger keine Antwort erhalte.
      Also so wie in dem Link (Seite1) beschrieben, lässt sich der CLIP API Debugger zwar aufrufen, aber wenn ich /api/newdeveloper bei URL eingebe dann bekomme ich KEINE Antwort - nix passiert.
      Woran kann das liegen? Browser Einstellungen? Oder weil ich auf meine Bridge auch mit iConnectHue App zugreife?
      Bridge habe ich schon neu gestartet. Ohne Erfolg.
      Zuletzt geändert von DasBesteOderNichts; 23.Nov.2019, 20:06.

      Kommentar


      • svethi
        svethi kommentierte
        Kommentar bearbeiten
        Philips hat das debug/clip.html kaputt gemacht. Kennst Du Dich etwas mit Linux oder dergleichen aus? Ich könnte Dir eine gepatchte clip.html zur Verfügung stellen. Diese müsstest Du aber auf einem Webserver (z.B. dem Loxberry) installieren und dort dann aufrufen.

      • DasBesteOderNichts
        DasBesteOderNichts kommentierte
        Kommentar bearbeiten
        Ich kenne mich mit Linux leider nicht aus. Ich wäre aber bereit einiges an Aufwand zu betreiben um es trotzdem hinzubekommen.
        Verstehe ich das richtig, dass ich das dann dauerhaft auf Loxberry oder ähnlichem laufen lassen muss, oder ist das nur damit ich einen User auf der Hue Bridge erstellen kann?

      • svethi
        svethi kommentierte
        Kommentar bearbeiten
        es geht nur um die debug/clip.html um z.B. den User anzulegen. Alles andere läuft weiter über die Bridge

    • Hi All,
      derzeit ist die clip.html auf den HUE Bridges kaputt. Ich stelle hier mal eine funktionierende zur Verfügung. Habe es grad mal ausprobiert. Man braucht noch nicht einmal einen Webserver. Einfach die enthaltene clip.html mit Eurem Browser der Wahl öffnen.
      WICHTIG: bei der URL muss vor den Angaben auf der Philipsseite immer "http://IP-DER-BRIDGE" stehen. Also z.B. http://192.168.178.10/api/newdeveloper.
      Angehängte Dateien
      Miniserver; KNX; Vitogate; EnOcean (EnOceanPi); Loxone Air; Caldav-Kalenderanbindung; RaspberryPi und für keine Frickellösung zu schade :-)

      Kommentar


      • varmin
        varmin kommentierte
        Kommentar bearbeiten
        Hi svethi! Kannst du bitte die funktionierende clip.html nochmals online stellen - der Link für den Download der "hue.zip" funktioniert nicht mehr. Vielen Dank (und schöne Feiertage...)

      • svethi
        svethi kommentierte
        Kommentar bearbeiten
        Der Link funktioniert mit Sicherheit. Versuche ihn nochmal, nachdem Du was gepostet hast.

      • varmin
        varmin kommentierte
        Kommentar bearbeiten
        Hi! Jetzt hat es geklappt - habe auch problemlos damit arbeiten können! Vielen vielen Dank - auch für die schnelle Antwort! Top!

    • Woher weiß ich, welche meiner Hue Lampen oder Gruppen (auf der Bridge) zu welcher ID im Programm gehören?
      Also mir ist noch nicht ganz klar, wie ich die Zuordnung mache.

      Hat bestimmt schon mal jemand gefragt oder erklärt, aber bei 30 Seiten zu einem Thema ist es auch schwer den Überblick zu bekommen.

      Kommentar


      • Moin !

        Das steht im ersten Post im Link in der 4. Zeile.

        Kommentar


        • DasBesteOderNichts
          DasBesteOderNichts kommentierte
          Kommentar bearbeiten
          Ja danke. Ich habe es mittlerweile selber durch Testen herausgefunden.

      • fhainz : Ich habe auch eine IKEA Tradfri mit Dimmable White. Dabei ist mir aufgefallen, dass diese einen Bug hat: Sie kann in einem Befehl keine 2 Werte (bspw: BRI & SAT) verarbeiten. Sie antwortet zwar mit success, führt aber nur einen der 2 Befehle aus (gleiches Verhalten auch, wenn ich den Befehl über die Debug-Bridge absende). Das könnte ich mir auch bei dir vorstellen. Ich habe bei mir das Skript erweitert, so dass der 2. Wert etwas verzögert an die Lampe geschickt wird; allerdings habe ich das bisher nur für Helligkeit & Farbtemperatur eingebaut (also nicht Farbe).

        Kommentar


        • fhainz
          fhainz kommentierte
          Kommentar bearbeiten
          Ok, das könnte ich versuchen!
          Wie hast du das Script umgebaut?

        • svethi
          svethi kommentierte
          Kommentar bearbeiten
          Das ist auch meine Vermutung. Wenn ich dazu komme, kann ich es ja mal umbauen

      • Anbei mal meine Erweiterung vom Skript für meine Tradfi Leuchte (mit TuenableWhite); ansteuerung via Lumitech. Wie gesagt, ich hab für meine Belange nur die Farbtemperatur berücksichtigt; ein paar Fehler sind bestimmt auch noch drin...
        Angehängte Dateien

        Kommentar


        • Hallo,

          Danke für das Script für Ikea.

          Ich habe mir gerade ein paar Tuneable White von Osram gekauft ( G10). Welchen Wert muss denn hier ins Script ? 4 oder 5 als RGB und im Baustein dann Lumitech? Kann es nicht probieren, weil die Leuchtmittel noch nicht eingetroffen sind.

          Danke.....

          Kommentar


          • Servus,

            ich hab eine kurze Frage. Bei mir ist die Reaktionszeit in der Loxone App sehr lange, wir reden hier von 1-7 Sekunden pro Farbwechsel. Ist das Normal oder hab ich was falsch gemacht?

            Danke

            Kommentar


            • Dears,

              from where may I get the latest PicoC script for Philips Hue compatible with Loxone Config 10.3 and Hue hib latest FW? I've read some posts here and there in the LoxWiki without having a good feeling about latest stable version.

              Thanks!

              Kommentar


              • SchmuFoo
                SchmuFoo kommentierte
                Kommentar bearbeiten
                Still works fine with Loxone 10.3 and even with an Hue Beta Firmware

            • Neue Version des HUE-PicoC-Scripts verfügbar! Siehe Positing #1

              Danke an svethi für die Programmierung der Änderungen!

              Kommentar


              • Danke fürs Onlinestellen.
                habe noch einen Hinweis dazu. Ich hatte den Andreas die Werte 1 und 255 gesagt. Diese beziehen sich auf die HUE Werte intern. Am Eingang geht es um 1% und 100% wie es aus einem Dimmerbaustein kommt.
                Hintergrund des Ganzen ist, dass man eine Szene nicht dimmen kann. Sie ist immer so, wie sie erstellt wurde. Eine Szene wird aber auch immer an ein bestehende Gruppe gebunden, die sehr wohl zu dimmen ist. Wird nun mit 100% die gewünschte Szene aktiviert, kann man danach dimmen. Je nachdem in welcher Helligkeit die Szene angelegt wurde, kann es sein, dass es beim Dimmen von 100% auf 99% erstmal heller wird. Das ist in dem Fall normal.
                Miniserver; KNX; Vitogate; EnOcean (EnOceanPi); Loxone Air; Caldav-Kalenderanbindung; RaspberryPi und für keine Frickellösung zu schade :-)

                Kommentar


                • Moin, bei meiner Huebridge lässt sich kein User erstellen und mir wird auch die api nicht ausgegeben, hat sich da irgendetwas geändert?

                  grüße Leonard

                  Kommentar


                  • svethi
                    svethi kommentierte
                    Kommentar bearbeiten
                    Nein, es hat sich nichts geändert. Man sollte noch immer lesen

                  • Leonard Lassen
                    Leonard Lassen kommentierte
                    Kommentar bearbeiten
                    Jup habe ich gemacht, so wie es auf der website stand geht nicht. Habe mich dann über teamviewer zu einem Freund verbunden, bei dem ging es aber auch nicht.

                  • svethi
                    svethi kommentierte
                    Kommentar bearbeiten
                    Hier im Forum. Problem ist bekannt mehrfach behandelt und von mir auch ein WA bereitgestellt.
                Lädt...
                X