Ankündigung

Einklappen

INFORMATION

Dieser Bereich ist für fertige Lösungen gedacht. Nutze bitte für Diskussionen die anderen Bereiche.
Mehr anzeigen
Weniger anzeigen

Phillips HUE mit Loxone verwenden

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Hallo,

    ich selbst setze HUE noch nicht mit Loxone ein, habe das aber bald für die Gartenbeleuchtung geplant und lese daher hier etwas mit. Bei der Suche nach Leuchtmitteln bin ich darauf gestoßen, dass nun auch Lampen von Ikea in HUE ohne zusätzliche Bridge eingebunden werden können (sh. auch http://stadt-bremerhaven.de/ikea-tra...hue-einbinden/ ). Vielleicht ist es für den ein oder anderen interessant hinsichtlich der HUE-Einbindung.

    Viele Grüße

    Kommentar


    • Vossi
      Vossi kommentierte
      Kommentar bearbeiten
      Naja, die HUE-Bridge benötigt man schon, nur die IKEA Bridge nicht mehr zusätzlich...
      Aber immerhin!

  • ... ist halt preislich interessant...

    Kommentar


    • hat jemand hier schon die Ambiance (z.B. GU10) mit Ct zum laufen bekommen?
      Ich habe viels durch proobiert, ich kann nur dimmen...

      Kommentar


      • Ich hatte doch da vor langer Zeit mal eine Funktion eingebaut, die eine Glühlampe simuliert. Das funktioniert über ct. Je dunkler, je wärmer. Die Beiden Endpunkte kannst Du angeben.
        Miniserver; KNX; Vitogate; EnOcean (EnOceanPi); Loxone Air; Caldav-Kalenderanbindung; RaspberryPi und für keine Frickellösung zu schade :-)

        Kommentar


        • Andreas Lackner
          Andreas Lackner kommentierte
          Kommentar bearbeiten
          für die "Glühlampen"-Simulation von Svethi inputType[x] = 5 setzen...

        • svethi
          svethi kommentierte
          Kommentar bearbeiten
          Hihi, danke. Hab da so lange nicht mehr reingesehen. Läuft halt einfach das Script von Andreas ;-)

      • Hallo,

        Ich habe schon seit Monaten das Programm in Betrieb ( mit Hue , Innr , Dresden Electronic Fls-PP, Lightify Lampen alles gemischt und durcheinander ) funktioniert normalwerweise alles tadellos . Leider habe ich Tage ,wo die Ansteuerung extrem langsam ist und die Hälfte der Lampen "vergessen" werden! Beim Ausschalten bleiben öfters Lampen an , dann musss ich wieder alles einschalten und alles ausschalten , wenn das nicht hilft muss ich die Lampen mit der HUE-App ausschalten !

        Hat jemand die gleichen Probleme oder ein Lösung für mein Problem ?
        Ich arbeite noch mit der "alten runden " Bridge , funktioniert die neue besser ?

        Besten Dank
        schöne Grüsse aus Luxemburg

        Kommentar


        • neonnt
          neonnt kommentierte
          Kommentar bearbeiten
          Solche Probleme habe ich auch mit der App, scheint wohl eher etwas mit der Verbindung der Lampen untereinander zu tun zu haben

      • Zitat von Biff12 Beitrag anzeigen
        Hallo,

        Ich habe schon seit Monaten das Programm in Betrieb ( mit Hue , Innr , Dresden Electronic Fls-PP, Lightify Lampen alles gemischt und durcheinander ) funktioniert normalwerweise alles tadellos . Leider habe ich Tage ,wo die Ansteuerung extrem langsam ist und die Hälfte der Lampen "vergessen" werden! Beim Ausschalten bleiben öfters Lampen an , dann musss ich wieder alles einschalten und alles ausschalten , wenn das nicht hilft muss ich die Lampen mit der HUE-App ausschalten !

        Hat jemand die gleichen Probleme oder ein Lösung für mein Problem ?
        Ich arbeite noch mit der "alten runden " Bridge , funktioniert die neue besser ?

        Besten Dank
        schöne Grüsse aus Luxemburg
        Hi,
        ich habe das gleiche Problem. Mittlerweile sogar noch ein weiteres. Loxone ist schon auf mich zugekommen, da das Pico C Programm für Abstürze sorgt. Auf meine Frage, wann sie HUE denn nativ mit einbinden kam natürlich nur Schulterzucken.
        Ich habe das aktuelleste Script eingebunden, überlege aber gerade die Hue´s in FHEM auszulagern und über diese Krücke in Loxone einzubinden.
        Ich nutze auch noch die alte runde Bridge.

        Beste Grüße
        Mc

        Kommentar


        • Andreas Lackner
          Andreas Lackner kommentierte
          Kommentar bearbeiten
          Einziger "Known-Bug" waren die zu kleinen Textvariablen für die Log- und Kommandoausgabe - dann ging aber gar nix mehr... ein Speicherloch oder sonst was kann ich mir beim Besten Willen nicht vorstellen (zumindest nicht direkt durch das Programm verursacht).
          Aber die Pico-C Implementierung dürfte wohl auch ihre Schwachstellen haben, und wer weiß, was z.B. die Implementierung von httpRequest macht...
          Das HUE-Programm an sich ist ja sehr einfach. Es hat keine Schleifen, reserviert keine großen Speicherbereiche oder ähnliches...

          Bei mir läuft das gesamte System völlig stabil, lediglich eine Lampe "spinnt" regelmäßig - und da ist einfach der ZigBee Empfang sehr schlecht...

      • Also bei mir läuft das Script jetzt schon Jahre. Okay, sicher nicht in der altuellen Fassung, doch ich denke, dass das nicht am Script als solches liegt. Was macht Ihr denn damit? Andauernde Farbwechsel? Permanentes Hoch-Runterdimmen? Ihr müsst bedenken, dass bei jeder geringsten Änderung am Farbwert/Dimmwert eine Verbindung zur Bridge aufgebaut werden muss und die Daten übermittelt werden müssen. Wenn Ihr da z.B. Mit dem Finger über den Farbkreis wischt, kommen da soo viele Daten zusammen, dass das schon zum Stau führen kann. Solche Lösungen sollten mit Bedacht eingesetzt werden.
        Miniserver; KNX; Vitogate; EnOcean (EnOceanPi); Loxone Air; Caldav-Kalenderanbindung; RaspberryPi und für keine Frickellösung zu schade :-)

        Kommentar


        • Biff12
          Biff12 kommentierte
          Kommentar bearbeiten
          Hallo,
          Also ich wechsele die Farben nicht ! Nur beim Szenen Aufruf schalte ich 13 Lampen mit der gewünschten Farbe , soll ich die Ansteuerung verzögern also eine Lampe nach der anderen einschalten ?
          mfg

      • Hi Svethi,
        also ich kann es mir tatsächlich auch nicht besser erklären. Der Hinweis mit dem Pico C Fehler kam dann von Loxone direkt, die sich aus dem Nichts bei mir gemeldet haben. Ich hab jetzt deine aktuellste Version genommen.
        Ich wechsle die Farben eigentlich gar nicht, da ich über Szenen schalte.
        Denke mal, dass es auch erst mit den ganzen Versionsänderungen kam.
        Aber ich stelle meine gesamte Programmierung sowieso gerade auf den Prüfstand, da muss ich noch mal von vorne ran, anstelle zu verschlimmbessern :-)
        Beste Grüße
        Mc

        Kommentar


        • Ich habe das Script auch schon länger in Verwendung.
          Bei mir war es auch so, dass das Licht ab und zu nicht ein und ausgeschaltet wurde.
          Bei mir ist aber die Quadratische also nicht die Runde Hue Bridge im Einsatz.

          Woran das liegt konnte ich nicht herausfinden.
          Warum es bei anderen funktioniert und bei mir nicht, kann ich nicht sagen, glaube aber dass die Meldung irgendwo zwischen Loxone und Lampe verloren geht.

          Als Notlösung habe ich das Script für meine Bedürfnisse daher angepasst.
          Ich sende das Kommando und frage danach die Hue ab ob das jeweilige Licht an oder aus ist.
          Wenn dies nicht der Fall ist, schicke ich den Status erneut. Das wiederhole ich maximal 5 mal.
          Zudem starte ich einen Pingbaustein um zu schauen ob die Hue erreichbar ist und gebe gleichzeitig einen Fehler im Tracker aus.
          Wenn die Hue den Ping bestätigt werden nochmals alle Lampenwerte gesendet.
          Die Fehler sind damit nicht weg, aber zumindest kann ich mich einigermassen darauf verlassen dass das Licht im gewünschten Zustand ist.

          Dass dies bei mir doch sehr oft vorkommt zeigen die Einträge im Tracker.
          Klicke auf die Grafik für eine vergrößerte Ansicht

Name: HueFehler.png
Ansichten: 218
Größe: 144,3 KB
ID: 126301
          lg Romildo

          Kommentar


          • Ich hab das Script auch schon lange im Einsatz und auch ab und zu das Problem.

            Hab mich mal etwas informiert bezügliche ZigBee und Wi-Fi Frequenzen (2.4GHz) und bin auf folgenden Artikel gestossen: https://support.metageek.com/hc/en-u...Fi-Coexistence

            Habe nun meinen Hub mal auf Channel 25 (vorher 11) und Wi-Fi 2.4GHz auf 1 und 6 (vorher Auto). Wohnen etwas abgelegen, entsprechend haben wir keine "fremden" Wi-Fi Netze.

            Werde nun mal beobachten.

            Gruss aus der CH,
            Christoph

            Kommentar


            • Hallo Zusammen,

              ich verwende mehre Lichtsteuerungs Bausteine, wenn ich dort jetzt auf alles EIN oder alles AUS drücke, dann gehen ja alle an der Bridge angelschlossen Lampen, auf den gewählten Modus.

              Jetzt würde ich gerne das weiterhin so nutzen wollen, jedoch sollen bei allles EIN/AUS nur die Lampen auch EIN/AUS gehen die gerade am Baustein hängen.
              Wäre das möglich?


              Gruß

              Kommentar


              • Ich verstehe die Anfragen nicht. Es werden nur die Lampen die auch die entsprechenden Befehle dazu bekommen, geschaltet. Alles Andere liegt an Deiner Programmierung.hast Du vielleicht Deine HUE's gruppiert? Dann wird natürlich die ganze Gruppe geschaltet. Du musst mal genauer schildern was Dein Problem ist.

                Gruß Sven
                Miniserver; KNX; Vitogate; EnOcean (EnOceanPi); Loxone Air; Caldav-Kalenderanbindung; RaspberryPi und für keine Frickellösung zu schade :-)

                Kommentar


                • Hi,

                  ich versuche es zu beschreiben. Am Programmierbaustein hängen alle Merker sprich die Hue Lampen 0-9 und die Gruppen 10-11. Wie im oberen Bild zu sehen, hängt am Lichtbaustein nur Merker mit den Lampen Bloom, Iris und Decke. Wenn ich jetzt an diesem Baustein alles EIN/AUS betätige, dann gehen nicht nur die Lampen am Baustein EIN/ Aus, sondern auch die anderen Lampen, die generell am Programmierbaustein hängen.

                  Das ist auch erstmal so gewohlt, weil der Code das so macht, der triggert ja über den 12er Ausgang die Funktion alles EIN/AUS in der Hue Bridge.

                  Ich würde aber gerne das wie folgt haben. Es gib nur einen Programmierbaustein HUE, der alle Lampen und Gruppen kennt, und je nach dem welche Merker am Lichtbaustein hängen, sollen halt geschaltet werden.


                  Ich hoffe ich habe es Verständlich beschrieben.

                  Gruss


                  Zitat von svethi Beitrag anzeigen
                  Ich verstehe die Anfragen nicht. Es werden nur die Lampen die auch die entsprechenden Befehle dazu bekommen, geschaltet. Alles Andere liegt an Deiner Programmierung.hast Du vielleicht Deine HUE's gruppiert? Dann wird natürlich die ganze Gruppe geschaltet. Du musst mal genauer schildern was Dein Problem ist.

                  Gruß Sven

                  Kommentar


                  • Ja, Du darfst den 12-er Eingang nicht nutzen, dann geht das auch. Den brauchst Du ja auch nicht. Die Lichtsteuerung setzt ja alle Lampen auf aus. Wenn Du dann noch über den Programmbaustein alles setzt, ist das ja doppelt gemoppelt.
                    Miniserver; KNX; Vitogate; EnOcean (EnOceanPi); Loxone Air; Caldav-Kalenderanbindung; RaspberryPi und für keine Frickellösung zu schade :-)

                    Kommentar


                    • Hi,

                      muss ich das im Programmierbaustein, dann ganz löschen?
                      Aktuell ist es so, wird trotzdem alles ausgeschaltet:



                      Zitat von svethi Beitrag anzeigen
                      Ja, Du darfst den 12-er Eingang nicht nutzen, dann geht das auch. Den brauchst Du ja auch nicht. Die Lichtsteuerung setzt ja alle Lampen auf aus. Wenn Du dann noch über den Programmbaustein alles setzt, ist das ja doppelt gemoppelt.

                      Kommentar

                      Lädt...
                      X