Ankündigung

Einklappen

INFORMATION

Dieser Bereich ist für fertige Lösungen gedacht. Nutze bitte für Diskussionen die anderen Bereiche.
Mehr anzeigen
Weniger anzeigen

Phillips HUE mit Loxone verwenden

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • okenny
    Die Hue Lampe hat ja immer den Status "on:true" sofern sie nicht aus ist, dann hat sie nähmlich "on:false"
    Diesen könntest Du ja beispielsweise über einen HTTP-Eingang abfragen. Die kleinste Abfragezykluszeit ist allerdings 10s.
    An sonsten müsstest Du dafür einen Programmblock verwenden.
    lg Romildo

    Kommentar


    • Hallo zusammen, ich habe eine HUE Ambiance Lampe, welche ich nicht eingebunden bekomme. Die Lampe ist Dimmbar und kann von kaltweiss nach warmweiss verstellt werden.
      Welche Parameter sind denn die richtigen? RGB oder Dimmer?

      Irgendwie passiert nichts...

      Hoffe Ihr könnt mir helfen.

      Grüße
      Angehängte Dateien

      Kommentar


      • okenny
        okenny kommentierte
        Kommentar bearbeiten
        hast du keine Hilfe bekommen?
        ich wollte auch Ambiance Lampen einbinden.....hast du es selber hinbekommen?

      • rcorten
        rcorten kommentierte
        Kommentar bearbeiten
        Hat es einen bestimmten Grund, warum du erst in einen Merker gehst, anstatt direkt auf den "Programbaustein" ?

      • okenny
        okenny kommentierte
        Kommentar bearbeiten
        ich habe ohne Merker gemacht, geht auch.
        Aber ich habe die Ambiance nicht zum laufen bekommen.......
        Zuletzt geändert von okenny; 24.Mär.2017, 07:31.

    • Hallo, nein bisher leider noch nicht.

      Kommentar


      • Hallo Okenny, wie hast Du es denn hinbekommen? Was ist an meiner Config denn falsch?
        Grüße

        Kommentar


        • okenny
          okenny kommentierte
          Kommentar bearbeiten
          Meine Ambiance gehen nicht leider. RGB geht ohne Problem....
          Ich werde es mit Scenes an Radio buttons oder ähnliches probieren, per UDP mit Fhem.

      • Muss man diese nicht im Lichtsteuerungsbaustein als "Lumitech" konfigurieren. Ich hab zwar keine davon im Einsatz, aber überlege gerade mit welche zuzulegen. Suche nur nach günstigen intelligenten Schaltern/Tastern.

        Kommentar


        • okenny
          okenny kommentierte
          Kommentar bearbeiten
          Danke, Lumitech probiere ich heute Abend aus.

      • Für die Ambient-Lampen sollte InputType 5 funktionieren, da die Lampe mit dem Parameter "ct" angesprochen werden muss.

        ++Luke

        Kommentar


        • Andreas Lackner
          Andreas Lackner kommentierte
          Kommentar bearbeiten
          Ich muss mich korrigieren. Die Ambient-Lampen sind ja nicht nur in ihrer Farbtemperatur veränderbar, sondern auch dimmbar. d.h. wäre seitens Loxone Lumitech und im Programmbaustein inputType 0 oder 4 (bzw 3 oder 6 für Gruppen) zu verwenden. Für die Ambientlampen macht natürlich die Anwahl eines RGB-Werts im Lumitech-Regler in der LoxApp gar keinen Sinn, es muss schon eine Farbtemperatur gewählt werden (Ausgangswert des Lichtbausteins ist dann 200bbbttt).

      • bei mir geht's leider nicht.....meine RGBs gehen alle, aber sobald ich versuch ein Ambiant zu schalten geht nix mehr ich ich mus den MS neustarten.....
        Ich habe InputType 5 und Lumitech und auch Dimmer 0-100% probiert..... noch eine Idee?

        Kommentar


        • Andreas Lackner
          Andreas Lackner kommentierte
          Kommentar bearbeiten
          Dass die MS hängt ist äußerst seltsam. Was sagen die Logs?

      • oh, ich hätte besser beschrieben sollen, mit "geht nix mehr" meinte ich, dass keine Hues funktionieren mehr. Die RGBs funktionieren wieder erst nach dem Restart wieder. Sonst funktioniert alles.
        Log Eintrag ist im Bild unten.
        Angehängte Dateien

        Kommentar


        • okenny
          okenny kommentierte
          Kommentar bearbeiten
          ooh, danke. Probier ich heute Abend aus

        • okenny
          okenny kommentierte
          Kommentar bearbeiten
          Es funktioniert besser - danke. Aber immer noch nicht gut genug.
          Keine Abstürze mehr

          Ich kann jetzt an und aus schalten, ich kann sogar dimmen - aber ich kann die Farbtmperatur nicht setzen.
          Ich habe alle mögliche Kombinationen ausgetestet: Lumitech & RGB mit alen inputType's.

          Mein FHEM Workaround geht noch.....wäre aber schön wenn es mit dem Pico-C Skript funktionieren würde.
          Wäre sehr denkbar, wenn du eine Idee hättest. Danke sehr.

        • Andreas Lackner
          Andreas Lackner kommentierte
          Kommentar bearbeiten
          Also die Farbetemperatur kannst du in der LoxApp sowieso nur setzen, wenn es du Lumitech eingestellt hast. Wenn du in der App dann den Farbtemperaturregler benutzt, kommt ein Wert 20xxxyyyy am Ausgang (per LiveView kontrollieren), der vom Pico-C nur dann interpretiert wird, wenn du inputType 0 oder 4 hast.
          Wenn du DEBUG_LEVEL auf 2 setzt, dann bekommst du im Log auch die Daten angezeigt, die das Programm an die HUE-Bridge sendet. Da sollte dann in etwa das da drinnen stehen: {"on":true, "bri": 255, "ct":300}
          Das kannst du ja mal direkt per Clip-API-Tester an die Bridge senden. Bei meiner Philips-Iris kommt dann eine entsprechende Fehlermeldung, weil die Lampe das nicht kann.
          Lösung bei mir: In der LoxApp die Lampe als "RGB" führen. Bei Auswahl am Temperatur-Regler wird dann ein RGB-Wert daraus gemacht (eine Gammutkorrektur ist so natürlich nicht möglich)

      • Hallo,

        mal etwas OT, aber hier im Thread sind bestimmt die Experten:

        Eine meiner Bulbs (Gen. 3 ) geht in unregelmäßigen Abständen einfach an. Ein Log gibt es laut Hotline nicht.

        Vom Support kam die Idee doch bitte in den Einstellungen der Bridge auf "Aufräumen" zu klicken. Natürlich konnte mir der Support nicht sagen, ob das Auswirkungen auf die API Schnittstelle hat und die Folgen.

        Meine Frage an euch. Kann ich bedenkenlos auf den Button drücken? Hat evtl. jemand noch eine Idee? Die Lampe war schon bei der Einrichtung etwas störrisch.

        Gruß

        Kommentar


        • Zitat von deepinpowder Beitrag anzeigen
          Hallo,

          mal etwas OT, aber hier im Thread sind bestimmt die Experten:

          Eine meiner Bulbs (Gen. 3 ) geht in unregelmäßigen Abständen einfach an. Ein Log gibt es laut Hotline nicht.

          Vom Support kam die Idee doch bitte in den Einstellungen der Bridge auf "Aufräumen" zu klicken. Natürlich konnte mir der Support nicht sagen, ob das Auswirkungen auf die API Schnittstelle hat und die Folgen.

          Meine Frage an euch. Kann ich bedenkenlos auf den Button drücken? Hat evtl. jemand noch eine Idee? Die Lampe war schon bei der Einrichtung etwas störrisch.

          Gruß
          Hier bei mir das gleiche Thema. Nur schalten sich bei mir alle HUE Lampen selbstständig ein...
          Loxone Miniserver
          Loxone AIR
          KNX
          KNX EnOcean Gateway

          Kommentar


          • Zitat von rcorten Beitrag anzeigen

            Hier bei mir das gleiche Thema. Nur schalten sich bei mir alle HUE Lampen selbstständig ein...
            Und wahrscheinlich auch keine Lösung .... mhhh.

            Gerade kam eine neue Software Version: 01038390 ....

            Ich sehe da keinen Zusammenhang mit dem Kanal, denn die Lampen reagieren ja.

            Hast du das mit dem Button "Aufräumen" probiert. Ich habe da etwas Angst, da man kein Backup der Hue machen kann.
            Zuletzt geändert von deepinpowder; 29.Mär.2017, 15:14.

            Kommentar


            • rcorten
              rcorten kommentierte
              Kommentar bearbeiten
              Ich habe es nun bei mir gelöst...

              Ich habe über das "My HUE Portal" mal alle "Vertrauensstellungen der Apps" gelöscht und siehe da. Die Lampen machen sich nicht mehr selbstständig. Vielleicht schwirrt bei Dir da auch die ein oder andere App rum.

              Was der Button "Aufäumen" alles macht, kann ich dir leider auch nicht sagen.

          • Hallo zusammen,

            ich benötige einmal eure Hilfe.

            Ich habe einen RGB Stripe mit der ID 16 inder HUE App. Habe ich die Konfiguration (Zuordnung) fehlerhaft? Leider reagiert der Stripe über Loxone nicht.

            Ich denke, dass ich die Zuweisung Eingang zu HUE ID falsch habe?!

            Vielen Dank für die Hilfe!
            Angehängte Dateien
            Loxone Miniserver
            Loxone AIR
            KNX
            KNX EnOcean Gateway

            Kommentar


            • rcorten
              rcorten kommentierte
              Kommentar bearbeiten
              Sorry, ich hatte den Anhang vergessen...

              Der Typ ist auf dem Screenshot auf 4 gesetzt. Ich habe es aber auch mit 0 versucht.
              Es handelt sich um einen LED Streifen mit einem HUE kompatiblen Vorschaltgerät. Über die HUE App kann ich den LED Streifen problemlos schalten.

            • Andreas Lackner
              Andreas Lackner kommentierte
              Kommentar bearbeiten
              Andere Lampen reagieren? Am Eingang AI12 liegt ein RGB-Signal an? Username und IP der Bridge passen?
              Dann bleibt dir nix übrig als Debugging einzuschalten und das Log anzusehen...

            • rcorten
              rcorten kommentierte
              Kommentar bearbeiten
              Vielen Dank für die Antworten. Ja, alle anderen Leuchten funktionieren einwandfrei. Ich werde mal den Debug Modus einschalten und schauen.

          • Es funktioniert. Ich habe den falschen Eingang genommen... Ich habe Eingang 11 gewählt, weil der ja so im Programm steht. Aber nicht beachtet, dass ja bereits von 0 gezählt wird...

            Danke für die Hilfe!
            Loxone Miniserver
            Loxone AIR
            KNX
            KNX EnOcean Gateway

            Kommentar


            • Hallo,

              ich habe meine Ambiance HUE Lampen mit dem Pico-C Skipt immer noch nicht zum laufen bekommen. Ich habe aber zum Glück auch FHEM auf meinem Server laufen, damit habe ich ein Workaround gefunden.
              Mit Radio Buttons und HTTP Virtual Output kann ich Scenes setzen, Analog Output vom Lighting Controller mit den Radiotasten verbinden, funktioniert super.
              Falls jemand mehr Infos braucht...Bescheid sagen

              Kommentar


            • Hallo Zusammen,

              In meiner Konfiguration schalte ich die Loxone Lichter mit Tastern an der Wand. In der Loxone Software möchte ich auch Taster zum Licht schalten haben, d.h. ich sehe nicht den Status ob die Lampe an oder aus ist. In weiterer Folge soll dann ein Tastendruck(Soft und Hardware) das Hue Light mittels Hue API abdrehen wenn es aufgedreht ist bzw. umgekehrt. Vorteil wäre nun, dass Änderungen am Licht durch externe Apps keine Inkonsistenzen in Loxone verursachen. Auch umgekehrt wird der Status in den Apps richtig dargestellt. D.h. Licht Ein/Aus wäre synchronisiert. Genauso möchte ich ein Hue White Ambient Licht mit dem Wandtaster in der Helligkeit dimmen können, wieder per Hue Api d.h. hier müsste man wieder den Dimmstatus auslesen und ausgehend von dem Wert dann entweder auf oder ab Dimmen. Aus der Loxone iOS app heraus muss ich nicht dimmen können. Nebenfrage: Kann man eigentlich in der Loxone iOS app links erstellen die dann im IOS andere Apps öffnen z.B. Philips HUE?

              Die Lichter haben immer Stromversorgung und werden nur mittels hue api gesteuert.

              So wie ich diesen Thread verstanden habe kann der picoC Baustein keine Werte von Hue Lampen auslesen weil es in Loxone nicht möglich ist Stati von Schaltern zu ändern. Oben beschriebener Anwendungsfall würde bedingen das vor dem setzen von hue api "on" auf true oder false der status der Lampe ausgelesen wird um dann den korrekten entgegengesetzten Befehl senden zu können(Wenn Licht on:false then set on:true - wenn licht on:true then set on:false) Wäre doch ein Sinnvoller Anwendungsfall, oder? Wäre oben beschriebener Anwenungdsfall mit dem PicoC Script realisierbar? Ich habe leider keine Programiererfahrung aber meines Erachtens müsste das doch relativ einfach realisierbar sein?

              Wäre eine Umsetzung dieses Konzepts eurer Meinung nach auch ohne PicoC script mir mit virtuellen ein und Ausgängen möglich? Habe bisher nur an der Loxone Config Oberfläche gekratzt und will nur abchecken ob sich ein tieferes eintauchen in Richtung dieses Konzeptes lohnt oder obs hier grundsätzliche Probleme gibt die ich nicht kenne.

              Wäre das eurer Meinung nach eine sinnvolle Anwendung oder übersehe ich hier irgendetwas und das ganze macht eh keinen Sinn?

              Ich hoffe dieser Kommentar passt in diese Diskussion. Wenn nicht bitte sagen dann mach ich einen neuen Thread auf - Danke.

              Danke auch für eure Kommentare,
              Grüße,
              Stefan

              Kommentar

              Lädt...
              X