Ankündigung

Einklappen

INFORMATION

Dieser Bereich ist für fertige Lösungen gedacht. Nutze bitte für Diskussionen die anderen Bereiche.
Mehr anzeigen
Weniger anzeigen

Phillips HUE mit Loxone verwenden

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Hmm, ich möchte halt die RGBW Spots zeitnah ansprechen, wenn man im TV Modus ist. 10x pro Sekunde mag etwas viel sein, die Praxis wird's wohl zeigen, was für Werte da am besten passen...
    Loxone: 1xMS, 2xExt, 2xRelay, 1xDimmer, 1xMulti Extension Air
    Tree: 10xTouch, 8xBWM, 8xStellantrieb
    Air: 5xRauchmelder, 9xRGBW Dimmer, 2xRemote, 1xNanoIO, 1xBWM, 2xSmart Socket
    Audio: Music Server 8 Zonen + 1xVerstärker (12 Ausgänge)

    KNX: 2xGira Tastsensor 3 Komfort, 2xGira Bewegungsmelder Unterputz
    Internet: Ubiquiti Unifi Security Gateway (100MBit VDSL2 T-COM / 100MBit Unitymedia)
    Netzwerk: Ubiquiti Unifi Switch 24 (LAN) + 4xUnifi AP AC PRO (WLAN)
    Speicher: Synology DS416j (4x6TB, Raid5)

    Kommentar


    • Besteht die möglichkeit den Bewegungsmelder von Philips Hue mit Loxone zu nutzen ?

      Kommentar


      • Andreas Lackner
        Andreas Lackner kommentierte
        Kommentar bearbeiten
        Theoretisch ja. Dazu müsste die Bridge in kurzen Abständen via http abgefragt werden. Das ist weder für die Lox noch für die Bridge von Vorteil...
        Wenn du mit geringen Abfrage-Frequenzen (<1Hz) arbeiten kannst, würde ich eine RaspberryPi oder ähnliches verwenden, der die Hue abfragt und bei Bedarf die Lix über eine Statusänderung informiert.

    • ich bin leider immernoch am probieren mit den Lightify GU10 RGBW. Hat einer von euch diese Lampen am laufen und kann problemlos Farben wechseln und dimmen über Loxone? Mich würde mal die Programmierung dazu interessieren. Wenn ich z.B. dimme kommt am Ende rot bei raus, soll heißen ich bekomme das Standard Warmweiss nicht gedimmt im gleichen Farbton. :-(
      Gruß
      neonnt


      MS, 2 Extensions, Tree-Extension, 1-Wire Extension, Enocean Extension, S0 Zähler, Loxberry + Homebridge + HA-Bridge + FHEM, DS1400 + Netatmo Wetterstation, Echo Dot, Hue Bridge v2, VU+ Solo2 und noch einige RPi + Arduino

      Kommentar


      • Andreas Lackner
        Andreas Lackner kommentierte
        Kommentar bearbeiten
        Hast du die aktuellste Variante vom Code in Verwendung? Welchen Inputtype verwendest du? Welcher Wert liegt am Eingang des Programmbausteins an? Ist der Debugmodus aktiviert? Kommando schon per CLIP getestet?

        Die Type muss 0 oder 4 sein, am Eingang muss ein Lumitech-Wert anliegen (2.....), im Log kommt dann
        "Light 1 ON 60% 6500K". Wenn du DEBUG_LEVEL > 1 hast, dann kommt auch noch das Kommando im Log: {"on":true, "bri": 60, "ct": 370}
        Das Kommando kannst du ja mal im CLIP testen (wie das geht, steht unter https://developers.meethue.com/docum...etting-started), damit du siehst, ob deine Lampe das Kommando mag.
        Zuletzt geändert von Andreas Lackner; 05.Dez.2016, 10:13.

      • neonnt
        neonnt kommentierte
        Kommentar bearbeiten
        Danke für die Infos :-)

        Die aktuellste Variante habe ich.
        Inputtype ist derzeit 3, dann werde ich das mal auf 6 ändern, das sollte ja wie 4 sein, nur für Gruppen.
        Wegen dem Eingangswert muss ich morgen mal schauen.
        Debug ist an.
        Clip habe ich noch nicht getestet, FHEM und Homebridge können die Lampen aber problemlos ansteuern. Nur das mit den Farben geht immer schief.

      • Andreas Lackner
        Andreas Lackner kommentierte
        Kommentar bearbeiten
        inputType 3 oder 6 macht bei der Ansteuerung der Weisswerte (also Brightness/Colortemp) keinen Unterschied.

    • verwendet Ihr die Hue Lampen zufällig auch in Verbindung mit dem Baustein "Treppenlichtschalter"?
      Wir möchten im Flur gerne unsere 3 Spots nach Einschalten max. 3 Minuten an lassen.
      Aktuell haben wir den Gira-Tasterschalter über die Bausteine Tastschalter -> Mehrfachklick (1-fach auf + um unterschiedliche % Helligkeit durchzuschalten / 2-fach auf R um alle Lampen auszuschalten)

      Loxone Miniserver / 1-Wire Extension / Air Base Extension, Tree Extension / Dimmer Extension / Debian Server, Raspberry

      Kommentar


      • Andreas Lackner
        Andreas Lackner kommentierte
        Kommentar bearbeiten
        Was hat das jetzt mit HUE zu tun? Es ist ja völlig egal wie du zu dem Signal kommst, das du am Programmbaustein für die HUE-Bridge anlegst...

    • Hallo,

      ich bräuchte auch mal Hilfe von Experten. Ich bastel seit Stunden rum, aber irgendwie bekomme ich meine HUE-Leuchten nicht gescheit zum Leuchten. Ich habe zwei HUE E27 Lampen in einer Gruppe und das Skript entsprechend konfiguriert (lightOrGroupID[0] = 1;inputType[0] = 6. Mit dieser Konfiguration funktioniert das Einstellen verschiedener Farben über die Loxone-app problemlos (Ausgnag im Lichtbaustein als Lumitecheingestellt), sobald ich aber eine Farbtemperatur einstelle (Balken links in der App), hängt sich das Skript auf (Fehler im Log: 197:67--> variable lightID is undefined). Gleiche Fehlermeldung bekomme ich auch, wenn ich andere Gruppeneingangstypen verwende (3 oder 7), allerdings in einer entsprechend anderen Zeile des Codes. Eingangstyp 7 natürlich dann als Dimmer im Lichtbaustein konfiguriert.
      Das Programm ist ohne Merker direkt an den Lichtbaustein angebunden.
      Woran kann das liegen?

      Schonmal vielen Dank für die Unterstützung!

      Kommentar


      • Hallo,
        Die Fehlermeldung besagt, dass die Variable nicht definiert ist.
        Somit stimmt der Inhalt in deinem Programmblock nicht oder die Deklaration ist mittels // zu Beginn der Deklaration ausgeschaltet.
        Solltest Dir diese Info nicht weiterhelfen, wäre es sinnvoll wenn Du den Programmblock-Script hier reinstellen könntest. Deine persönlichen Einstellungen kannst Du ja vorher ändern.
        Zuletzt geändert von romildo; 27.Dez.2016, 21:42.
        lg Romildo

        Kommentar


        • Hallo,
          was ist der Unterschied zwischen RGB und Lumitech am Lichtbaustein? Aktuelle verwende ich den RGB-Ausgang und gebe diesen dann in das Skript.

          Gruß Lars
          Wohnhaus Baujahr 2013
          1x Miniserver; 5x Extensions; 4x Relay; 4x Dimmer; 1x 1-Wire; KNX-Sensorik
          Miniserver Go; Smart Socket Air; Bewegungsmelder Air; Tür- und Fensterkontakte Air; Touch Air
          Loxberry (Raspberry); Philips Hue

          Kommentar


          • Hallo romildo,

            danke für den Hinweis. Da ich nicht weiter wusste, habe ich vor ein paar Stunden den Code noch einmal frisch aus dem ersten Post kopiert, in den Programmbaustein eingefügt und keine Anpassungen außer der Konfiguration vorgenommen. Habe nach deinem Hinweis die Variable lightID und command oben im Code definiert...aber eigentlich werden die ja im Programm schon in der entsprechenden Funktion definiert. Nun gibts zumindest keine Fehlermeldungen mehr, die PUT Befehle werden auch geschrieben (z.B. Light 1 ON 35% 6345K) nur leider ist die Content lenght immer 0....
            Und nun?

            Edit: anbei noch ein Screenshot des logs und der Werte am Programmbaustein. Ich bekomms nicht hin. Die Werte müssten nach meinem Verständnis passen. Evtl. ein Fehler im Code?
            Angehängte Dateien
            Zuletzt geändert von mattgas; 28.Dez.2016, 01:23.

            Kommentar


            • romildo
              romildo kommentierte
              Kommentar bearbeiten
              So habe ich das eigentlich nicht gemeint. Du solltest nicht oben was einfügen.
              Im Code scheint irgendwo ein Fehler zu sein. Wo genau kann ich nicht sagen, da ich den Code nicht kenne.
              Welchen Code hast Du denn verwendet, in Post 1 gibt es 3 txt Files.
              Wenn Du den TeQ Ausgang beim Programmblock einblendest, kannst Du in der LiveView den Fehler sehen.

            • Gast-Avatar
              Gast kommentierte
              Kommentar bearbeiten
              Hab ich gerade mal ausprobiert....die von mir eingefügten Variablendeklarationen wieder rausgeschmissen (Code entspricht wieder dem des neuesten txt-files vom 10.11.2016). Am Ausgang steht nur tx, wenn ich mit der Maus über den Baustein fahre, wird der gleiche Fehler wie im log angezeigt: 196:67 variable lightID is undefined.

          • hier noch der Screenshot dazu.
            Angehängte Dateien

            Kommentar


            • Andreas Lackner
              Andreas Lackner kommentierte
              Kommentar bearbeiten
              Servus,

              also der Programmcode ist so wie er ist korrekt. Ich habe exakt den selben Code am Laufen wie du - und bei mir funktioniert's.
              Nachdem Pico-C eine Interpreter-Sprache ist, vermute ich mal einen Bug im Pico-C. Nachdem es sich bei der betroffenen Zeile um eine Debug-Ausgabe handelt, schmeiss die betroffene Zeile einfach mal raus.
              Noch ein Tip: Wenn sich die Loxone komisch verhält (und das hier zähl' ich jetzt mal dazu) ist's an der Zeit, die SD-Karte zu tauschen... kann jedenfalls nicht schaden.

          • Andreas Lackner
            Ich habe mal alle 3 Versionen aus #1 getestet.
            Config Version 8.1.11.11
            Ergebnis:
            Bei mir läuft auch nur die älteste Version.
            Bei der neuesten Version bekomme ich einen Fehler in Zeile 200 die Fehlermeldung ist ...command is undefined und zeigt auf die ).
            Der Verursacher ist aber in Zeile 196.
            Code:
            sprintf(command, "{\"on\": true, \"bri\": %d, \"ct\": %d, \"transitiontime\": %d}", briNorm, miredNorm, TRANSITION_TIME);
            Wenn ich die Zeile wie folgt abändere ist der Fehler weg.
            Code:
            sprintf(command, "{\"on\": true, \"bri\": %d, \"ct\": %d}", briNorm, miredNorm);
            Die Ursache konnte ich aber bisher nicht Ausfindig machen.

            Dies nur zur Info, möglicherweise kannst Du damit was anfangen.
            lg Romildo

            Kommentar


            • Gast-Avatar
              Gast kommentierte
              Kommentar bearbeiten
              Das wars! Mit der Anpassung im Code läufts nun auch bei mir! Danke romildo.

            • Andreas Lackner
              Andreas Lackner kommentierte
              Kommentar bearbeiten
              TRANSITION_TIME sollte ja eigentlich auch definiert sein (Zeile 20)... Pico-C ist ja echt zum Wahnsinnig werden...

            • romildo
              romildo kommentierte
              Kommentar bearbeiten
              Pico-C ist ja...........
              Da kann ich Dir nur recht geben.

              Bitte siehe #206

          • Andreas Lackner
            Ich habe jetzt etwas weiter gespielt.
            Bei der Lichsteuerung kommt bei "Alles ein" bei den Lumitech Ausgängen der Wert 201004600 an den Eingang des Programmbausteins.
            "Alles aus" bringt dann den Programmblock zum Absturtz.
            Möglicherweise hilft das etwas weiter.

            lg Romildo

            Kommentar


            • Andreas Lackner
              Andreas Lackner kommentierte
              Kommentar bearbeiten
              was liegt am Programmbaustein dann an?

            • romildo
              romildo kommentierte
              Kommentar bearbeiten
              Der Wert 201004600. Nach Aus der Wert 0
              Oder was meinst Du?

          • Hallo zusammen,

            meine erste wirkliche Programmierung in Loxone war nun also die Einbindung der Hue und was soll ich sagen: Gestern Abend begonnen und heute Mittag nach Lesen in diesm Thread, auf der Loxone-Web und parallel die Tutorials auf dem Fernseher läuft es!!! Ich bin total glücklich und danke allen, die hier in den letzten (fast) zwei Jahren ständig anderen geholfen haben. Super von euch *thumbup*

            Beste Grüße
            Dirk

            Kommentar


            • Hallo zusammen,

              meine erste wirkliche Programmierung in Loxone war nun also die Einbindung der Hue und was soll ich sagen: Gestern Abend begonnen und heute Mittag nach Lesen in diesm Thread, auf der Loxone-Web und parallel die Tutorials auf dem Fernseher läuft es!!! Ich bin total glücklich und danke allen, die hier in den letzten (fast) zwei Jahren ständig anderen geholfen haben. Super von euch *thumbup*

              Beste Grüße
              Dirk

              Kommentar


              • Hello,

                Eine Frage zum Punkt "Eine Rückmeldung der Zustände von HUE in die Loxone ist nicht möglich."
                Es ist mir aufgefallen, dass FHEM merkt ob eine Lampe an oder aus ist, auch wenn es mit dem App oder Dimmer geschaltet wird. Veilleicht nicht sofort aber innerhalb von Sekunden.
                Hat jemand versucht per Virtual Eingang den Signal von FHEM zum MS zu schicken?
                Ich weiss nicht warum es nicht gehen sollte...

                Kommentar


                • Das Problem ist nicht die Statusrückmeldung, das Problem ist die Umrechnung der Farben. Loxone nutzt strickt RGB HUE HSB oder xyB. Eine Umrechnung zwischen diesen ist nicht "verlustfrei" möglich, was zu permanent wechelnden Farben führen würde.
                  Miniserver; KNX; Vitogate; EnOcean (EnOceanPi); Loxone Air; Caldav-Kalenderanbindung; RaspberryPi und für keine Frickellösung zu schade :-)

                  Kommentar


                  • okenny
                    okenny kommentierte
                    Kommentar bearbeiten
                    ah, ok, danke!
                    Aber für Szenen an oder aus würde es gehen, oder?

                  • svethi
                    svethi kommentierte
                    Kommentar bearbeiten
                    Was für eine Szene? In der Loxone Lichtsteuerung?
                    Na überlege mal. Die Szene wird über einen RGB-Wert dargestellt, diesen kannst Du nicht zu 100% mit dem HUE-Farbwert vergleichen. Daher kannst Du nie genau wissen, welche Szene an ist.

                  • okenny
                    okenny kommentierte
                    Kommentar bearbeiten
                    ja, okay danke.
                    Ich soll damit rumspielen, veilleicht krieg ich irgendetwas sinnvolles hin.
                Lädt...
                X