Ankündigung

Einklappen
Keine Ankündigung bisher.

WLED Projekt

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • #46
    Ich bin mir bei der Stromversorgung noch nicht ganz sicher, vielleicht könnt ihr mir weiterhelfen....

    Ich möchte einen 5m Stripe mit 60 Led/m installieren.
    Demnach hätte ich 300 Led's und 18A.

    1. Kann mir jemand ein 5V 18A Netzteil empfehlen?
    2. In eurer Anleitung schreibt ihr alle 2,5m sollte man einspeisen. Reicht es dann, wenn ich am Anfang und in der Mitte einspeise oder muss ich am Ende vom Stripe auch nochmal einspeisen?
    3. Den Kondensator setze ich bei jeder Einspeisung, richtig?

    Danke und Gruß
    Stefan

    Kommentar


    • pmayer
      pmayer kommentierte
      Kommentar bearbeiten
      Bei 5m reicht einfach von beiden Seiten einspeisen.
      Ich hab mit den Netzteilen von MeanWell in dem Bezug gute Erfahrungen gemacht.
      Die 18,4 brauchst du wirklich nur, wenn die 100% weiß, also R+G+B, an hast - natürlich sollte das Netzteil aber passend ausgelegt sein. Bei Effekten oder Segmenten brauchst du ja immer nur den Strom der LED's die grade an sind.

      Im Webinterface von WLED kann man die maximale Stromaufnahme einstellen. Wenn du also nur ein 10A Netzteil hast, berechnet WLED den nötigen Gesamtstrom anhand der eingestellten Pixelanzahl und begrenzt die Gesamthelligkeit.

  • #47
    Also könnte ich auch ein 10A Netzteil nehmen, wenn dann mehr als 10A benötigt werden ist die Helligkeit begrenz, richtig?

    Wieviel Amper hat dein Netzteil?
    Bei Meanwell finde ich nur Einbaunetzteile die 20A haben.

    Wollte aber lieber so etwas:
    https://www.reichelt.de/led-trafo-60...t=pol_11&nbc=1

    Habe mir übrigens gerade einen Controller und zwei Kondensatoren bestellt

    Kommentar


    • pmayer
      pmayer kommentierte
      Kommentar bearbeiten
      Japp, richtig. Muss man nur passend im WLED einstellen
      Hier haben wir 6 x 10A verbaut: https://allgeek.de/2018/01/29/esp826...el-controller/
      Das 12A da sieht doch gut aus.

      Danke, Bestellung wird gerade verpackt.

    • Drunkard
      Drunkard kommentierte
      Kommentar bearbeiten
      Würden sich denn die fehlenden 6A bemerkbar machen? Oder macht das keinen großen Unterschied?
      Ansonsten könnte ich ja auch 2 Netzteile mit je 10A nehmen.

    • pmayer
      pmayer kommentierte
      Kommentar bearbeiten
      Naaa, das weiß ist schon um einiges dunkler. Kommt aber da auch wieder auf den Stripe an.
      Frage ist eben ob du in deiner Anwendung 100% weiß oft brauchst.

  • #48
    Könnt ihr nicht mal ein paar Pakete zusammenstellen, sodass Elektrolaien es einfach bestellen können :-)
    • LED-Stripe 5m IP67
    • Netzteil(e) 20A?
    • WLAN-Modul von cod.m
    • ggf. Kann pmayer direkt einen Link auf Amazon machen in seinem Shop und noch Provision abgreifen.
    • Braucht man noch mehr? Aderendhülsen? Kabel?

    Die Verbindung von Netzteil und Stripe sieht kompliziert aus. Bei einigen Netzteilen steht immer NUR VON ELEKTRIKERN anzuschließen.
    Ich würde ein Paket zum Spielen gerne mal bestellen
    Node-RED mit influxDB und Grafana - z.B. Statistiken auslagern:
    https://www.loxforum.com/forum/germa...d-grafana-visu
    Mit Loxone einen Windows-PC steuern:
    https://www.loxforum.com/forum/faqs-...indows-steuern

    Kommentar


    • pmayer
      pmayer kommentierte
      Kommentar bearbeiten
      Ich versuche schon seit Wochen Kontakt zu nem chinesischen Hersteller von Stripes aufzunehmen... die sitzen mom aber auf ihren Ohren.

      Die Stripes haben teilweise ne Hohlsteckerbuchse und für kurze Längen reicht dann ein Steckernetzteil.

    • Clubsport
      Clubsport kommentierte
      Kommentar bearbeiten
      @Xenobiologist: Da ist irgendwie auch was dran. Mit 220V sind halt leider nicht zu spaßen.

    • verdammt
      verdammt kommentierte
      Kommentar bearbeiten
      super Idee hier das pmayer ,sowas müsste unbedingt mal in den Shop.

  • #49
    In meinem LOXpixel Weihnachtsdeko Test aus dem letzten Jahr findest du im Beitrag unten den verwendetenbund von mir empfohlenen LED Streifen sowie ein Netzteil das für 5M Stripe ausreicht.

    https://unser-smartes-zuhause.de/201...chtsdeko-test/

    Kommentar


    • #50
      Okay, dann mache ich mal einen Versuch:

      Für einen "Spiel"-betrieb von z.B. 5m LED-Streifen mit IP67 im Außenbereich mit Anschluss an eine normale Schukosteckdose:

      Diese Liste sollte für jeden pflegbar sein: https://www.amazon.de/hz/wishlist/dl...?ref_=wl_shareBraucht man das auch? https://shop.codm.de/automation/pixe...apacitor-board

      Wie schließt man das alles an, ohne das es nach Bastelkeller aussieht? Wagoklemmen? Das Netzteil hat keinen Stecker. Muss man noch einen Stecker anschließen
      Wäre so etwas nicht besser für Nicht-Elektriker? https://www.amazon.de/gp/product/B06...?ie=UTF8&psc=1

      Fragen über Fragen
      Zuletzt geändert von Xenobiologist; 19.Nov.2020, 19:41.
      Node-RED mit influxDB und Grafana - z.B. Statistiken auslagern:
      https://www.loxforum.com/forum/germa...d-grafana-visu
      Mit Loxone einen Windows-PC steuern:
      https://www.loxforum.com/forum/faqs-...indows-steuern

      Kommentar


      • VaniX
        VaniX kommentierte
        Kommentar bearbeiten
        Hi, das ist jetzt aber ein 12V Netzteil mit 5V Stripes?
        Ich habe aktuell das Meanwell LPV-100-5
        Wago 221 sind top! Evtl. mit Wago Gelbox, habe ich aber selber noch nicht getestet
        Zuletzt geändert von VaniX; 18.Nov.2020, 18:08.

      • Xenobiologist
        Xenobiologist kommentierte
        Kommentar bearbeiten
        Dann muss ich gleich am Laptop den Link auf dies ändern: https://www.amazon.de/dp/B00S9OTJYC/..._0IvTFbZZ814NV

      • Xenobiologist
        Xenobiologist kommentierte
        Kommentar bearbeiten
        Ihr dürft die Liste bei Amazon gern optimieren/erweitern. :-)

    • #51
      Falls euch WLED Projekte nicht ausreichen.
      Next Level https://youtu.be/BmE5Sps-sjI
      😇


      Gesendet von iPhone mit Tapatalk
      Node-RED mit influxDB und Grafana - z.B. Statistiken auslagern:
      https://www.loxforum.com/forum/germa...d-grafana-visu
      Mit Loxone einen Windows-PC steuern:
      https://www.loxforum.com/forum/faqs-...indows-steuern

      Kommentar


      • t_heinrich
        t_heinrich kommentierte
        Kommentar bearbeiten
        Krass!!

      • Xenobiologist
        Xenobiologist kommentierte
        Kommentar bearbeiten
        Damit den Weihnachtsmann an den Himmel bringen, und du bist der Star der Stadt :-)

    • #52
      Zitat von Xenobiologist Beitrag anzeigen
      Falls euch WLED Projekte nicht ausreichen.
      Next Level https://youtu.be/BmE5Sps-sjI
      😇


      Gesendet von iPhone mit Tapatalk
      Nehme ich (-;

      Kommentar


      • #53
        Hallo zusammen,

        kann mir hier evtl. jemand helfen? Im WLED-Forum hält sich die Reaktion eher in Grenzen.....
        Ich kopiere mal der Einfachheit halber mein Posting hier rein:

        When I was in “Breeze” and want to switch to “Candle”, I have to switch it off between both commands by /win&T=0 . Otherwise, “Candle” will only flash shortly and directly go back to “Breeze”.
        The other way, from “Candle” to “Breeze”, i got really strong flashing and strobe light from all LEDs.

        Attached are my commands for :

        Candle:

        {“on”:true,“bri”:,“transition”:7,“ps”:-1,“pss”:49152,“pl”:-1,“ccnf”:{“min”:1,“max”:5,“time”:12},“nl”:{“on”:fa lse,“dur”:15,“fade”:true,“mode”:2,“tbri”:120},“udp n”:{“send”:false,“recv”:true},“lor”:0,“mainseg”:1, “seg”:[{“id”:1,“start”:0,“stop”:12,“len”:12,“grp”:1,“spc” :0,“on”:true,“bri”:255,“col”:[[255,160,0],[0,0,0],[0,0,0]],“fx”:88,“sx”:109,“ix”:110,“pal”:0,“sel”:true,“rev ”:false,“mi”:false},{“id”:2,“start”:12,“stop”:24,“ len”:12,“grp”:1,“spc”:0,“on”:true,“bri”:255,“col”:[[255,160,0],[0,0,0],[0,0,0]],“fx”:88,“sx”:109,“ix”:111,“pal”:0,“sel”:false,“re v”:false,“mi”:false},{“id”:3,“start”:24,“stop”:36, “len”:12,“grp”:1,“spc”:0,“on”:true,“bri”:255,“col” :[[255,160,0],[0,0,0],[0,0,0]],“fx”:88,“sx”:114,“ix”:119,“pal”:0,“sel”:false,“re v”:false,“mi”:false}]}

        Breeze:

        {“on”:true,“bri”:,“transition”:7,“ps”:-1,“pss”:49152,“pl”:-1,“ccnf”:{“min”:1,“max”:5,“time”:12},“nl”:{“on”:fa lse,“dur”:15,“fade”:true,“mode”:2,“tbri”:120},“udp n”:{“send”:false,“recv”:true},“lor”:0,“mainseg”:1, “seg”:[{“id”:2,“start”:1,“stop”:0},{“id”:3,“start”:1,“sto p”:0},{“id”:1,“start”:0,“stop”:36,“len”:36,“grp”:1 ,“spc”:0,“on”:true,“bri”:255,“col”:[[255,160,0],[0,0,0],[0,0,0]],“fx”:65,“sx”:10,“ix”:110,“pal”:15,“sel”:true,“rev ”:false,“mi”:false}]}


        Im Anhang noch ein paar Screenshots meiner Config. Ich habe die Probleme sowohl bei einem mit WLED geflashten Wemos D1 mini, als auch beim Pixel Controller von cod.m - schließe die Hardware eigentlich daher aus.

        Wäre schön, wenn mal einer drauf guckt, ich finde den Fehler einfach nicht....

        Danke & Grüße,

        Martin

        Angehängte Dateien

        Kommentar


        • #54
          pmayer : Welches Environment hast du im Platformio verwendet? Ich habe nämlich das Problem, dass ich die selbst gebaute Firmware nicht über das Webinterface updaten kann. Bei mir stoppt das Update mit "Failed updating firmware" "Please check your file and retry".
          Ich erzeuge das bin über das Environment "codm-controller-0.4". Das sollte doch passen oder?

          Kommentar


          • pmayer
            pmayer kommentierte
            Kommentar bearbeiten
            Japp. 0.5 war quasi die Zwischenversion zur 0.6 mit dem selben Pinout 👍

          • Hannes Schellnast
            Hannes Schellnast kommentierte
            Kommentar bearbeiten
            Eine Frage hab ich noch:
            Wenn ich die Status LED in Version 0.4 u. 0.6 vergleiche, dann hängt diese LED in beiden Versionen auf IO12 (Pin 4). Das hat aber nichts mit dem Buildflag LEDPIN=3 zu tun, oder?

          • pmayer
            pmayer kommentierte
            Kommentar bearbeiten
            Nein, der LEDPIN ist der für den Stripe. Bei 0.6 GPIO2 wie Standard bei WLED.
            GPIO12 ist unsere Status-LED, die leider gerade noch keine Funktion hat: https://github.com/Aircoookie/WLED/issues/841

        • #55
          Danke für eure ganzen Mühen!

          Das Projekt ist wirklich super Damit kann man schon einiges machen

          Sind WS2812b 5 V LED Streifen um die Dachkante und das Carport, der Rest sind WS2811 Pixel. Gesteuert wird das Ganze von 5 Wemos D1 Mini mit der aktuellsten WLED - Version

          Die Sequenzen sind mit XLights erstellt, und auf einem Raspberry PI läuft die FPP - Software, auf der die XLights-Sequenzen dann gespeichert sind und der dann zu festgelegten Zeiten das Ganze startet

          https://youtu.be/gWSIlCRoyPo
          Zuletzt geändert von RiverRaid; 14.Dez.2020, 12:42.

          Kommentar


          • Lightpicture
            Lightpicture kommentierte
            Kommentar bearbeiten
            Coole Sache, super umgesetzt.
            Da würden die Amis vor Neid erblassen!

          • Hannes Schellnast
            Hannes Schellnast kommentierte
            Kommentar bearbeiten
            Cool!!!

          • Duffy
            Duffy kommentierte
            Kommentar bearbeiten
            Wow sehr toll umgesetzt, wäre interessiert an genaueren Infos wie du das genau umgesetzt hast. Würd auch gern so was ähnliches verwirklichen für mein Gartenhäuschen.

        • #56
          Ich muss leider sagen, was die Idee von WLED angeht - fantastisch!
          Was die Dokumentation, eventuelle Fallstricke und die Hilfe im Forum angeht... Verbesserungswürdig.
          Grad das hantieren mit Segmenten erzeugt aus meiner Sicht immer wieder nicht rekonstruierbares Verhalten.
          Bedienung über die Web-UI als Spielerei fürs Handy - tolle Sache! Einbindung ins Smarthome - sehr umständlich und aus meiner Sicht nicht "durchsichtig", warum etwas was wie funktioniert oder auch nicht funktioniert..... Ist man irgendwie bessere Umsetzungen (Loxberry und seine Plugins! ) gewohnt.

          Dies ist explizit KEINE Wertung des cod.m-Pixelcontrollers, die Hardware läuft anstandslos und einwandfrei!

          Grüße, Martin

          Kommentar


          • #57
            Kann mir jemand was zur WLAN Reichweite des Controllers sagen? Im Haus habe ich keine Probleme, sobald ich nach draußen gehe ist das Teil offline. Stehe 2m neben der Fritzbox getrennt von einer Hauswand. Das sollte doch gehen oder?

            Kommentar


            • #58
              Ich habe im Herbst am Zugang zum Haus gearbeitet, und bei dieser Gelegenheit 2 Stück der Pixelcontroller in die Gabionenbeleuchtung eingearbeitet. In der Gabione liegt eine Schicht Glasbrocken, die das Licht der selbstgebauten wasserdichten Leuchten sehr gut brechen. Sieht real noch viel besser aus, als auf den Bildern. Auch die Lichtfarbe kann ideal auf die restliche Beleuchtung abgestimmt werden.
              Als zusätzliches Feature habe ich für die Pixel Controller Software noch ein Plugin geschrieben, welches mir bei Bewegung UDP Messages von den selbstgebauten wasserdichten Bewegungsmeldern an den Miniserver schickt. Pro Gabione ist ein Bewegungsmelder eingebaut, damit die Lichter auch selektiv geschalten werden.

              Klicke auf die Grafik für eine vergrößerte Ansicht  Name: Leuchtenteile_beschriftet.jpg Ansichten: 0 Größe: 1,50 MB ID: 279756Klicke auf die Grafik für eine vergrößerte Ansicht  Name: Zugang.JPG Ansichten: 0 Größe: 2,00 MB ID: 279757
              Klicke auf die Grafik für eine vergrößerte Ansicht

Name: WebInterface.jpg
Ansichten: 767
Größe: 113,9 KB
ID: 279759

              Im folgenden Link habe ich noch versucht ein paar Lichteffekte einzufangen. Real wirken die Effekte aber viel besser als im Video.
              https://www.youtube.com/playlist?lis...N8VWqStzDtXpav
              Angehängte Dateien
              Zuletzt geändert von Hannes Schellnast; 14.Dez.2020, 20:49.

              Kommentar


              • kei
                kei kommentierte
                Kommentar bearbeiten
                Mega stark, gefällt mir sehr.
                Hättest du Infos oder einen Link, wo man die Teile für die runden Gehäuse bestellen kann?
                Zuletzt geändert von kei; 17.Dez.2020, 12:58.

              • Hannes Schellnast
                Hannes Schellnast kommentierte
                Kommentar bearbeiten
                @kei: Die runden Gehäuse sind nichts anderes als Alurohre, die mit einem Lamellenstopfen verschlossen worden sind. Um bei der Dichtigkeit noch ein wenig nachzuhelfen, ist an den Lamellen noch ein wenig Silikonfett aufgetragen. Die transparenten bzw. satinierten Teile sind Acrylglas. Beim satinierten Akrylglas habe ich an der Stelle des Stopfens die Oberfläche noch glatt poliert, damit das ganze wirklich dicht ist.
                Die LEDs selbst habe ich auf einem Alurohr (zur besseren Wärmeableitung) befestigt, und anschl. in das satinierte Rohr gegeben, und mit den Stopfen verschlossen. Zum Anschluss der Kabeln habe ich hier IP68 Kabeldurchführungen angebracht.
                Falls es dich interessiert, kann ich dir hier noch mehr Bilder zeigen.

            • #59
              Ich habe mir die WLED Software jetzt auch mal auf ein paar H801 PWM Controller installiert. Dabei ist mir aufgefallen dass die Umsetzung für Loxone aus meiner Sicht nicht so 100%ig ist:
              Wenn man über LX=... die Farbe setzt, wird automatisch der Weisskanal auf 0 gesetzt. Da ich den weissen Kanal getrennt ansteuern möchte funktioniert das so nicht. Daher habe ich die entsprechende Zeile in der Funktion "bool parseLx(int lxValue, byte rgbw[4])" auskommentiert. Jetzt passt es aus meiner Sicht.
              Oder ist das Verhalten so extra gewollt ?

              Ansonsten muss ich sagen ist die Software echt super. Jetzt muss ich das nur auch ncohmal an ner Pixelkette ausprobieren, bin schon gespannt.

              Kommentar


              • #60
                Ich habe da noch ein Problem:

                Wenn ich über Loxone zu schnell / oft hintereinander Befehle an einen H801 Controller mit der WLED Software schicke, z.B. indem ich in der App am Farbwähler herum ziehe und somit immer wiede neue Farben auswähle, hängt der Controller sich auf. Ich kann nicht sagen ob nur das W-Lan die Verbindung verliert oder ob der Controller komplett neu startet.

                Hat noch jemand solche Probleme ?
                Angebunden habe ich das per MQTT...

                Wie steuert ihr den Controller eigentlich an ?
                Ich habe das bei mir mit nem Statusbaustein gemacht, allerdings wird ja dann auch jedes mal &T=1 mit geschickt, was ja an sich auch ein Befehl ist den der Controller verarbeiten muss, auch wenn der schon ein ist....

                Gruß

                Kommentar


                • Chris8519
                  Chris8519 kommentierte
                  Kommentar bearbeiten
                  per udp solltest du keine probleme haben

                • pmayer
                  pmayer kommentierte
                  Kommentar bearbeiten
                  Mit UDP, wie Chris sagt, oder per MQTT QOS 0 sollte das gehen. Ich nehme für MQTT node-red-contrib-loxone, nicht die picoC-Implementation.
              Lädt...
              X